Issue 67967 - New words not added to standard.dic if new doc not saved
Summary: New words not added to standard.dic if new doc not saved
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Internationalization
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.3
Hardware: Mac Mac OS X, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: jjmckenzie
QA Contact: issues@l10n
URL:
Keywords: oooqa, usability
Depends on:
Blocks: 69308
  Show dependency tree
 
Reported: 2006-07-31 07:24 UTC by padmavyuha
Modified: 2008-12-19 09:26 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
spell check Add button (126.79 KB, image/png)
2006-09-07 05:16 UTC, sparcmoz
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description padmavyuha 2006-07-31 07:24:08 UTC
If you create a new doc (e.g. in Calc or Writer), type some words into it, and add words the spellchecker 
doesn't recognise to the standard.dic user dictionary, then standard.dic does not get updated with the new 
words if you don't save the new doc.
So if you decide to chuck the new doc and try again later, you'll have to re-add the new words to the 
dictionary all over again. OOo 2.0.3-Windows saves the data, but OOo 2.0.3-OSX/X11 does not.
Comment 1 padmavyuha 2006-07-31 07:25:17 UTC
Sorry, should probably be Enhancement, not defect.
Comment 2 padmavyuha 2006-07-31 07:39:58 UTC
In case this saves time, the procedure I used to confirm this is:
i) create a new doc
ii) type in a few words, including one the spellchecker doesn't recognise, e.g. autochthon
iii) right-click on the word, save to standard.dic
iv) close the new doc without saving it
v) quit OpenOffice completely (in Winxx, exit the QuickStart - in OSX, quit OOo and then quit X11)
vi) open standard.dic in a text editor
in Winxx, autochthon has been added to standard.dic - in OSX it hasn't.
If you save the new doc in (iv), autochthon appears in standard.dic on both platforms.
Comment 3 Olaf Felka 2006-07-31 08:20:00 UTC
I can't see this as an 'enhancement'. It should work on all platforms.
Comment 4 padmavyuha 2006-07-31 08:25:17 UTC
Okay - a category misunderstanding on my part.
Comment 5 michael.ruess 2006-07-31 09:53:36 UTC
I cannot reproduce the issue on Windows or Linux - it seems limited to Mac OS
port. But if it really occurs as described above, it is clearly a defect and not
an enhancement. A feature does not work as promised -> bug!
Comment 6 pavel 2006-08-01 12:25:53 UTC
James: can you please verify this issue?
Comment 7 michael.ruess 2006-08-01 13:01:02 UTC
Removing mru from cc.
Comment 8 cbrunet 2006-08-01 15:07:06 UTC
Cannot reproduce on OOo 2.0.3FR. Mac OS X 10.3.9 PPC.
Comment 9 jjmckenzie 2006-08-02 03:50:49 UTC
@pjanik:

Not here on the Intel build.  Will check PPC build soon.

Was able to add the misspelled gobbledegook and have it come up as a suggested
correction to goobledegook (correct spelling: gobbledygook.)

en_US 2.0.3 rc 7.

James M
Comment 10 padmavyuha 2006-08-02 06:19:07 UTC
In case it's it's relevant, my installation is:

*en_GB* OOo 2.0.3r7 PPC (on OSX 10.4.7)

Sorry, I should have specified that earlier.

- padmavyuha
Comment 11 jjmckenzie 2006-08-02 15:31:40 UTC
That might explain it.  I was testing with *en_US*.
And I was not able to repeat this error with either the PPC or Intel releases.

James M.
Comment 12 jjmckenzie 2006-08-03 04:56:48 UTC
@pjanik:

Needs to be assigned to en_GB NL lead.  This is another issue for that team.

James M.
Comment 13 pavel 2006-08-11 18:35:40 UTC
James: why?

Have you reproduced the problem with en-GB version as well?
Comment 14 jjmckenzie 2006-08-11 18:45:56 UTC
@pjanik

Have you confirmed/denied this fault exists in any of your 2.0.3 builds?  I 
could not confirm this with the en_US build and the reporter advised using the 
en_GB build.

James M.
Comment 15 jjmckenzie 2006-09-07 04:28:32 UTC
Added 2.0.4 tracker issue as this issue blocks release of this version.

James M.
Comment 16 sparcmoz 2006-09-07 05:14:59 UTC
padmavyha: You mention the procedure in Windows is "right click on the word". What is the procedure in 
Mac OSX where I have no right button to click. Please describe exactly the procedure on OS X, as I can not 
reproduce the problem using the normal spellcheck dialog. 

Also please have a close look at the Add button in the attached screenshot. This is on Mac OS X. Does it 
appear different on Windows? When the Add button is pressed then a new button appears below, labelled 
standard[All], this button has to be pressed too. (I usually forget to press the second time although I know 
about it!).

Using the spellcheck dialog the problem is not seen in 2.0.3 or 2.0.4 680m2 (9064) maho build.
Comment 17 sparcmoz 2006-09-07 05:16:30 UTC
Created attachment 39011 [details]
spell check Add button
Comment 18 padmavyuha 2006-09-07 09:52:16 UTC
In OpenOffice OSX (X11) the equivalent of right-click without a 2-button mouse is cmd-click - this calls 
up the contextual menu which, when the cursor is on a word with the 'spell squiggle' underlining, includes 
the spelling suggestions and the Add submenu option, which generally consists of just the standard.dic 
option. Click on this to add to the dictionary. This is how I add items to the dictionary, it's more direct 
than the approach you described, which I've never tried (sounds like a lot of clicks!)

I can confirm that using OSX (X11) v2.0.3 final (En_US) with the English (UK) dictionaries installed, I don't 
get this bug. As I can find no v2.0.3 final En_GB version to test, I don't know whether this bug still exists in 
that package. If you can point me to a url for downloading an En_GB version I'll test it.

Comment 19 padmavyuha 2006-09-07 09:54:27 UTC
(The 'adding to dictionary' approach I described just now involves having Auto Spell Check turned on so I 
can add spellings on the fly, in case that's not apparent.)
Comment 20 sparcmoz 2006-09-07 10:31:22 UTC
padmavyuha: thank you for the explanation, and yes - I had the Auto turned off ;) 
I can follow the same procedure you described, but I do not see any error.  The new word is added in the 
dictionary although the document was not saved. I have en_GB version, many language versions are here:  
ftp://ooopackages.good-day.net/pub/OpenOffice.org/MacOSX/OOD680_m2/
Comment 21 padmavyuha 2006-09-07 11:21:22 UTC
Okay, I'll d/l that and test it out.
Comment 22 jjmckenzie 2006-09-08 15:34:51 UTC
@all

m2 has been withdrawn and rc1 released.  Directory is 2.0.4rc1_20060906 vice 
OOD680_m2.

James McKenzie
Comment 23 padmavyuha 2006-09-08 17:47:28 UTC
Okay, I'll d/l *that* now :) - PPC versions weren't in there yesterday.

But meanwhile, this bug no longer persists in EN_GB vOOD680_m2, so I'm closing it as WORKSFORME. I've 
no idea why it manifested in earlier releases, but it's gone now.
Comment 24 pavel 2006-09-21 20:51:50 UTC
Maybe some user rights problem or whatevere...

Closing.
Comment 25 kikl 2008-12-19 09:26:20 UTC
I have the same bug, however, it is irrelevant, whether the new doc is saved. No
words can be added to the standard dic. As soon as you close the document and
restart it, the new words are erazed from the standard.dic.

Regards

kikl