Issue 68023 - Bogus vertical gradient direction import/export from/to PowerPoint
Summary: Bogus vertical gradient direction import/export from/to PowerPoint
Status: CLOSED DUPLICATE of issue 70102
Alias: None
Product: Impress
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.0.3
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: sven.jacobi
QA Contact: issues@graphics
URL:
Keywords: needmoreinfo
Depends on:
Blocks:
 
Reported: 2006-08-01 11:00 UTC by sthibaul
Modified: 2013-08-07 15:20 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
rectangular with vertical gradient (9.55 KB, application/vnd.oasis.opendocument.presentation)
2006-08-01 15:24 UTC, sthibaul
no flags Details
rectangular gradient saved once, correctly rendered by powerpoint, rendered exchanged by ooimpress (69.50 KB, application/vnd.ms-powerpoint)
2006-08-01 15:25 UTC, sthibaul
no flags Details
rectangular with vertical gradient saved the second time. rendered exchanged by powerpoint, rendered correctly by ooimpress (70.00 KB, application/vnd.ms-powerpoint)
2006-08-01 15:26 UTC, sthibaul
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description sthibaul 2006-08-01 11:00:51 UTC
Hi,

When importing/exporting presentations with vertical gradients from/to PowerPoint, the direction of gradients get inverted. Reproducing the bug can be done as follow:

- create a new presentation,
- draw a rectangular,
- apply a vertical gradient to it (from black to white for instance),
- save it to PowerPoint format,
- open it with PowerPoint, gradients are fine,
- open it again in OpenOffice, the colors of the gradient got exchanged,
- save it again,
- open it with PowerPoint, colors are exchanged,
- open it again in OpenOffice, the colors got back to original state...

On the other hand, gradients which are created with PowerPoint are correctly opened by OpenOffice...

Regards,
Samuel
Comment 1 wolframgarten 2006-08-01 12:50:06 UTC
Reassigned.
Comment 2 christian.guenther 2006-08-01 14:33:48 UTC
I can't reproduce the bug.
Please attach a bugdoc to reproduce the bug.
Comment 3 sthibaul 2006-08-01 15:24:32 UTC
Created attachment 38176 [details]
rectangular with vertical gradient
Comment 4 sthibaul 2006-08-01 15:25:30 UTC
Created attachment 38178 [details]
rectangular gradient saved once, correctly rendered by powerpoint, rendered exchanged by ooimpress
Comment 5 sthibaul 2006-08-01 15:26:33 UTC
Created attachment 38179 [details]
rectangular with vertical gradient saved the second time. rendered exchanged by powerpoint, rendered correctly by ooimpress
Comment 6 sthibaul 2006-08-03 00:35:37 UTC
Mmm, something that might very well have been mis-explained: by "vertical gradient", I actually meant a gradient whose equi-color lines are vertical. The gradient direction itself is horizontal, i.e. an 90° inclinaision in the gradient panel. 0° inclinaision gradients do work fine indeed.
Comment 7 christian.guenther 2006-08-03 17:18:40 UTC
I can reproduce the bug.
To create such a document
- start an Impress
- insert a rectangle
- assign Gradient 1 from the line and filling toolbar.
- Click on the area icon
- change to the gradients tabpage
- change the angle to 90 and click ok.
- normaly the warning 'The gradient was modified without ......' must appear but
it doesn't.
Comment 8 christian.guenther 2006-08-03 18:00:05 UTC
Please have a look.
Comment 9 jjtn 2006-10-17 10:32:56 UTC
The problem happens when importing the file (opening the saved .ppt with MS
PowerPoint Viewer under Wine shows the right gradient direction).
It seems related to any gradient with nonzero direction (following cgu's steps
with different angles results in the wrong behaviour).
Saving the gradient has no effect, since a new (wrong) one is created during import.
Comment 10 clippka 2007-09-12 13:40:07 UTC
reassigned
Comment 11 Martin Hollmichel 2007-11-09 17:17:53 UTC
set target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 12 kpalagin 2007-12-13 09:07:32 UTC
Seems to be dup of http://www.openoffice.org/issues/show_bug.cgi?id=70102.
Resolving as such.

*** This issue has been marked as a duplicate of 70102 ***
Comment 13 kpalagin 2007-12-13 09:08:07 UTC
and closing.