Issue 68563 - bad paste menu item when pasting from old to new version (or from OOo to SO?)
Summary: bad paste menu item when pasting from old to new version (or from OOo to SO?)
Status: CLOSED DUPLICATE of issue 58605
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: OOo 2.1
Assignee: andreas.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-08-12 20:26 UTC by norbert2
Modified: 2006-08-25 14:11 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
copy_paste_ooo115_to_SO8.odg (75.87 KB, application/vnd.sun.xml.draw)
2006-08-12 20:29 UTC, norbert2
no flags Details
copy_paste_crash.odg (97.54 KB, application/vnd.sun.xml.draw)
2006-08-12 20:50 UTC, norbert2
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description norbert2 2006-08-12 20:26:35 UTC
- open OOo 1.1.5 Writer

- enter some text

- copy the text to clipboard

- open SO8 Writer

open the drop down menu of the paste button: now you can see a menu item with
bad name, like the one in the attached screenshot.

The same happens when pasting some Calc cells from OOo 1.1.5 Calc to SO8 Calc

I have nosted Impress/Draw application.

I don't know if this also happens if I would paste to OOo 2.x instead of SO8,
since the menu item name includes the string "OpenOffice.org". (So this could
also be a interoperability problem between OOo and SO.)
Comment 1 norbert2 2006-08-12 20:29:21 UTC
Created attachment 38475 [details]
copy_paste_ooo115_to_SO8.odg
Comment 2 norbert2 2006-08-12 20:30:26 UTC
Found on SO8 Product Update 2, WIndowsXP (should be equal to OOo 2.0.2 I think)
Comment 3 norbert2 2006-08-12 20:48:50 UTC
If I use Edit/Paste Special instead of the paste button, SO8 hangs! Please have
a look at the second screenshot.

So this is a bigger problem than I thought first. Could someone please correct
the  Priority to P2!?
Comment 4 norbert2 2006-08-12 20:49:30 UTC
The summary should also be corrected.
Comment 5 norbert2 2006-08-12 20:50:03 UTC
Created attachment 38476 [details]
copy_paste_crash.odg
Comment 6 Regina Henschel 2006-08-12 22:34:19 UTC
I think, your problem is double to issue 58605.
Comment 7 norbert2 2006-08-13 10:52:06 UTC
Typing error in the initial comment:

"I have nosted Impress/Draw application."
-> "I have not tested Impress/Draw application."
Comment 8 thorsten.martens 2006-08-14 12:51:53 UTC
TM->MRU: Please have a look.
Comment 9 michael.ruess 2006-08-14 13:47:34 UTC
Reassigned to ES.
Comment 10 eric.savary 2006-08-14 15:52:40 UTC
ES->AMA: from OOo 1.1.5 to 2.0.3, one of the clipboard format shown either in
the drop down menu of the paste icon or in the Edit - Paste Special dialog
doesn't show "OpenOffice.org Document" but the xml stream itself.
Comment 11 andreas.martens 2006-08-25 14:10:52 UTC
Yes, Regina is right: It's a duplicate of issue 58605
It has been retargetted to 'OOo Later' because it is not easy to fix and it is
not an usual scenario to have different versions of OOo running. (Exept for
testing and developing purposes ;-)


*** This issue has been marked as a duplicate of 58605 ***
Comment 12 andreas.martens 2006-08-25 14:11:52 UTC
Closed.