Issue 68717 - gstreamer backend for avmedia
Summary: gstreamer backend for avmedia
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.3
Hardware: All Unix, all
: P3 Trivial with 11 votes (vote)
Target Milestone: ---
Assignee: radekdoulik
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-17 14:09 UTC by radekdoulik
Modified: 2010-08-03 12:30 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Updated version of gstreamer-config-office.diff that works on gstreamer-less systems and adds --disable-gstreamer (3.28 KB, patch)
2007-02-19 22:09 UTC, bero
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description radekdoulik 2006-08-17 14:09:26 UTC
implement new gstreamer backend for avmedia for media playing on Linux/UN*Xes
Comment 1 radekdoulik 2006-08-17 14:24:29 UTC
reassign to me
Comment 2 ht990332 2007-01-10 11:07:53 UTC
Is this planned for any specific version of OpenOffice? 2.2 , 2.4 .. ?
Comment 3 radekdoulik 2007-01-10 15:05:20 UTC
I think I will try to upstream it soon as it works pretty well. No idea in which
version it will be included though.
Comment 4 bero 2007-02-19 22:08:56 UTC
The current patches for this issue (from ooo-build) introduce a new bug: It 
can't compile on boxes without gstreamer anymore.
Comment 5 bero 2007-02-19 22:09:53 UTC
Created attachment 43178 [details]
Updated version of gstreamer-config-office.diff that works on gstreamer-less systems and adds --disable-gstreamer
Comment 6 bero 2007-02-19 22:10:25 UTC
You need to rerun aclocal and autoconf in config_office after applying the 
patch.
Comment 7 rene 2007-02-20 09:19:24 UTC
see my comment on openoffice@lists.ximian.com:

--- snip ---
Hi,

Bernhard Rosenkraenzer wrote:
> I'm not committing it because it's the first time something in ooo-build wants 
> to use PKG_CHECK_EXIST -- aclocal has to be rerun to drag in the definition 
> after applying the patch, and I'm not sure adding an aclocal run to the build 
> scripts is ok with everyone.

simple solution. Patch aclocal.m4, too (better: acinclude.m4, iirc)
But why do you need PKG_CHECK_EXIST after all?

If someone wants to build with gstreamer and PKG_CHECK_MODULES fails (and
(s)he doesn't want to install gstreamer or he doesn't want to enable gstreamer
support) (s)he can use --disable-gstreamer. We should honour what people want,
otherwise they might run into the situation that they might want gstreamer,
but somehow don't have it installed and therefore don't get it.
(OK, that shopuld be seeable by the packages' contents and library deps,
but...)
--- snip ---
Comment 8 lunixgeek66 2007-03-28 16:38:58 UTC
Since wav files and other media play fine using OpenOffice under XP I think it
would be most critical to get this functionality working under Linux.  This is
an important issue for those that wish to switch to Linux from Microsoft products.
Comment 9 nadavkav 2007-07-22 14:31:17 UTC
i know that Debian and Fedora has a working copy of OO 2.2.x with GStreamer.
so maybe you should check what they have done and add it here (main OO tree) or
ask them to push it upstream ?

it solved allot of multimedia issues and it works beautifully :-)
Comment 10 radekdoulik 2007-07-23 09:18:52 UTC
nadavkav: SUSE, Debian, Fedora etc. all use ooo-build, which includes my code.
It just wasn't upstreamed yet. BTW, it was developed by Novell Inc. ;-)
Comment 11 nadavkav 2007-07-23 09:30:29 UTC
our localized (Hebrew) version is dependent on your build and we are really
really missing this beautiful upgrade :-)

when do you expect to see it integrated ? 
Comment 12 radekdoulik 2007-07-23 09:36:04 UTC
no idea :( I am swamped with other work now.
Comment 13 mmeeks 2007-09-17 18:49:49 UTC
> Our localized (Hebrew) version is dependent on your build and we are really
> really missing this beautiful upgrade :-)
> when do you expect to see it integrated ? 

Unfortunately, Sun refused to include code such as this (available under the
LGPL) into OO.o. So - marking WONTFIX. We hope to make it easier to get builds
for you with this feature though. Sorry.
Comment 14 Mechtilde 2008-11-06 21:14:44 UTC
close the invalid issue
Comment 15 kami911 2008-11-27 14:46:25 UTC
Why WONTFIX? I do not undestand...
Comment 16 ccheney 2009-02-26 03:20:19 UTC
kami,

It is WONTFIX due to Novell not assigning copyright to Sun so it will not be
included in the official build, at least aiui.
Comment 17 caolanm 2010-08-03 12:29:33 UTC
reopen to update status
Comment 18 caolanm 2010-08-03 12:29:58 UTC
Alternative gstreamer support now landed in vanilla DEV300_m86
Comment 19 caolanm 2010-08-03 12:30:21 UTC
closing as of m86