Issue 69322 - Spelling check available but not working properly when language set to English(Eire)
Summary: Spelling check available but not working properly when language set to Englis...
Status: CLOSED DUPLICATE of issue 3310
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: issues@lingucomponent
QA Contact: issues@lingucomponent
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-06 12:05 UTC by noelcosgrave
Modified: 2013-02-24 20:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description noelcosgrave 2006-09-06 12:05:06 UTC
If the document language is set to English(Eire), the spelling check option is
enabled even though no matching dictionaries are installed. Running the spelling
check on a document littered with nonsense words and misspellings immediately
gives the message that the spelling check is complete. 

As the dictionary is essentially the same as English(UK), this is not a problem,
but it might be worth considering an aliasing feature so that duplicated
dictionaries are not needed.  

One final point, that may or may not be relevant here (it may be more relevant
to i18n) the language should be correctly described as English(Ireland). No
native Irish person would ever call the country Eire.
Comment 1 Mathias_Bauer 2007-01-17 21:59:07 UTC
Looks like a duplicate to issue 3310: allow to use any installed english
dictionary if the exact matching one isn't present.

*** This issue has been marked as a duplicate of 3310 ***
Comment 2 Mathias_Bauer 2007-01-18 16:21:02 UTC
closing
Comment 3 plandai 2007-02-14 14:29:36 UTC
Just to clarify the i18n point raised: it's reasoning is incorrect, for a great
many "native Irish person"s would & do call the land Eire, or more precisely Éire.  

E.g. re. the Irish constitution, "Éire is the Irish name of the [land] called
Ireland in the English language" & 'The Republic of Ireland' is not the name but
a description -http://en.wikipedia.org/wiki/%C3%89ire (2007.02.14).

Seeing as how the E.U. now accepts Irish as a working language, & the U.N. Éire
as the real place-name of the land, I respectfully suggest that the language is
no more correctly described in OpenOffice etc. as English(Ireland) than as the
current standard English(Eire).
Comment 4 noelcosgrave 2007-02-15 07:50:22 UTC
Further clarification.

Eire is the name in Irish (Gaelige), and it is how it is referred to in the
constitution of the country. Ireland is the name of the country in English, the
language in everyday use, and the language in question in this bug report. I
have never seen English(Eire) as a language option in any software before
OpenOffice, but I have seen English(Ireland). Ask any Irish person where they
are from, and 99% of them would respond 'Ireland'. The word Eire is simply not used.
Comment 5 Regina Henschel 2007-02-15 11:38:10 UTC
OOo should use ISO standard 
http://www.iso.org/iso/en/prods-services/iso3166ma/02iso-3166-code-lists/list-en1.html

There it is IRELAND.

But you have to write a new issue for that, because this one is about working of
spelling check.