Issue 69402 - "Replace all" does not work as expected
Summary: "Replace all" does not work as expected
Status: CLOSED DUPLICATE of issue 8288
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.4
Hardware: PC All
: P4 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-09-08 16:53 UTC by lkaratzas
Modified: 2006-09-13 16:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lkaratzas 2006-09-08 16:53:08 UTC
When you do a Replace All, the program takes you to the place where the last
instance of the replaced string was found. There is little use in this. It would
be much more useful if the insertion point did not move at all, i.e. it remained
at the point which you are actually editing. The user might also be given an
option on this, although I would personally see it as a rather unnecessary
complication.
Comment 1 kpalagin 2006-09-10 09:17:51 UTC
Confirming with m180 on Win XP.
Moving insertion point after "Replace All" is counterintuitive and 
counterproductive (as the user has to search back, wasting time). Competitors 
do not do this.

lkaratzas,
I would suggest changing priority to "P3", because "P2" is way too high.
Comment 2 michael.ruess 2006-09-11 08:54:29 UTC
Reassigned to SBA
Comment 3 stefan.baltzer 2006-09-13 16:30:48 UTC
SBA->lkaratzas: Please make up a more "telling" summary next time. People who
have to cross-read many issues or do a query based on summary strings will
appreciate it.

Thank you for your comptrehension

Duplicate of reopened issue 8288 "Leave / return cursor to original position
after Find & Replace All".

*** This issue has been marked as a duplicate of 8288 ***
Comment 4 stefan.baltzer 2006-09-13 16:32:13 UTC
SBA: By the way, this is an enhancement as the current behavior is the  one that
was desigend times ago.

Closed.