Issue 69580 - Imported HTML document is truncated
Summary: Imported HTML document is truncated
Status: CLOSED DUPLICATE of issue 17171
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
Keywords: oooqa
Depends on:
Reported: 2006-09-16 06:04 UTC by gobbledegook
Modified: 2010-11-11 01:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description gobbledegook 2006-09-16 06:04:06 UTC
Wanting to convert this URL
 to PDF I saved it as a complete html file from Firefox 1.0.6 and then opened
the file into OOo 2.0.3 (fresh upgrade from 1.0.2 - all default settings). The
resulting single page document is truncated at about 75% complete in the middle
of a block of text, there appears to be nothing special about the truncation
point in the html source file. Re-opening the saved html file in firefox
confirms it is complete.

I then tried a work-around with edit->select all, edit->copy in firefox and
paste into a new OOo writer document, the resulting 29 page document is
truncated at the same place.

I then tried this on another computer (Win Xp Pro SP2 + Updates, FireFox, OOo 2.0.1) and it failed the same way.

For added excitement place the cursor at the truncated point and press 'enter'
for a new line, then 'backspace' several times, seems to crash OO.
Comment 1 michael.ruess 2006-09-16 11:14:34 UTC
Reassigned to ES.
Comment 2 Rainer Bielefeld 2006-09-16 14:20:30 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]"  and also 
"1.1.4 (German) WIN XP: [645m52 (Build 8824)]", both the same result: I can
confirm that problem.

If you open webpage at a.m. URL and search for "Alturas, California 96101", you
will find it at the End of the text. In a "complete" copy of the page with
seamonkey also that string will be found if you reopen it with seamonkey from
disk, but if you open it with OOo, the string will not be found. 

In OOo the text ends with the string "successive troughs touching heel and", and
when I save the document from OOo, file size decreases from 129kB to 98 kB. Also
when I try to transfer the complete document contents from webpage to an empty
OOo WRITER HTML-ocument, the document will be cut after a.m. string "successive
troughs touching heel and".

It seems to be some strange kind of length limitation: I used a text editor to
insert a paragraph with nonsense text at the beginning of the HTML body, and
app. that lot of text I inserted was cut at the end of the document by OOo when
I reopened the document with OOo. I can insert as much text as I want, the size
of the file saved with OOo never will exceed 98 kB.
But: After Inserted some text in WRITER/HTML, this was accepted without cutting
any more at the end of the document.

So it seems to be something different from "open import" but currently I don't
know any better Component.
Comment 3 eric.savary 2006-09-18 11:25:25 UTC

*** This issue has been marked as a duplicate of 17171 ***
Comment 4 eric.savary 2006-09-18 11:25:44 UTC
Comment 5 clespantleri 2010-11-11 01:13:16 UTC
Created attachment 73985