Issue 69928 - "Adjust table column" function does not always appear in low zoom levels
Summary: "Adjust table column" function does not always appear in low zoom levels
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.3
Hardware: All All
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2006-09-28 06:58 UTC by dcam
Modified: 2017-05-20 11:26 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

document to reproduce issue (10.70 KB, application/vnd.oasis.opendocument.text)
2006-09-28 06:59 UTC, dcam
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description dcam 2006-09-28 06:58:39 UTC
Table columns can be resized by dragging the vertical lines defining the column
with the mouse.

If you move the mouse above the vertical lines, then the mouse pointer changes
to indicate the "Adjust table column" function, and you can then click and drag
the vertical lines

However, sometimes, the mouse pointer does not change and you cannot resize the

I will attach a document with a table with four columns.  All the vertical lines
in the table can be moved with the mouse except for the middle one.  WEIRD.

This has to be a bug!
Comment 1 dcam 2006-09-28 06:59:41 UTC
Created attachment 39405 [details]
document to reproduce issue
Comment 2 michael.ruess 2006-09-28 12:05:05 UTC
I have to investigate this a bit more. With the attached document it works
perfectly on my OOo 2.0.3 and 2.0.4 RC on Windows XP.
Comment 3 dcam 2006-09-28 12:13:34 UTC
Hmm...ok... I just quit OpenOffice and restarted it and loaded that document,
and I get the same behaviour.

This is Windows XP SP2.

Interestingly enough, when I move the mouse over any of the other vertical lines
apart from the middle, the mouse pointer changes and I get a little message
saying "Adjust table column".

On the middle line, when I put the pointer over the middle vertical line and not
over the horizontal lines, it says "Adjust table row".

Hmm, I just tried adjusting the zoom to 150%, and if I do that, then I can
adjust the middle vertical line.  If I then adjust the middle vertical line back
down to 100% I cannot adjust it, though I can adjust all the others.
Comment 4 dcam 2006-09-28 12:17:09 UTC

If I then adjust the zoom back down to 100% I cannot adjust the middle vertical
line, though I can adjust all the others.
Comment 5 michael.ruess 2006-09-29 12:50:42 UTC
Maybe this problem is limited to special screen settings... with which
resolution do run your OS?
Comment 6 dcam 2006-09-29 13:12:55 UTC
My screen is 1680x1050, Win XP SP2.  It is an ATI Mobility Radeon 9700 chipset.
Comment 7 michael.ruess 2006-10-05 11:09:34 UTC
Cannot reproduce the issue using resolutions like 1600x1200.
Have to find a system which is capable of displaying 1680x1050. Is it a Notebook
having a widescreen?
Comment 8 dcam 2006-10-05 11:41:04 UTC
yes, it is a widescreen notebook, a Clevo D870P

... but I have seen some Dells with the same resolution I believe
Comment 9 Rainer Bielefeld 2007-02-02 06:51:19 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]" (Nvidia
GeForce 7300 LE, 1024x768). Problem was not reproducible.

I checked with "2.1.0  German version WIN XP: [680m6(Build9095)]" on a notebook
with widescreen-display (ATI Radeon Xpress 1100, 1280x800). Problem was not
Comment 10 Rainer Bielefeld 2007-02-02 07:46:28 UTC
For 2.0.2 I tried various zooms and screen resolutions, I was not able to
reproduce the problem.
Comment 11 Rainer Bielefeld 2007-02-02 12:21:04 UTC
Thank you for your VNC offer, but the problem is not, that we would not believe
in your report. We want to rule out the possibility that really only your
computer is affected , and so we need someone else who can confirm that problem
(what also might generate additional information concerning the reasons for that
strange effect).
Comment 12 dcam 2007-02-02 12:25:10 UTC
Any chance of you experimenting with the attachment I created in this case,
playing with the zoom scale of the document?  I find that the column-dividers
that are affected change with the zoom scale.
Comment 13 dcam 2007-02-02 12:34:14 UTC
My screen is 1680x1050 while a 17" laptop, so the pixel density is high.

This problem is reproducible for me at 100% zoom.  Perhaps for others it is not
reproduceable because their pixel density is not so high.

If I set my zoom to 200% then I don't see the problem, but if I set it to 100%
or lower I see this problem.

I suspect that others will be able to reproduce this if you take the zoom down
even lower for screens that have a lower pixel density.
Comment 14 kpalagin 2007-04-26 19:24:12 UTC
I have tried going up to 2048x1536 and zoom to 100% and 75% and still could 
not reproduce.
Please try with version 2.2 and with some common resolutions (like 1024x768 or 
suchlike even if that is not native for built-in LCD).
Also specify what DPI setting is used (Display props - Settings tab - Advanced 
button - General tab) and if any special apps (like mouse pointers) are in use.
Comment 15 dcam 2007-04-26 21:08:53 UTC
AHHH - I believe I've made some progress on this issue.

The MOUSE POINTER MOVEMENT SPEED is a significant variable!

If you set the mouse pointer speed high, then it jumps a certain number of
pixels at a time, and it actually jumps over the tolerance for selecting the
vertical table lines in OpenOffice.

If you set the mouse pointer speed low, then you can't see this problem.

The same problem is not visible in MS word where it works even when zoomed out a
long way with high mouse pointer speed.
Comment 16 dcam 2007-04-26 21:16:46 UTC
To answer your questions and provide some further detail...

The DPI is set to normal which is 96DPI.

Yes the problem is still visible in 2.2

Yes the problem is still visible at 1024x768 at certain zoom scales in 2.2

My mouse is USB and using default MS driver
Comment 17 kpalagin 2007-04-27 05:17:50 UTC
Now I see - "Mouse pointer" speed does not seem to cause the problem, 
but "Enhance precision" does. If I uncheck it and set zoom to 25% or 50% then 
I can reproduce the problem - middle vertical border it difficult to "pickup" 
and I get "Adjust row" hint. All other borders do not have this problem.

Confirming with 2.2 on WinXP.
Comment 18 michael.ruess 2009-03-27 14:32:18 UTC
MRU->OS: this is not so easy to reproduce. If you have a simple table (like in
the attachment), and you set the zoom factor to 60 or even 50% sometimes it is
hard to get the "resize column" arrow when hovering across the border lines. It
was best to see on the line between column B and C. 
Comment 19 Marcus 2017-05-20 11:24:59 UTC
Reset assigne to the default "".
Comment 20 Marcus 2017-05-20 11:26:01 UTC
Reset assigne to the default "".