Issue 70026 - Calc - subtotals are not expandable in attached .xls file
Summary: Calc - subtotals are not expandable in attached .xls file
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.4
Hardware: All Windows, all
: P3 Trivial with 8 votes (vote)
Target Milestone: ---
Assignee: frank
QA Contact: issues@sc
URL:
Keywords:
: 74363 75004 77612 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-10-01 19:25 UTC by kpalagin
Modified: 2013-08-07 15:14 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Problematic .xls file (65.50 KB, application/vnd.ms-excel)
2006-10-01 19:27 UTC, kpalagin
no flags Details
Illustrating screenshot (72.63 KB, image/gif)
2006-10-01 19:30 UTC, kpalagin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kpalagin 2006-10-01 19:25:24 UTC
In attached "subt+filter.xls" Subtotals are not expandable (see area circled 
in red on attached "subtotals+filter.GIF"). The same file opened in that other 
spreadsheet app is just fine (see area circled in green on 
attached "subtotals+filter.GIF"). 
If I save file in .ods, close it and reopen then subtotals expand just fine.
Comment 1 kpalagin 2006-10-01 19:27:21 UTC
Created attachment 39494 [details]
Problematic .xls file
Comment 2 kpalagin 2006-10-01 19:30:46 UTC
Created attachment 39495 [details]
Illustrating screenshot
Comment 3 frank 2006-10-02 08:03:30 UTC
Hi Daniel,

column B seems to be filtered. Please have a look at this one.

Frank
Comment 4 kpalagin 2006-10-02 09:41:09 UTC
Daniel, Frank,
filter is not applied. 
Repro steps:
1. Start Calc, populate sheet with data simmilar to what is in attached .xls 
(copy/paste will do just fine).
2. Click cell that is part of the whole data array, click Data, Filter, Auto.
3. Then click Data, Subtotals and insert twolevels of subtotals, grouping by 
manufacturer, then brand and summing quantity.
4. Save the file in Excel 97/2000/XP format, close and open - now outlines 
(circled in red) are nonfunctional.

If I can he of any help please let me know.
WBR,
K. Palagin.
Comment 5 daniel.rentz 2006-11-23 10:02:48 UTC
Minor issue, due to different behaviour in Calc and Excel. As a workaround, you 
can select "All" in autofilter to bring the symbols back.
Comment 6 kpalagin 2007-02-09 18:51:29 UTC
*** Issue 74363 has been marked as a duplicate of this issue. ***
Comment 7 frank 2007-03-01 09:33:57 UTC
*** Issue 75004 has been marked as a duplicate of this issue. ***
Comment 8 frank 2007-03-01 09:35:22 UTC
changed target
Comment 9 hrist 2007-04-17 21:40:39 UTC
http://getfile.biz/67611
Comment 10 kpalagin 2007-06-17 07:52:28 UTC
*** Issue 77612 has been marked as a duplicate of this issue. ***
Comment 11 kpalagin 2007-07-18 04:38:06 UTC
Daniel,
any news with this issue?
Thanks a lot.
Comment 12 dma2002 2007-12-20 17:47:56 UTC
Hi all,

this issue exists more than one year, last comment is dated the 18-th July 2007.
Target is "2.x", votes total 18 and there are a lot of duplications. It shows
the importance of fixing this issue. That's why I'd like to ask you to think
about it. Also the codefreeze is in three weeks.
Comment 13 dma2002 2007-12-23 20:20:37 UTC
dr, thank you very much for setting the target to 2.4.
Comment 14 daniel.rentz 2008-01-07 12:57:21 UTC
seems to be double to issue 11776, or better, fix of this issue is broken again..
Comment 15 daniel.rentz 2008-01-07 13:49:10 UTC
broken with issue 38093
Comment 16 daniel.rentz 2008-01-07 14:35:21 UTC
fixed in SRC680/dr58 (OOo 2.4)
Comment 17 dma2002 2008-01-07 15:31:46 UTC
Daniel, thank you very much for fixing this issue! Great job!
Maybe the next point could be 59745? Regression with 40 votes and 5 dups?
Comment 18 daniel.rentz 2008-01-14 12:05:51 UTC
back to QA
Comment 19 oc 2008-01-16 15:13:09 UTC
verified in internal version cws_dr58
Comment 20 frank 2008-02-11 13:20:01 UTC
found integrated on master OOHm5 using Solaris, Linux and Windows builds