Issue 70089 - Field shading not shown with character background "white"
Summary: Field shading not shown with character background "white"
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.0.3
Hardware: PC Linux, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-10-04 11:50 UTC by napaloni
Modified: 2017-05-20 11:25 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Example document for demonstrationg that 'enable field shading' does not work. (10.34 KB, application/vnd.oasis.opendocument.text)
2006-10-04 11:52 UTC, napaloni
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description napaloni 2006-10-04 11:50:50 UTC

I am currently editing a document which uses fields. It was a long document, but
I reduced it to two text lines, one which defines a field, the second one using
the field (I'm going to attach it...)

Now to the problem:
I can't enable "field shading". I tried it from the menu, I found the color
configuration dialog and tried giving it a different color and enabling it from
there, and I enabled/disabled use of OpenGL, but fields can't be enabled in this
document. Even when the cursor is left to the field, I see no shading at all.
The reference itself works perfect: if I change text and press F9 the change is
reflected immediately.

An update to OpenOffice 2.0.3 (SuSE Linux 10.1) didn't change the situation, so
it seems I have a document which is broken in some way.

If I create a new OO Writer document, all fields I insert are colored in the
color I configured for shaded fields earlier, and I can enable/disable field
shading as desired, so it really is my other document which must be broken.

BTW the document is originally converted from PDF by KWord and then edited in

I hope this feedback is useful in finding some bugs... :)

Walter Zimmer
Comment 1 napaloni 2006-10-04 11:52:13 UTC
Created attachment 39557 [details]
Example document for demonstrationg that 'enable field shading' does not work.
Comment 2 michael.ruess 2006-10-04 11:55:18 UTC
Reassigned to ES.
Comment 3 eric.savary 2006-10-04 13:03:22 UTC
ES->OS: Please have a look.
Comment 4 napaloni 2006-10-04 15:39:13 UTC
There is also a hint from Hagar de l'Est here:

He suspects that the background color of the "default" style
is set to white (by KWord) and causes this behaviour. Although,
he can't see a way to change it.

Should we still take the unability to change it as a bug or
is the problem solved now?
Comment 5 napaloni 2006-10-05 09:55:18 UTC
Confirmed: If the default style is edited, the background character color of the
default style can be set from white to "no fill" which fixed this problem.

Therefore, now I know how KWord defines its default style, I know how to change
it so it works for OpenOffice, so it works for me.

However, maybe a fix to make this somehow more transparent might be a good idea.
Maybe the field shading should override the background coloring in any case?
Thereofore the prio is set to P4.
Comment 6 michael.ruess 2010-02-18 07:42:50 UTC
Making summary more significant.
Comment 7 Marcus 2017-05-20 11:25:01 UTC
Reset assigne to the default "".
Comment 8 Marcus 2017-05-20 11:25:48 UTC
Reset assigne to the default "".