Issue 70151 - database explorer need to select address_query again by mailmerge printing
database explorer need to select address_query again by mailmerge printing
Status: RESOLVED FIXED
Product: Writer
Classification: Application
Component: ui
current
All All
: P3 trivial with 4 votes (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
issues@sw
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 12:06 UTC by h.ilter
Modified: 2012-09-27 01:49 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description h.ilter 2006-10-06 12:06:17 UTC
- Create a query from your current database
- Insert fields from the query into a writer document
- Click on print button and answer mailmerge print with Yes.
-> The mailmerge dialog will appear without selected source of the defined query
Note: It works when you use the database instead the query.
Comment 1 Martin Hollmichel 2007-09-10 13:35:54 UTC
move target to 3.x according http://wiki.services.openoffice.org/wiki/Target_3x
Comment 2 colebantam 2008-03-19 10:00:57 UTC
Is this (realy anoying) problem indeed so hard to fix, that it must be 
postponed to 3.x?
Comment 3 Starsearcher 2012-09-26 21:59:48 UTC
Not just annoying - essential for non-IT literate users of a database system - they don't have a clue about 'data sources' - they just wonder why they are not able to print a sheet of labels!
Comment 4 Ariel Constenla-Haile 2012-09-27 01:39:35 UTC
Root cause:

SwNewDBMgr::ExecuteFormLetter() tries to convert the css.sdb.CommandType from css.uno.Any to sal_Int16, conversion fails because IDL long is mapped to sal_Int32
Comment 5 Ariel Constenla-Haile 2012-09-27 01:45:41 UTC
Fixed in trunk with revision 1390434
Comment 6 Ariel Constenla-Haile 2012-09-27 01:49:52 UTC
(In reply to comment #5)
> Fixed in trunk with revision 1390434

Correction: Revision 1390801
(it seems the bugzilla bot is not working)