Issue 7020 - paste into highlighted cells, not from where focus is (when pasting unformatted)
Summary: paste into highlighted cells, not from where focus is (when pasting unformatted)
Status: CLOSED WONT_FIX
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: niklas.nebel
QA Contact: issues@sc
URL:
Keywords:
: 6360 29912 (view as issue list)
Depends on:
Blocks:
 
Reported: 2002-08-15 20:30 UTC by lars
Modified: 2013-08-07 15:14 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lars 2002-08-15 20:30:28 UTC
when selecting cells and pasting unformatted, the content should be pasted into 

the selected cells if it matches size-wise and not starting from the last cell 

where the focus is
Comment 1 lars 2002-09-22 00:27:54 UTC
*** Issue 6360 has been marked as a duplicate of this issue. ***
Comment 2 oc 2002-11-28 16:16:03 UTC
reproduced
Comment 3 niklas.nebel 2002-11-28 17:46:38 UTC
It works as intended: When pasting spreadsheet cell data, the
selection is used and the clipboard content is repeated to fill the
selection. Pasting of text data doesn't have that "repeat" function,
so the cursor position is used. Using the selection only if it happens
to match the size of the clipboard content sounds strange to me.
Comment 4 lars 2002-11-28 19:25:26 UTC
?

if I highlight sth. I expect the next operation to be performed on 
the highlighted selection

that's the principle behind highlighting used in the majority of 
cases and it should always be everywhere like that.


how to do it in calc:

highlight: datapointer=selected_object;
perform action: datapointer->do();

if highlighted selection wrong size: ask whether it should be resized 
appropriately by Calc (+ option field: always do it like that in the 
future; -> see issue 7185 !!) or to do nothing

if selected object==singlecell do action starting on inclusive this 
cell


repeat: only as an option !  ask the user; see issue 7185
Comment 5 niklas.nebel 2002-12-16 17:59:17 UTC
I still don't consider this a bug. There are operations that work on
the selection, and there are operations that use the cursor position.
Pasting plain text is one from the second group.
Comment 6 michael.bemmer 2003-03-11 18:06:35 UTC
As mentioned on the qa dev list on March 5th I will close all resolved duplicate
issues. Please see this posting for details. First step in IssueZilla is
unfortunately to set them to verified.
Comment 7 michael.bemmer 2003-03-11 18:14:57 UTC
As mentioned on the qa dev list on March 5th I will close all resolved
<wontfix/duplicate/worksforme/invalid> issues. Please see this posting for details. 
Comment 8 niklas.nebel 2004-06-07 08:56:09 UTC
*** Issue 29912 has been marked as a duplicate of this issue. ***