Issue 70325 - Add an option "Enable quick start after first OOo start"
Summary: Add an option "Enable quick start after first OOo start"
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.3
Hardware: All Windows, all
: P5 (lowest) Normal with 4 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-10-11 19:22 UTC by vytis
Modified: 2017-05-20 10:35 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description vytis 2006-10-11 19:22:07 UTC
There is no way to set on windows version od OOo, to start quick start on first
start of OOo, but not when Windows starts.

I want to have quick start running, when i deside to work with OOo, but not when
i start my PC. This is how quickstart works on Baltix/Ubuntu/Debian versions.
Comment 1 Olaf Felka 2006-10-12 08:19:51 UTC
This doesn't make sense. Loading the quickstarter when I want to use the office
doesn't speed up the start of OOo. The quickstarter works as designed.
Comment 2 vytis 2006-10-16 09:39:58 UTC
In general, quick starter do not act the same on windows and on linux. 

On linux it does not sit in memory until i start openoffice. 
On Windows openoffice sit in memory even i do not started openofice.

On linux option "use quoistarter", does only one thing - it enables quickstarter.
On Windows option "use quickstarter", does two thinga
 - it enables quickstarter.
 - it starts openoffice, when OS is startig

quickstarter should start only when i open openoffice first time and sit in
memory to speed up openoffice, when i start open office second and next time.
Like on linux.

I don't want to have openoffice running, when i boot my pc just to watch movie.



Comment 3 Olaf Felka 2006-10-16 11:11:43 UTC
What you describe is how a link in the autostart folder works. Just try the new
Acrobat Reader or try Mozilla (Mozilla acts the same even without an enty in the
autostart folder). This quickstarter should speed up the first office start and
is useless if the office has been started before.
Comment 4 vytis 2006-10-17 08:09:45 UTC
1. if i disable starting of mozilla when OS starts, quickstarter starts when i
start mozilla,  and will sit in memory until i turn off computer.
2. The same acts Adobe acrobat.

So, quick starter of openoffice, acts in different way like other popular systems.

3. why quickstart acts different on Linux? On linux, if you want to have it
started , when os starts, you have manualy put it to sessions.

4. if quickstart aim is to make first start of openoffice to make faster - OO
failed - starting of quickstarter is too long.

I don't like such microsoft style "WE know better, what you need". 
I need fast start of OS, to be able to work with program what i need, but not
which was choosen by openoffice. Starting of quickstarter takes time, and slows
down loading of other program, which i realy need.




Comment 5 Olaf Felka 2006-10-17 08:57:03 UTC
Again: This is not a defect! The quickstarter works as designed.
1. This is not true: When you disable the 'quickstart' for mozilla, mozilla is
no longer in the memory after closing.
2. The same for Acrobbat Reader: Closing Acrobat Reader without a running
quickstart tool and it is no longer on the memory.
3. Linux is just different to Windows?!
4. Have you ead this after writing? The quickstarter is just a preload of files.
It can't be  much quicker than the office start. But this is something we don't
care about becaus nobody sees the quickstart! If the quickstart would be fast we
don't need a quickstarter because the office start would be also fast.
At last: "I don't like such microsoft style". Where can I find the style guide
for this 'Microsoft Style' you thik you have found here? I don't like this
rhetorical killing phrases. It is not 'We know better..' it is just a
description how it works and why it can't be changed.
Comment 6 vytis 2006-10-18 15:05:51 UTC
sorry for reopening, but in another case this problem would not get attention.

When Mozilla or Acrobat enables quickstarter i does two two things:
1. add program to autostart (when OS starts) list
2. enables quickstarter

So, this mean, that i can delete shortcut from autotart list. And this do not
disable quickstart of mozilla and acrobat. It starts when i start program first
time.

If i try to do the same for openoffice - quickstarted do not starts. OpenOffice
diasapears from memory, if close last window. And thi do not hapen on Mozila, do
not hapen on Acrobat, do not hapen on linux version of openoffice. To close
Mozila/Acrobar linux ooo i have to click on quicstarter and select "close/end/or
something like this".
This is usefull , when you don't need program all the time, but when you need,
you using very intensive. 

At work i'm using Windows, at home - Baltix(Debian), all program, what i use on
both computers, acts the same on linux and on windows. All except OpenOffice
quickstarter. :/  

Comment 7 Rainer Bielefeld 2007-02-06 07:16:18 UTC
Indeed, My Seamonkey browser will  start QuickStarter (if quickstart is enabled)
after first start of Seamonkey, so that you have a speed up  further starts of
Seamonkey, if you close it after every use.

OOo has an other philosophy, here the QuickStarter will be enabled with system
start, so that you have a speed up for the first OOo use. As far as I know,
further OOo starts will be faster than the first start (no Idea why), so that
there is no use to have a QuickStart option "enable QS with first OOo start".
Comment 8 sophia 2008-07-11 09:44:24 UTC
I'm using a laptop and I'm not using oo every time my computer is started.

Usualy, there is a higher probability that I will use OpenOffice when it has
already been used (oo started and then closed).

Then I would benefit from a high speed-up if I would have 3 quickstart behaviors:
- disabled
- enabled after 1st use
- always enabled
Comment 9 kosmodrom2000 2011-07-20 19:02:08 UTC
Is there any progress on this option? Last post was in 2008, but there still seems to be no way to make quickstart be enabled on first start rather then either always or never.
Comment 10 Edwin Sharp 2014-02-13 13:26:55 UTC
Confirmed with
AOO410m1(Build:9750)  -  Rev. 1565724
Rev.1565724
Win 7
Comment 11 Edwin Sharp 2014-02-27 11:34:59 UTC
quickstarter starts with AOO, not Windows.
AOO410m1(Build:9750)  -  Rev. 1569541
Rev.1569541
Win 7