Issue 7037 - Cannot shutdown windows properly...
Summary: Cannot shutdown windows properly...
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.0.1
Hardware: PC Windows XP
: P3 Trivial with 7 votes (vote)
Target Milestone: AOO Later
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
: 6846 7948 8120 10753 10885 12559 14436 14925 (view as issue list)
Depends on:
Reported: 2002-08-16 12:54 UTC by erpel
Modified: 2013-02-07 22:19 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

the open handles log after closing (WinXP ger, OOo 1.0.1 ger, user "ue", OOo-net-path "c:\programme\", OOo-user-path "c:\dokumente und einstellungen\ue\eigene dateien\") (5.52 KB, text/plain)
2002-10-30 10:06 UTC, erpel
no flags Details
oh log, I can't log off windows xp, quickstarter was not in use (5.54 KB, text/plain)
2002-11-25 23:30 UTC, erpel
no flags Details
script to diagnose 'hanging' soffice.exe (4.09 KB, text/plain)
2003-01-27 13:13 UTC, lo
no flags Details
soffice.exe mini user dump (230.08 KB, application/octet-stream)
2003-03-18 12:41 UTC, erpel
no flags Details
Another mini user dump (same PC) (252.11 KB, application/octet-stream)
2003-03-27 15:09 UTC, erpel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description erpel 2002-08-16 12:54:04 UTC
I have a problem with 15 PCs, all running Windows XP Pro with OOo 1.0.1 german. Samba is used as file 
Every few days, if we try to shutdown Windows XP, i.e. START / SHUTDOWN / OK, after using 
OOo, the shutdown-window disappears and we are back in Windows. In this case, the only possibility 
is to open the Task Manager and kill "soffice.exe". Then it is possible to shutdown WinXP 
Unfortunately, I can't reproduce this error, but it occurs every few days on approx. 
10 of 15 PCs.
I would be glad to trace this bug farther, so any suggestions HOW to trace it would be 
appreciated. :-)
Comment 1 thorsten.martens 2002-08-22 11:23:23 UTC
TM->PL: Can you please have a look at this one ? As far as I know,
you´ve checked a similar problem in Linux. Maybe you´ve got an idea
about this one.
Comment 2 Unknown 2002-09-12 13:20:08 UTC
I don't know if this will help any, but I've noticed the same problem 
on Win95, Win98 and Windows 2000 systems.  I've noticed that it 
occurs on systems that are not rebooted very often, whereas ones that 
are don't have this issue.
Comment 3 philipp.lohmann 2002-09-12 13:49:40 UTC
pl->hro: since Windows is not really my area of expertise, could you
please have a look at that ? ssa mentioned that this may have to do
with the quickstarter.
Comment 4 erpel 2002-09-22 12:01:17 UTC
Further information:
If the problem occurs (i.e. I can't shutdown WinXP), I CAN 
close the OOo Quickstarter. Then, the OOo symbol gets removed from the sys tray. 
Unfortunately, I still can't shutdown WinXP, unless I kill soffice.exe through the 
Task Manager.

BTW: The PCs are rebooted every day, nevertheless the bug occurs 
every few days.
Comment 5 Unknown 2002-10-01 03:05:33 UTC
This also occurs under windows 2000.  Have to use task manager to 
end task "soffice.exe" in order to logoff/shutdown.
Comment 6 hennes.rohling 2002-10-14 13:15:35 UTC
@MBA: As discussed this seems to be in your ambit.
Comment 7 Mathias_Bauer 2002-10-22 15:47:48 UTC
Carsten, please take this one over.
Comment 8 carsten.driesner 2002-10-23 11:38:57 UTC
I will investigate this problem, but currently we have no clue what 
the real cause is. The testing crew is not able to reproduce this 
Maybe we can provide a special OpenOffice build which logs some 
information gathered during the shutdown process.
Comment 9 erpel 2002-10-30 10:03:03 UTC
I'm not sure, if this helps at all, but using oh.exe (OpenHandles) from
returns the following open handles after trying to shutdown WinXP and
closing the OOo Quickstarter. (see next attachment)
Comment 10 erpel 2002-10-30 10:06:54 UTC
Created attachment 3427 [details]
the open handles log after closing (WinXP ger, OOo 1.0.1 ger, user "ue", OOo-net-path "c:\programme\", OOo-user-path "c:\dokumente und einstellungen\ue\eigene dateien\")
Comment 11 thomas.lange 2002-11-01 10:36:14 UTC
Please try disabling the quick launcher for OpenOffice in the taskbar.
Comment 12 prgmgr 2002-11-16 21:55:29 UTC
*** Issue 6846 has been marked as a duplicate of this issue. ***
Comment 13 diane 2002-11-17 03:20:07 UTC
Please read my notes attached to Issue 6846.  My quickstarter dies
multiple times per day.  I check for it to be "not responding" in my
task list before I perform a shutdown, in order to get a clean
shutdown.  I shutdown at the end of everyday, and start it up again
each morn.  I still see no definite pattern.  I run OOo 1.0.1 on
win98.  I wonder, from my observations, if it is somehow tied to an
interference with mozilla or autocad.  I wonder too if it is somehow
related to the status of network communication.  I say this because
sometimes I can go maybe three days in a row without seeing the
failure...and then it appears again multiple times per day.  I have
started to wonder if these 2 or 3 day spans happen to fall on the
weekend when a couple more computers are on the network.  I am still
hunting for a pattern, and am very willing to run whatever tests might
be needed to capture whatever data that might be needed.  I have
written alot on Issue 6846 about what I have witnessed on my setup. 
Good luck on this seems quite elusive.

I would like to cc myself to this issue, but there appears to be no
field for that....perhaps I have lost some permissions.  I would be
most grateful if someone could add my email to the cc list.  I am very
curious about this issue.  
Comment 14 diane 2002-11-17 03:23:50 UTC is way over scrolled to right...wakeup diane! added my addr
to cc list.
Comment 15 erpel 2002-11-25 23:25:20 UTC
I have tried to disable the quickstarter. After that, the phenomenon
occurs fewer, but is not away completely. Right today, it has happened
again. I have done another Open Handles dump, and there are several
entries for the process "soffice.exe". It seems as if
(w/o quickstarter) does not exit completely (after closing all docs)...

I'll post the new OpenHandes log as new attachment.

Does the first "KeyedEvent": \KernelObjects\CritSecOutOfMemoryEvent
mean anything? It is present in both log files...
Comment 16 erpel 2002-11-25 23:30:54 UTC
Created attachment 3755 [details]
oh log, I can't log off windows xp, quickstarter was not in use
Comment 17 cjensen 2002-11-27 22:40:50 UTC
We see this in our company also. We have approximately 40 PC's running
ooo 1.0.1 under Windows 2000 SP3.
The computers are left on for long periods - users logoff and put the
machine to sleep rather than shut down at the end of the day.
Most of the documents that the users would open are located on Network
Drives - the users My Documents folder is mapped to a network drive.
Another user reported they were using Mozilla, we are using Netscape 6.2
Comment 18 carsten.driesner 2002-12-06 07:38:15 UTC
Hi Lars, please take over as you are already working on an issue 
related to the shutdown process.
Comment 19 lo 2002-12-16 10:28:04 UTC
The only way we have to block windows from shutting down is by
answering 'false' when we are handling a WM_QUERYSHUTDOWN message.
Our answer to this message depends on destop::Desktop::QueryExit() -
So we block shutdown if there are modified documents for example...

There is a general problem with the way we respond to windows shutdown
since we might get terminated before we are able to deinitialize
everything completly (see internal issue #105960)
Comment 20 Mathias_Bauer 2003-01-08 14:53:19 UTC
*** Issue 7948 has been marked as a duplicate of this issue. ***
Comment 21 apienk01 2003-01-10 14:30:27 UTC
I've got a similar problem on Win98SE on my Toshiba notebook, but it 
concerns Windows' suspend mode (save to RAM). I have no problems with 
shutdown. The issue is intermittent - not always happens - and 
depends on whether any documents have been opened by OO since the 
last system start. If no documents were opened, the system goes to 
suspend mode without problems with OO quickstart in the tray. But if 
any document was opened, Windows often refuse to suspend until I 
manually close all openoffice executables including quickstart. I 
noticed however that suspend is often successful, when I leave the 
focus on an open OO document window. Hope it helps.
Comment 22 Unknown 2003-01-16 19:36:55 UTC
I have this same problem with on Windows 98 and Windows ME. 
START/SHUTDOWN/OK and then I am back in Windows... I must 
kill "soffice.exe" process and then it is possible to shutdown 
operation system... this happen every few days and does not matter 
how long I work with the computer.
Comment 23 thorsten.martens 2003-01-23 12:59:56 UTC
TM->LO: Just some additional remarks:
OpenOffice blocks windows shutdown if a dialog (modal only) is
displayed (such as file-open or database source dialog) or if a
modified document hasn`t been saved -> appearing windows dialog
mentions that OpenOffice is not responding and should be ended by user
Further on JSK said, he had problems with the windows shutdown when
DDE-Server is hung (maybe due to too many OLE-actions in Impress ?)
Comment 24 lo 2003-01-23 13:50:12 UTC
Ok, the issue seems to be with an soffice.exe that does not terminate
after all documents and quickstarter have been closed.
This renegade process them seems to answer windows WM_QUERYENDSESSION
message with FALSE, making windows shutdown impossible.
I have personaly never seen this happen, so could anyone who saw this
behaviour give a full account on what he did with his office before
he/she tried to shutdown windows? If anyone can get callstacks from a
process in this state, that would be perfect. But if I get some notion
of how to trigger the behaviour I could debug it from there...
Comment 25 thorsten.martens 2003-01-24 10:36:26 UTC
*** Issue 10885 has been marked as a duplicate of this issue. ***
Comment 26 diane 2003-01-24 12:50:40 UTC
I deal with the soffice task going into the "not responding" state on
my win98 box almost daily. (I am still running 1.0.1) I see this when
I do a cntl-alt-delete to bring up the box where I can end tasks or
shut down.  I do this often, especially if my pc starts misbehaving,
such as my internet connection seeming to freeze. I will try to notice
what I am doing right before that when in OOo.  Likely, I am in my
calc time sheet.  (This is a sheet that was once brought in as an
excel file, but is now a .sxc file.)  This is not a failure I can
"cause" to happen upon request so far, but it does happen
often...likely multiple times per day.  If you can teach me how to get
callstacks, I will try to provide them.  I do not get shutdown errors,
because I am very trained at killing the soffice from the task box. I
likley do so multiple times per day, and I always look for the (not
responding)soffice before shutting down, just to get a friendly
shutdown.  I am not a programmer, but I am a troubleshooter by trade.
 If you can guide me thru the programmer stuff, I can likely help you
gather some useful data for this. 
Comment 27 lo 2003-01-24 14:11:09 UTC
It would also be interesting to know how OOo was closed when the
'leftover' process occurs. File/Exit, File/Close or exit via closing
the last open window.
In tha latter case, the office should wait 5 seconds before
terminating itself - this is to speed up things when you close the
last open document and open another document in your file manager
right after that.
It is also very important to know whether and how you use
quickstarter. The quickstarter is just an soffice process that has no
open document window but a system-tray icon.
Comment 28 diane 2003-01-24 16:18:24 UTC
I am pretty sure that I close my OOo file by doing File/Exit after
doing a File/Save.  I will watch myself better when I am in
"auto-pilot mode" tho, to be sure this is what I do.

My quickstarter is set up to run automatically.  I typically open OOo
by  clicking on an icon on my desktop for the calc program to get to
my time sheet.  I also go into the writer program fairly regularly, so
I may click the writer icon on my desktop.  I allow the quickstarter
to just run, and its little icon hangs out on the bar at the bottom of
my screen in the right hand corner.  Sometimes it will just disappear
when I wave my mouse pointer over it.  I assume this is when the
soffice is "not responding", but I have not yet discovered that it has
stopped.  If I do find my soffice not responding (via cntl-alt-del), I
end the soffice task, but the quickstarter icon does not go away until
I wave my mouse pointer over it.  If OOo is started up again, and I
have not yet waved my mouse pointer over the quickstarter icon, a
second quickstarter icon will appear.  When this happens, if I wave my
mouse pointer over the quickstarter icons, one of them will disappear.  
Comment 29 lo 2003-01-24 16:47:57 UTC
having a systray icon disapear when waving the mouse at it, means that
the application associated with that icon has exited without
explicitly removing itself from the system notificatin area. this
either an indication of the soffice process having crashed or at least
a sign of an unclean exit... maybe the same thing can lead to either a
hangup or an abnormal process termination/unclean exit.
Comment 30 diane 2003-01-24 17:55:01 UTC
Another interesting point is that I have had more than one spell 2 or
3 days long where I do not see this error at all.  I have not been
able to  find a pattern to it.  I do not understand how the blocks of
code work, but if you can set me up with steps that exercise different
chunks of code, I am willing to alter my steps to provide data.  With
what you have said already, I can see that maybe the steps I take to
close my file might be suspect, so I can try different ways of closing
files and log my actions vs the quickstarter behaviour, to see if a
pattern develops.  My lack of knowledge of the code itself hinders my
troubleshooting ability with this issue.
Comment 31 diane 2003-01-26 17:49:59 UTC
I have now witnessed a quickstarter "crash" after doing a file/save
then file/close from a calc sheet when using the calc time sheet I
described earlier.  I witnessed a second quickstarter "crash" after
doing an entry into the calc sheet, then file/save, then file/exit. 
Neither is reproducible upon command.  Also, last eve, before
shutdown, I killed the soffice task thru the taskbox, even tho it did
not show the (not responding)message.  And I rec'd message back that
it was not responding, even tho it did not show the message.  The
shutdown the nite before this did not complete, and reboot in the morn
was rough, requiring a clean shutdown and reboot to get back full
mozilla functions.  This is what motivated me to kill soffice before
shutting down last eve.  Is it possible that OOo and Mozilla want to
use the same memory addrs?  I wonder if those experiencing this issue
use Mozilla.  I also wonder if those not experiencing this use
Mozilla.  I have been hoping to prose these questions on the discuss
mail list, cuz there is talk of this issue there...but I have not yet
been able to subscribe likely do to issues with my mail server. 
Another question in regard to this:  is there a common piece of code
between file/close, and file/exit that could give a clue to cuase?  I
also notice that I am not nearly as routine with closing an OOo file
as I thought...I have seen myself use all three methods.  Will
continue to keep a log.
Comment 32 erpel 2003-01-26 20:55:12 UTC
We run Mozilla (first 1.0.1, now 1.1) on all PCs that are having the
described problem. IIRC, the Mozilla Quicklaunch is also activated on
all these PCs.
Comment 33 erpel 2003-01-26 22:08:00 UTC

can I get a callstack image with the "MS Debugging Tools for 

so, please tell me how, then I (and probably others, too) will create one and attach it 
to this issue...
Comment 34 lo 2003-01-27 10:28:13 UTC
Since getting stacktraces for binary openoffice windows releases could
be complicated (no .pdb files), it would be nice if someone could
check the state of the office like this: can you still open documents
with the process infor that is preventing shutdown (e.g.
doubleclicking them in explorer)? If that is the case, we will provide
a basic script that tries to find out what was preventing the office
from shutting down.
Comment 35 lo 2003-01-27 13:13:01 UTC
Created attachment 4445 [details]
script to diagnose 'hanging' soffice.exe
Comment 36 lo 2003-01-27 13:16:55 UTC
Have a look at this script, at the top there are some settings you
need to adept to your environment (temp path). When you have no more
visible open documents and no quickstarter running but still
soffice.exe running, open a cmd prompt and try to run 'soffice
shutdown.bas', if you get a shutdown.log file in the directory you set
as temp-dir please, provide it.
Comment 37 erpel 2003-01-27 15:26:16 UTC
If I just run "soffice shutdown.bas", a new Writer window is opening,
showing me the source code of shutdown.bas.
Is there any command line option I have to add, so that OOo *executes*
the script rather than displaying it? :)

Furthermore, if I import the script into a new .sxw/.sxc and try to
execute the macro (manually or by the "open document" event) from
there, I get the runtime error "object variable not set" @line 104
("if isObject(lArgs(i).Value) then").
Comment 38 diane 2003-01-27 16:04:26 UTC
I was not able to run the basic program either.  My partner is helping
me out a bit with this.  He tells me that the basic program needs to
be compiled in order to provide an .exe file to run on my machine. 
This is a out-of-the box plug and play type machine, an HP Brio BA200
where the operating system comes on HP discs and is embedded in HP
stuff.  It runs Win98SE 4.10.2222A, which does not include Qbasic,
according to my partner.  We searched for some sort of basic program
too (*basic*.*), and found nothing useful.  Unfortunate...

Anyway...I do have a little bit more data for you.  Today, the soffice
showed (not responding) in the task manager box (via cntl-alt-del)
after doing an edit to the same calc file, file/save, then X to close.
 This means I have now crashed the soffice task with all three methods
of closing a file.  With soffice (not responding), I can still open,
edit and save files both in calc and writer.  I can do this by opening
the files thru a shortcut icon on my desktop for each, and I can do
this by using explorer to get to my files and double-clicking to open
them.  When I wave my mouse over the quickstarter icon when my task
manager shows the soffice as (not responding) it did not disappear.  
 Then I exited the quicklaunch via its own menu.  After this, I looked
in my task manager box again (via cntl-alt-del) and the soffice task
was gone.

Any chance that you can provide an executable test script?  I will
keep trying...  :)  
Comment 39 lo 2003-01-27 16:22:33 UTC
Sorry, my explaination was just wrong, and was depending on some
provisins not available in the open office builds. You can use the
script like this:
Open OO, click on tools/marcos/macro... Make sure that the
Standard/Module1 and press edit. Append the contents from the
shutdown.bas file to the end of the script. Rename the 'sub Main'
function from shutdown.bas to 'sub Shutdown' (1st line) and press
save. (Don't forget to change the temp-dir). Exit Office.
Now, if you find your office in the state where it blocks shutdown,
open a command window and do:
<OOinst>\program\soffice.exe macro:///Standard.Module1.Shutdown
This should execute your script and produce a shutdown.log
Comment 40 erpel 2003-01-27 17:12:24 UTC
If there is an OOo window open (i.e. @line 101: nCount >= 1) , I still
get the runtime error described:
"object variable not set" @line 104 ("if isObject(lArgs(i).Value) then")
Comment 41 diane 2003-01-28 03:30:39 UTC
I now have the task soffice showing as (not responding) in my task
manager (via cntl-alt-del).  My quickstarter icon is still running,
because if I exit it, the soffice(not responding) will go away from my
task manager (cntl-alt-del) list.  I ran the macro as you described. 
My temp directory now has a shutdown.log file that says "open frames = 0".
Comment 42 diane 2003-01-28 03:40:00 UTC
I just exited the quickstarter via its own menu.  the soffice (not
responding) task disappeared from my task manager (seen via
cntl-alt-del).  I ran the macro script again.  The shutdown log shows
the same thing as my earlier test:  open frames = 0.  But, an
interesting event occured:  the splash screen appeared, and the
quickstarter restarted itself.  Is this expected?
Comment 43 diane 2003-01-28 03:50:25 UTC
For hee-haws we did a third test:  this time we opened OO.o and ran
the shutdown macro while OOo was running.  And this time I get the
same error that Christian reported.  This time the shutdown log also
has text in it.  I have not attached it because it doesn't quite match
the test you requested, but it is still on my machine, should you
decide you would like to see it.
Comment 44 lo 2003-01-28 10:01:02 UTC
Soffice being shown as 'not responding' is not always a sign for a
hanging office. When a process is not calling GetMessage() for some
time, windows will show it as not responing for instance. The
test-script is only of use when the process is in a state in which it
prevents windows from shutting down. It is - on the other hand - no
problem to see an soffice task as long as the quickstarter is running
and working. Also, please don't try to interpret too much from the
output of the script, since it is just dumping away info from certain
objects, but it helps us to see what's there and what might be causing
trouble, so everytime, you cannot shutdown windows, please run the
script and send in the output.
Comment 45 thorsten.martens 2003-01-28 10:41:22 UTC
*** Issue 8120 has been marked as a duplicate of this issue. ***
Comment 46 diane 2003-01-28 13:01:32 UTC
From what I have seen on this machine, when I know the machine is not
going to shutdown, its too late.  It is frozen in a state where the
windows splash screen is up, and no controls work to get me back to
where I might be able to run the script.  Is there a set of keystrokes
or something that can bring up the dos prompt when in this state?  My
typical action when the machine goes into this state is to physically
turn off the power supply, and then deal with the ms brow beating the
next morning during power up.

Perhaps you are thinking that the window frames of OOo are not
visually closing, when perhaps what people are trying to explain is
that the operating system will not shutdown?  Or are there two (or
three) seperate issues occurring that are accidentally being meshed
together?  I have tied the soffice (not responding) issue to this,
after making it a habit to watch my task manager (via cntl-alt-del). 
Killing this soffice (not responding) process before a pc shutdown
usually helps me avoid an incomplete shutdown.  And from what I have
witnessed, when a program is saying (not responding) in this box, it
is indeed hung.  I have witnessed my machine in a frozen state, killed
the soffice (not responding) task, then witnessed the machine resume
its other adventures.

With this in mind, what is the best way to collect some useful info to
resolve this?  Sure wish you could see it for yourself...
Comment 47 lo 2003-01-29 12:30:06 UTC
As far as I can see, this problem only seems to affect verision 1.0.1.
from what I have found in the CVS, changes have been made to the
source concerning quickstarter and shutdown behaviour... can anyone
who is experiencing this problem check if it is still in 1.0.2
Comment 48 erpel 2003-01-31 21:23:53 UTC
Today, I experienced the phenomenon again.
The quickstarter was deactivated and all (foreground) applications
were closed, but I was unable to shutdown WinXP Pro.
I ran the script and it said: "open frames = 0".
After killing soffice.exe in the task manager, everything went fine.

We are still using 1.0.1, but I plan updating our office LAN to 1.0.2
as soon as ther german builds are available. (Many of our users only
speak german)
Comment 49 diane 2003-02-01 17:53:43 UTC
I have just installed 1.0.2 on my win98se box. I am writing this here
to record upgrade time and date, in hopes of not seeing this issue again!
:)  ...will try to come back in a week or so to report my results.
Comment 50 diane 2003-02-02 01:57:00 UTC
Well, I'm back again, like a bad penny.  I have seen my soffice in
(not responding) mode again in my task box (via cntl-alt-del), while
running OOo 1.0.2.  While you say that this is not always a sign for a
hanging office, I really have doubts about that.  I have been working
in between OOo, Mozilla 1.1 (with no quicklaunch activated in
Mozilla), and AutoCADLT 98.  I am not really sure what other data to
provide at this point.  

One thing I can say, that I do not believe I have said or read before,
is that the soffice task is running only when there is no OOo doc
opened.  As soon as I open an OOo doc, the OOo task shown in the task
manager (via cntl-alt-del) becomes "DocName.ext -
1.0.2".  When I close the doc, the task becomes "soffice" again.  If I
have two OOo docs opened, the task shows the latest doc opened in the
"DocName.ext - 1.0.2" name format.  I rarely (if ever)
see the "DocName.ext - 1.0.2" (not responding).  

I have learned that when I see the soffice (not responding), I can
kill it by exitting the quickstarter thru its menu, instead of "End
Task".  The soffice (not responding) disappears from the task list,
but not immediately.  I have seen it linger for a few seconds after
exitting the quickstarter via its menu.  When I saw this, I left the
task box by pressing cancel, went back into it again via cntl-alt-del,
and the soffice task was gone.  (I thought I was going to have a great
opportunity to run the test script there for a second or two!)

I am thinking I have beat to death what I can say about the things I
have seen with this issue.  I surely wish we could get to the bottom
of it. 

I did see comments written by Mathias Bauer in the discuss list
written on 22 Jan 2003: 

"AFAIR there was a bug that the OOo quickstarter prevented Windows
from shutting down. It was fixed, but I don't remember in which
version.  Surely it was not fixed before the new OOo1.0.2 version or
the SRX643c build."

It looks like it still exists in 1.0.2, unless I am speaking with
assumptions, and the soffice (not responding) message is not a clue
that the issue still exists. In my own observations tho, it is a clue.
 If it truly has been fixed, it might be good to add that info to this
issue....unless that is what the "target milestone" is trying to tell
us.  From what I can see on the discuss list and other issues, several
users are living  with this issue.  The odd thing is many are not
seeing it too.  There has to be a clue there.  What is the delta
between the machines not seeing it and the machines that are?  Could
it be a conflict between Mozilla and OOo?  Is it possible that both
progs are trying to grab the same memory space, but neither knows the
other is there?
Comment 51 apienk01 2003-02-02 18:28:48 UTC
I also see no change after installing Ooo1.0.2, but I don't think 
Mozilla is to blame. I use IE6.0 on my laptop and never had any other 
browsers. As I wrote before, my problem has always been with suspend 
mode - shutdown is OK. After some investigation it seems that this 
problem occurs when a Ooo document was opened AND closed. After clean 
boot, with QuickStart in the tray, everything works fine, and is 
still fine when I first open a document. After I close it, the issue 
starts to manifest and stays whatever I do in Ooo, until I manually 
close soffice.exe.
Comment 52 carsten.driesner 2003-02-04 07:21:18 UTC
I want to clarify that the "Quickstarter prevents Windows from 
shutdown" bug (internal bug id #95896# ) was fixed for OpenOffice 
This bug fix is definitely part of OpenOffice 1.0 and later versions.
If this bug wasn't fixed in OOo 1.0.x you won't be able to shutdown 
Windows with a running Quickstarter at all. As this problem is not 
easy to reproduce and even occurs without running the Quickstarter 
it must be something else.
Comment 53 diane 2003-02-06 15:59:22 UTC
I can verify the comments made by apienk01@OOo.  If I leave my time
sheet open for the day, I get the soffice(not responding) much, much
less; typically after I close the timelog file, leaving no OOo files
open.  This is running OOo 1.0.2 on Win93SE (w/mozilla).  I think the
clue is here.   It is still not reproducible upon command, but it is
more controllable to know this.
Comment 54 diane 2003-02-06 16:01:11 UTC
oops...make that win98 not win93.
Comment 55 diane 2003-02-11 22:28:33 UTC
I was gifted with an opportune moment today, but it seems I was not
prepared for it.

I have soffice(not responding) in my task manager at this very moment.
 My quickstarter icon is disappeared at some point when I
was not paying attention.  I do not have any OOo files open. 
So...this would be a great time to run the test script. 
Unfortunately, I did not install it into OOo 1.0.2.'s what
we did, maybe there will be some clues here:  We went into the OOo
1.0.1 directories, and we copied the module1.xba file from
c:\ProgramFiles\OOo1.0.1\user\basic\Standard\ dir to the same dir in
OOo1.0.2, hoping to move that script along with it.  (Surely hope I
haven't broken things by doing partner says he
right?)  Anyway...then we attempted to run the test script.  It did
not make a shutown log.  Boo-hoo!  I have such an opportune moment
here: this state does not occur very often.  

I cannot open OOo right now.  There is no response, no matter which
way I try to get it to start.  I will have to kill the soffice (not
responding) process.  It is likely once I do this, all clues will be
gone, and I will be running as normal again.  Thought I'd write this
here in spite of our failed attempts, just in case it makes something
visible to you that we are not wise enough to see.  I guess I will
attempt to get that script installed again too...for next time.

I will procrastinate my kill just a bit, in case there is some chance
someone reads this when it arrives, and can help me capture some data
from it.  Is that too hopeful?  :)
Comment 56 lo 2003-02-19 13:37:41 UTC
I still found no way to reproduce this. Maybe someone who has an
office in this state can generate a userdump that I can analyze.
I am not sure how well all of this works with Win98 - your mileage may
- get and install the microsoft debugging tools from
- when you have an soffice process that is preventing your computer 
  from shutting down do the following:
  - Start WinDbg
  - Choose File/Attach to a Process (F6)
  - Select the soffice.exe process
  - in the command window type 
    '.dump /mhiprR c:\soffice.dmp'
- attach soffice.dmp to this issue, the r and R options will remove
  privacy related stuff from the dump, so there should be no risk in
  posting it here. However, you can email the dump to me if you feel
  uncomfortable with posting it here.

(You might need to install the windows ME version of the debugging
tools to run this with win98... I have no win98 machine on which I can
test the procedure at this moment)
Comment 57 Mathias_Bauer 2003-02-20 18:29:06 UTC
target adjusted
Comment 58 lo 2003-03-04 09:15:47 UTC
The state in which the office is, when it prevents windows from
shutting down is still not clear. In case we don't get any dump within
the next week, I will retarget this bug to 2.0.
We are dependent on external reports here since we are not able to
reproduce it in-house
Comment 59 Mathias_Bauer 2003-03-11 08:52:03 UTC
Retargeted for OOo2.0 (as long as no reproducable scenario makes it
possible to work on that again).

As long as this bug is not reproducable on a regular base, it is not a
showstopper for the OOo1.1 release.
Comment 60 Unknown 2003-03-11 18:38:23 UTC
We have this problem occuring on every PC running XP (with or without 
all patches) and having quickstarter running.

It does NOT happen if the system is brought up and shutdown after all 
processes are started.
It does NOT happen if the system is brought up and shutdown after 
opening a new document and closing but not saving.
It does NOT happen if the system is brought up and shutdown after 
opening an existing document from a shared network directory and 
closing but not saving.

But I can tell you that in our case it happens every evening when our 
users try to shutdown.

I'll try to do further diagnostics.
Comment 61 Unknown 2003-03-12 20:25:36 UTC
For what it is worth, I also have this problem. I have about 20
machines running Windows 2000, and there are 3 machines (that I know
of) that have this problem--at least one user had the problem, then it
went away, and then it came back. The problem on one machine went away
when I upgraded to 1.0.2. 
Comment 62 erpel 2003-03-18 12:40:16 UTC
I have attached a user dump of the soffice.exe process that prevents WinXP Pro from 
shutting down correctly. (WinXP Pro ger, OOo 1.0.1 ger)
Comment 63 erpel 2003-03-18 12:41:22 UTC
Created attachment 5128 [details]
soffice.exe mini user dump
Comment 64 erpel 2003-03-27 15:09:22 UTC
Created attachment 5283 [details]
Another mini user dump (same PC)
Comment 65 lo 2003-03-31 13:38:22 UTC
when taking a minidump, please also issue the commen '~*kp' in windbg
and include the output aswell, I had problems constructing the
environment for the dumps, and this would helpo me to verify my results.
You can also load up an existing dump and do ~*kp then
Comment 66 diane 2003-04-10 22:47:57 UTC
It will be interesting to see if this glitch exists in 1.0.3.  I see a
bug fix in the lower section of "other bugs" in the list of bug fixes
on the 1.0.3 release notes page:

Office crashes when trying to save files in a Win98 peer to peer network

Suppose this is a squirrelly case of what was seen in that bug?  It
seems most who are seeing this are on a network, and it seems like the
soffice(not responding) occurs after closing of a file, which usually
requires a save first.  I am pretty sure ours is a peer to peer type
Comment 67 thorsten.martens 2003-04-11 10:56:07 UTC
*** Issue 12559 has been marked as a duplicate of this issue. ***
Comment 68 prgmgr 2003-06-17 17:44:58 UTC
*** Issue 10753 has been marked as a duplicate of this issue. ***
Comment 69 prgmgr 2003-06-19 21:17:19 UTC
*** Issue 14436 has been marked as a duplicate of this issue. ***
Comment 70 prgmgr 2003-06-19 21:22:36 UTC
*** Issue 14436 has been marked as a duplicate of this issue. ***
Comment 71 farhiz 2003-08-01 07:53:27 UTC
I've noticed that whenever I have opened a pdf in Acrobat Reader 
sometime later that soffice stops responding in the end task window. 
Any correlation?
Comment 72 rtrout 2003-08-03 23:38:57 UTC
No, I don't believe this is related. You may like to open another bug
if it is affecting you.
Comment 73 apienk01 2003-09-02 09:15:11 UTC
I can confirm that on my system the shutdown bug is present in both
1.0.3 and 1.1RC3. I also noted an interesting effect. Apparently, is preventing one of applications I use - a dictionary
- from starting (opening main program window). After I close Ooo,
dictionary opens immediately. This dictionary is quite old (I believe
it was written for Win95), but it doesn't show such behaviour with
other apps. Should I test this relation in any way, please let me know
how to do it.
Comment 74 prgmgr 2003-10-30 20:28:12 UTC
*** Issue 14925 has been marked as a duplicate of this issue. ***
Comment 75 thorsten.martens 2004-05-03 12:31:23 UTC
"According to the roadmap
( this issue was retargeted to OOo
Comment 76 rtrout 2004-05-03 23:58:45 UTC
Sorry - I fail to understand where in the roadmap this bug is moved to OOo
Later. Please explain or return to 2.0.
Comment 77 lo 2004-05-04 09:44:36 UTC
As long as there is no way of reproducing this there is no way this can be
fixed. So it can't be on the roadmap.
I know, there are people having this problems but I can shutdown any (finite)
number of machines available to me without a glitch and thus have no chance in
finding a cause for this problem. 
As soon as a way is found to reproduce this I will be more then happy to debug
it and get rid of it.
Comment 78 jwt 2004-05-20 16:57:27 UTC
I do not think that this is primarily a shutdown problem, though it may cause
such problems on some machines.  I do not have a problem with shutting down.  I
have the problem as previously described that with quickstart activated and when
I do not have an OOo document open the close programme dialogue (i.e. when
pressing ctrl+alt+del) shows Soffice [Not responding].  Normally this does not
cause a problem, although it still should not happen.  However, sometimes when
my computer hangs, closing Soffice frees it up.
Comment 79 john_winterflood 2005-02-08 03:00:12 UTC
I have had many problems relating to "Soffice (Not responding)" for a long time
and having just come across this issue report today, I thought I should add my
experiences.  I am currently running Win98SE and OOo 1.1.2.  The fault is
unfortunately not very reproducible but if I use OOo Draw a couple of times
during a day, I will almost certainly have problems with other programs (eg
Eudora) not firing up (until I ctrl-alt-del and get rid of "Soffice [Not
responding]" item in the task list), or the system not shutting down.  Having
seen these issue reports, I thought I would experiment to see if I can get the
fault to appear reliably and as a result found something which seems to be
readily reproduced and is almost certainly closely related.  After rebooting my
system from scratch and entering the Windows network logon password, If I press
Ctrl-Alt-Del, I can see Soffice (quickstarter) in the list of tasks, but if I
try to "End Task" it says "This task is not responding. It may be busy ... etc".
 This seems to be a prime cause of many associated problems, and is certainly
easy to reproduce as it is in this state immediately after every startup with no
other action required!

An obvous bug that I could reproduce reliably directly from restart (about 20
times but now I can't) goes as follows :
1) Reboot my sytem,
2) Enter networking password,
3) Start Windows Explorer (from start menu),
4) Open a folder, and two subfolders,
5) Double-click on a "file.sxd" to fire up openoffice,
(Strangely OOo comes up in a background window (behind Windows Explorer) rather
than in foreground).
6) Click on the close button in the top right hand corner (without bringing it
to the foreground).
7) Double-click on the same "file.sxd" to fire it up again,
This time it starts to come up in a foreground window (in front of Windows
Explorer) but stops short of opening the file.  The system has not locked up,
but OOo has definitely fallen asleep and anything which depends on it being
awake (such as firing up an application such as Eudora or shutting down the
system) will presumably hang when you try.

Up to this point the symptoms occured quite reliably, but after this point the
results differed depending I guess on time delays etc.  If I wait a little while
and then press Ctrl-Alt-Del I can see in the task list "file.sxe - 1.1.2 [Not responding]" (If I don't wait so long the [Not
responding] note is not yet there).  If I now escape out of this little task
display listing OOo will generally wake-up, open the file and proceed as normal!
 However sometimes if I scroll up and down the task list in the display window,
and then escape, it will not wake-up.  It will wake-up if I escape a few more
times - particularly if I don't do any scrolling!

I have noticed that even if I exit Quickstarter (by right-clicking on the little
icon at the right hand end of the task bar and choosing exit), it will be
restarted when I invoke and exit from OOo draw.  This does not seem like correct
operation either.  Also I have often seen two instances of Quickstarter in the
task list (and if I remember rightly even two little double seagull icons at the
right hand end of the task bar).

I hope these symptoms might aid the solving of this problem.  For myself this
bug has been the main ongoing problem that I have had with OOo.  I have upgraded
to later versions in the hope that it would dissapear, and I have been hoping
that a later operating system (I still run Win98SE) would solve the problem. 
However from other postings here it looks like I should not hold out any hope of
Comment 80 jwt 2005-05-09 15:59:28 UTC
OK, I can reproduce the issue.
With quickstarter running normally (i.e. the task manager (Ctrl+Alt+Del) shows
the two entries for soffice (.bin and .exe presumably).
Open Writer (blank document) and close it.
Open Firefox, log in and get to this page
Open Thunderbird, open an e-mail, select and copy some text (Ctr+C).
Paste it into this window in the issue tracker page in Firefox (Ctr+V).
Undo the last action (Ctr+Z).
Hey presto, the task manager shows the first entry for soffice as (not responding).
(I found this as a result of pasting spam messages to Spamcop to report them).
I am using OOo 2.0 beta (1.9.95) on Windows ME.
Comment 81 john_winterflood 2005-05-09 16:33:23 UTC
Have you tried getting Soffice to "end task" before it is even listed as "not
responding"?  (ie ctrl-alt-del, select Soffice, then end-task).  When I do this
on my system it immediately comes up as "This task is not responding. ..." -
even directly after a fresh boot and before having done anything else on the system!

Surely this is incorrect operation and is the easiest symptom to check for and
reproduce?!  I am frankly surprised that even though I reported this 3 months
ago, no one interested in this issue has reported whether they can reproduce it
or not!
Comment 82 jwt 2005-05-09 16:41:10 UTC
Yes, that happens for me too.
Comment 83 lo 2007-03-06 16:58:00 UTC
dispatch to framework team
Comment 84 carsten.driesner 2007-03-08 10:01:16 UTC
cd: Accepted. I will check the description from jwt, may be I can reproduce the
Comment 85 robbk 2009-06-08 12:40:25 UTC
Our users have no longer reported this problem since about version 2.4. Not sure
if the problem has been fixed or if this is a coincidence. Removing my vote.
Comment 86 Olaf Felka 2009-06-30 11:02:36 UTC
@ cd: Due to the last comment I'm tending to close this issue.
@ erpel: Do you have similar findings in OOo 3.1?
Comment 87 stoffell 2010-07-23 11:00:38 UTC
To me this issue is still occuring. Windows 7 english, OpenOffice 3.2.1 US English.
Comment 88 stoffell 2010-07-23 11:02:23 UTC
This is also written about it somewhere else: