Issue 70402 - Many Icons in "Further objects" dialog not shown when file assoziation activated during installation
Summary: Many Icons in "Further objects" dialog not shown when file assoziation activa...
Status: CONFIRMED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: 680m188
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-13 15:05 UTC by michael.ruess
Modified: 2017-05-20 10:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description michael.ruess 2006-10-13 15:05:27 UTC
When having the file assoziation for MS Office filetypes has been activated in
the OOo installation (in setup), many Icons will not be shown in the "further
objects" dialog when the "insert as icon" option is clicked. Just travel through
the OLE server list and you will notice that many icons are not show. Even when
inserting these into document, the iconified object will not have a picture.
Comment 1 biosbvba 2007-09-10 09:55:55 UTC
This have nothing to do with the file association.  It also happens when you 
deselect this during setup.  I also notice that this problem appears only on 
WinXP (SP1 and SP2), not on Win2000.
Any idea if there's a workarround?
Comment 2 biosbvba 2007-09-11 15:31:14 UTC
I found that this is a issue with displaying icons / graphics.

When you want to change the icon and browse p.ex to 
C:\WINNT\Installer\{90110409-6000-11D3-8CFE-0150048383C9}\xlicons.exe on a 
WIN2000 pc, you see all the icons.
If you do the same on a XP for C:\WINDOWS\Installer\{90110409-6000-11D3-8CFE-
0150048383C9}\xlicons.exe, you see only a few of the icons in this file.

Can someone give me more information so that I can find a workarround?
Comment 3 Mathias_Bauer 2007-12-04 16:19:34 UTC
according to release status meeting -> target 3.x
Comment 4 mikhail.voytenko 2008-04-17 12:47:59 UTC
The further objects dialog is actually system dialog. As far as I know Wordpad
uses it as well to insert OLE objects, and the same problem is reproducible in
the Wordpad dialog. So this is just a system problem. And the inserted object
has just the icon it has got from the dialog.

I doubt that there is a workaround for this problem, otherwise it would be used
in Wordpad with high probability. So the only way seems to be the implementation
of the own dialog.
Comment 5 Marcus 2017-05-20 10:55:34 UTC
Reset assigne to the default "issues@openoffice.apache.org".