Issue 70456 - edit links should be easier to discover / images should not be linked as default
Summary: edit links should be easier to discover / images should not be linked as default
Status: CLOSED DUPLICATE of issue 15381
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.4
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-16 00:36 UTC by nekohayo
Modified: 2006-10-16 13:32 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description nekohayo 2006-10-16 00:36:10 UTC
Copy-pasting contents from a webpage that contains images links the images by
default (I object to this behavior, but I assume it is already like that for a
reason?), and the user cannot easily figure out how to "save" the images with
the document.

The only way I have been told is to use the edit menu and use the "Links..."
item. I would like that to be availabe in a popup menu when clicking on images
and/or in the image toolbar.

If the user does not know about that, he will just assume his images are "saved"
and will have very bad surprises. Here are the consequences of the current "link
images" default behavior:
* Everytime you load that document, if the images were on the Internet, you will
need an internet connection
* Even if you have a fast 3mbits internet connection, it will make your computer
hang for a LONG time loading those images.
* Moving through the pages of a document makes you lag in a terrible way (images
are loaded one at a time (or so it seems!)
* Deleting those images is painful because, once again, you lag while doing that.
* If you copy-paste contents from a local HTML page that has images, and delete
the page/images OR move them, the images will be broken inside the ODT file and
you will have no way of accessing them.
Comment 1 eric.savary 2006-10-16 13:29:43 UTC
Reassigning
Comment 2 eric.savary 2006-10-16 13:30:03 UTC
Reassigning
Comment 3 eric.savary 2006-10-16 13:31:10 UTC
duplicate

*** This issue has been marked as a duplicate of 15381 ***
Comment 4 eric.savary 2006-10-16 13:32:12 UTC
Closed