Issue 70518 - Build breaks in hsqldb (issue 51409 is back /again/)
Summary: Build breaks in hsqldb (issue 51409 is back /again/)
Status: CLOSED FIXED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: 680m186
Hardware: All All
: P2 Trivial (vote)
Target Milestone: OOo 2.1
Assignee: thb
QA Contact: issues@dba
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2006-10-17 12:54 UTC by lohmaier
Modified: 2007-01-22 15:50 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
suggested patch (1.78 KB, patch)
2006-10-17 14:05 UTC, Frank Schönheit
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description lohmaier 2006-10-17 12:54:12 UTC
I really wonder what could prevent losing the patch (necessary to build with ant
1.5.x) again and again.

see issue 51409 for the initial issue, and issue 61760 for the first time it got
lost.
Comment 1 lohmaier 2006-10-17 12:55:25 UTC
intended to cc vg (who integrated), not vq...
Comment 2 Frank Schönheit 2006-10-17 14:03:51 UTC
more care from those people changing hsqldb/hsqldb_1_8_0 (me, in this case)
Comment 3 Frank Schönheit 2006-10-17 14:05:30 UTC
Created attachment 39826 [details]
suggested patch
Comment 4 Frank Schönheit 2006-10-17 14:07:09 UTC
The attached patch should fix this - cloph, could you please try?

fs->hr: Should/Could we master-fix this for m189, since it's a build-breaker for
people using an older Ant (which nonetheless is claimed to be supported by us?)
Comment 5 Frank Schönheit 2006-10-17 14:09:55 UTC
fs->cloph: Would you agree to be the QA-rep for a CWS containing only this fix?
Comment 6 lohmaier 2006-10-18 23:12:06 UTC
I can only build on linux and Mac PPC/X11

The patch works fine.
Comment 7 Frank Schönheit 2006-10-19 06:23:13 UTC
I'll do the builds myself. Since this is a mere developer fix, you can simply
verify this by saying verifying the proper patch made it into the CWS. Let's
hang this low.

patch checked in in CWS hsqlandant01
Comment 8 Frank Schönheit 2006-10-23 11:00:25 UTC
fs->tbe: please verify in CWS hsqlandant01
Comment 9 Frank Schönheit 2006-10-23 11:00:53 UTC
s/tbe/thb/
Comment 10 thb 2006-10-23 11:03:58 UTC
Setting a target, trying fix on my ole Sun...
Comment 11 thb 2006-10-23 11:13:16 UTC
Verified in CWS.
Comment 12 lohmaier 2006-10-24 14:23:03 UTC
While I expected to get a "CWS is ready" mail from EIS, I only got one
"QARepresentative changed" mail.. So I just want to let you know that I wasn't
unwilling to do QA, it is just that the notification system didn't work as I
expected.
Comment 13 Frank Schönheit 2006-10-24 15:07:11 UTC
no problem. We just decided to do it the quick way since Thorsten needed the fix
for setting up a build bot ...
Comment 14 jens-heiner.rechtien 2007-01-22 15:50:51 UTC
Close issue.