Issue 70582 - moving text frame with cursor keys always moves downwards
Summary: moving text frame with cursor keys always moves downwards
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.4
Hardware: All Windows XP
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
: 70623 73960 83068 86559 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-10-19 03:40 UTC by gleppert
Modified: 2013-08-07 14:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Problem moving text boxes with microstepping (9.69 KB, application/msword)
2006-10-19 03:42 UTC, gleppert
no flags Details
Problem moving text boxes with microstepping (9.69 KB, application/vnd.oasis.opendocument.text)
2006-10-19 03:42 UTC, gleppert
no flags Details
Test file for microstepping bug (7.52 KB, application/vnd.oasis.opendocument.formula)
2008-04-07 16:10 UTC, savebart
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description gleppert 2006-10-19 03:40:57 UTC
If  I want to move the textboxes with the cursor/arrow keys, it works fine. If I
want to use the microstepping, I usually press the Alt key together with the
arrow keys. Try it out, any arrow key will move the textbox downwards. No other
direction is possible.

This happened since I installed version 2.0.4. I didn't experience that
behaviour with 2.0.3.
Comment 1 gleppert 2006-10-19 03:42:03 UTC
Created attachment 39869 [details]
Problem moving text boxes with microstepping
Comment 2 gleppert 2006-10-19 03:42:32 UTC
Created attachment 39870 [details]
Problem moving text boxes with microstepping
Comment 3 gleppert 2006-10-19 03:47:11 UTC
both attached files are identical, sorry for submitting twice. 
Comment 4 allad 2006-10-19 15:36:39 UTC
I got the same problem here (with 2.0.4).

I know this bug from previous versions.
Comment 5 michael.ruess 2006-10-23 10:17:09 UTC
MRU->OS: I cannot see this with a newly created docuement; only inthe attached -
moving the frame with cursor or ALT-cursor keys will always move the frame downwards
Comment 6 Oliver Specht 2006-10-23 12:31:45 UTC
It calls SwFEShell::SetFlyPos(). Alt+Left|Right really moves the object to the
left|right but also down.
Comment 7 Oliver-Rainer Wittmann 2006-10-23 14:41:45 UTC
accepted.

defect cause:
method <SwFlyAtCntFrm::SetAbsPos(..) doesn't consider compatibility option "Use
OpenOffice.org 1.0/1.1 object positioning", which has influence on the alignment
areas of an anchor paragraph for an anchored object.
Comment 8 Oliver-Rainer Wittmann 2006-11-09 13:29:59 UTC
*** Issue 70623 has been marked as a duplicate of this issue. ***
Comment 9 michael.ruess 2007-01-29 10:23:25 UTC
*** Issue 73960 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2007-10-31 11:23:18 UTC
*** Issue 83068 has been marked as a duplicate of this issue. ***
Comment 11 Mathias_Bauer 2007-12-03 14:48:27 UTC
according to release status meeting -> 3.x
Comment 12 michael.ruess 2008-02-29 09:42:36 UTC
*** Issue 86559 has been marked as a duplicate of this issue. ***
Comment 13 savebart 2008-04-07 16:07:25 UTC
I have the same problem with 2.3 version.
Moreover, the microstepping increment changes when the anchor point jumps from
one paragraph to the next.
Comment 14 savebart 2008-04-07 16:10:52 UTC
Created attachment 52623 [details]
Test file for microstepping bug
Comment 15 savebart 2008-04-07 16:16:35 UTC
In the file "FrameTest.odt", select the frame and move first upwards with Up
arrow key, in order to make the anchor point jump to the first paragraph. Then
move the frame downwards with Alt+Down Arrow, and see the microstepping
increment to change  when jumping back to the second paragraph.
Comment 16 Oliver-Rainer Wittmann 2008-04-28 13:49:40 UTC
Due to the duplicates and votes I will try to consider a fix for OOo 3.1
Comment 17 Oliver-Rainer Wittmann 2009-01-12 11:38:18 UTC
fixed in cws sw31bf04 - changed file:
/sw/source/core/layout/flycnt.cxx, rev. 266143
Comment 18 Oliver-Rainer Wittmann 2009-01-21 14:32:47 UTC
OD->MRU: Checked in internal installation set of cws sw31bf04 - please verify.
Comment 19 michael.ruess 2009-01-26 15:12:20 UTC
Verified fix in CWS sw31bf04.
Comment 20 larysahitekschool 2009-03-26 22:08:07 UTC
Verified fix in master version OOo-dev 3.1.0 (OOO310m7)
Comment 21 michael.ruess 2009-03-26 22:30:18 UTC
Thanks for checking, larysa. Closing issue.