Issue 71018 - python interface to Footnote
Summary: python interface to Footnote
Status: UNCONFIRMED
Alias: None
Product: App Dev
Classification: Unclassified
Component: api (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: PC Windows XP
: P3 Trivial
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-30 22:10 UTC by jobermark
Modified: 2013-02-24 21:07 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jobermark 2006-10-30 22:10:54 UTC
I need to automatically find the actual footnote mark, not its content, but its
location in the document.

According to the API reference at
http://api.openoffice.org/docs/common/ref/com/sun/star/text/Footnote.html, the
class com.sun.star.text.Footnote should give access to two different text
anchors, one in the XFootnote interface for the label, and one in the XText
interface for the note text.  But no matter how I have interrogated the thing, I
can only select or edit the note text.

I am working in Python, and think this may be the root of my problem.  Since the
python bridge does not really use queryInterface, I think I am always getting
the first interface with the corresponding functions in it, and I need the other
one.  

And explicitly calling queryInterface() does not seem to help.  If I understand
the interface, the python statement

    [getattr(fn.queryInterface(x), 'String', None) for x in fn.getTypes()]

should theoretically get me two different string values, and a bunch of None
entries.  Instead I get the note text string over and over.
Comment 1 jsc 2006-10-31 08:34:48 UTC
jsc -> tl: Thomas, can you please check this from an API persepctive. If it is
no API but a Python related issue please send it back to me. In case of Python I
probably see no chance to fix the issue because of missing maintenance  of the
Python binding
Comment 2 thomas.lange 2007-08-08 07:39:23 UTC
.
Comment 3 Martin Hollmichel 2007-11-09 17:28:23 UTC
set target from 2.x to 3.x according to
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 4 stefan.baltzer 2008-10-29 14:17:42 UTC
SBA: This issue has a target set but is still in state of "Unconfirmed".
Please re-check with OOo 3.0 or younger if it is (still) valid.
Then confirm it or set an appropriate resolution.
Thank you.
Comment 5 stefan.baltzer 2008-10-29 14:24:47 UTC
SBA: This issue has a target set but is still in state of "Unconfirmed".
Please re-check with OOo 3.0 or younger if it is (still) valid.
Then confirm it or set an appropriate resolution.
Thank you.
Comment 6 hanya 2012-07-24 06:58:23 UTC
It seems the problem is misunderstanding the related API.
- getAnchor method inherited from css.text.XTextContent provides the text range to the field inserted.
- css.text.XText interface provides access to the content of foot note text. The content can be edited starting with getText call.
This can be closed as invalid in my opinion. But I am not clear on the problem on version 2.0.3, the above description is on AOO 3.4.