Issue 71055 - tab fill in text box have wrong appearance
Summary: tab fill in text box have wrong appearance
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Draw
Classification: Application
Component: ui (show other issues)
Version: OOo 2.0.4
Hardware: All Linux, all
: P3 Trivial with 2 votes (vote)
Target Milestone: OOo 2.2
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2006-10-31 23:11 UTC by Joe Smith
Modified: 2006-12-01 17:03 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Document with screenshots demonstrating problem (51.29 KB, application/vnd.oasis.opendocument.graphics)
2006-10-31 23:13 UTC, Joe Smith
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Joe Smith 2006-10-31 23:11:35 UTC
Text paragraphs in text box objects may have tab stops and fill styles set. The
appearance of the tab fill has changed between OOo 2.0.2 and 2.0.4, so that the
fill characters no longer fill the tab space. So, rather than this:

  Left..............Right

You see this:

  Left.     .      .Right

This happens for all the tab fill styles.

It happens for text boxes in Writer as well.

Steps to reproduce:
1) File > New > Drawing
2) Create a text box ("T" toolbar icon)
3) Enter text: A<tab>B<tab>C
4) Format > Paragraph
5) Create two tab stops (e.g. 2cm, 5cm)
6) Change the tab fill style for both tabs to ".........."
7) OK

Note that only three dots are used for each tab stop.
Comment 1 Joe Smith 2006-10-31 23:13:38 UTC
Created attachment 40202 [details]
Document with screenshots demonstrating problem
Comment 2 wolframgarten 2006-11-01 07:33:31 UTC
Reassigned.
Comment 3 christian.guenther 2006-11-01 17:41:06 UTC
Set to new and change the target
Comment 4 christian.guenther 2006-11-01 17:44:20 UTC
I can reproduce the bug.
was ok in src680m173 and is broken in src680m178
Please have a look.
Comment 5 flaime 2006-11-03 14:05:32 UTC
The regression is related also to windows not only linux.
Comment 6 Joe Smith 2006-11-30 19:30:30 UTC
Based on my (unofficial) testing, this issue appears to be fixed in 2.1.0rc1
Comment 7 clippka 2006-12-01 10:13:05 UTC
I can also confirm that this seems to be fixed in m194

cl->cgu: please officially confirm and close
Comment 8 christian.guenther 2006-12-01 16:45:35 UTC
I can also reproduce that it works correct in the 195.
I close the issue as invalid.
Comment 9 christian.guenther 2006-12-01 16:46:37 UTC
I close the issue as invalid.
Comment 10 Joe Smith 2006-12-01 17:03:47 UTC
"INVALID"? Why not FIXED?

The issue was confirmed for 2.0.3/4--was nothing done to fix it?

I hope it didn't just mysteriously appear and disappear.