Issue 71138 - AutoCorrect: Disabling of "Capitalize first letter [...]" option doesn't work for single 'N' character
Summary: AutoCorrect: Disabling of "Capitalize first letter [...]" option doesn't work...
Status: CLOSED WONT_FIX
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.4
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-11-03 09:04 UTC by d_walczak
Modified: 2007-01-16 11:06 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description d_walczak 2006-11-03 09:04:10 UTC
--== Problem overview: ==--
OOC can't be forced to keep 'n' letter lowercase when it's entered as single 
letter into separate cell.

--== Steps to reproduce: ==--
1) Disable Tools->AutoCorrect->Options->"Capitalize first letter of every 
sentence" option.
2) In the empty sheet, select A1 cell.
3) Press the 'a' key and the right-arrow key (A1 cell should contain single, 
lowercase 'a' letter and the B1 cell should be selected).
4) Press the 'b' key and the right-arrow key (B1 cell should contain single, 
lowercase 'b' letter and the C1 cell should be selected).
5) Optionally you can enter letters of range <'c','m'>. Everything should be ok 
for them. You can also step to the next point.
6) In the N1 cell, press the 'n' key followed by the right-arrow key. *BUG*: N1 
cell contains single, uppercase 'N' letter instead of expected, single, 
lowercase 'n' letter.
7) Optionally you can enter letters of range <'o','z'>. Everything should be ok 
for them.

--== Expected: ==--
Prevent OOC from changing the case of entered, single 'n' letter when the 
proper autocorrect option is disabled.

--== Additional info ==--
In fact, this bug occures even if all of AutoCorrect options are disabled. For 
cell contents starting with the lowercase 'n' letter, followed by any other 
character (for example 'space') everything is ok. Of course, the CapsLock was 
disabled when pressing the 'n' letter. :-).
Comment 1 d_walczak 2006-11-03 09:07:07 UTC
--== Additional system info ==--
System: polish version of Windows XP SP2
OpenOffice: english version
Comment 2 frank 2006-11-03 09:31:43 UTC
Hi,

please check under tools-options-OpenOffice.org Calc-Sort Lists that no list
entry with a single capitalized letter N exists. If so, either delete this list
or enter the letter with a leading apostrophe.

Frank
Comment 3 d_walczak 2006-11-03 09:45:28 UTC
'Tools'->'Options'->'OpenOffice.org Calc'->'Sort Lists' contained following 
list: "Pn, Wt, Åšr, Cz, Pt, So, N". The items represent shortcuts of week names 
in polish. When I have removed the last item ("N"), the problem was work/
arounded (the 'n' letter wasn't capitalized anymore).

It looks that the problem is related to the "Sort Lists" feature.

The 'Sort Lists' entry was included in the default installation of the OO (I 
didn't enter it myself).
Comment 4 d_walczak 2006-11-03 09:46:53 UTC
Errata:
The items represent shortcuts of day-of-week names in polish.
Comment 5 olly600 2006-12-19 14:39:56 UTC
ooqa- Windows XP, build OOE680_m6, UI english US
Cannot replicate

Comment 6 d_walczak 2006-12-20 12:00:48 UTC
Try to go to 'Tools'->'Options'->'OpenOffice.org Calc'->'Sort Lists' and add 
following list: "A, B, C". Then try to enter these letters into separate cells. 
On my system (Windows XP SP2 PL, OOo 2.0.4 EN) it results in the same problem 
as in previous case.
Comment 7 olly600 2006-12-28 11:23:07 UTC
As Frank (fst) indicated this is not a bug. Under tools->options->sort lists
the list entry needs to have single quotation marks ('') around it.



Comment 8 d_walczak 2006-12-28 12:09:55 UTC
Ok, your solution works. In case of following, example list, the letters aren't 
capitalized when entered in separate cells:
'A','B','C'.

However, the list (provided out of the box) which caused this issue to be 
reported has following form:
Pn,Wt,Åšr,Cz,Pt,So,N
instead of correct:
Pn,Wt,Åšr,Cz,Pt,So,'N'

I don't know where this localized list is taken from (I suppose that it is 
received from the system in some way, as I have polish version of the Windows 
XP and the list represents shortcuts of day of week names in polish). Even if 
the list is provided by the system, it should be processed to avoid behaviour 
described in the report.

I can agree that this issue could be given a lower priority but IMO it's still 
a bug.

--== Expected ==--
English version of OpenOffice installed on polish version of Windows XP should 
include correct sort list (Pn,Wt,Åšr,Cz,Pt,So,'N') instead of the current one 
(Pn,Wt,Åšr,Cz,Pt,So,N).
Comment 9 olly600 2007-01-10 09:48:56 UTC
English version of OpenOffice.org installed on polish version of Windows XP should 
include correct sort list (Pn,Wt,Åšr,Cz,Pt,So,'N') instead of the current one 
(Pn,Wt,Åšr,Cz,Pt,So,N).

See previous comments.
Comment 10 frank 2007-01-12 13:35:35 UTC
Hi,

this is not a defect, as the sortlist is created from locale data (l10n
framework) on installation. Doing it the proposed way would break other peoples
expectations and compatibility to MS Excel. So this is a wontfix Issue.

Frank
Comment 11 frank 2007-01-12 13:35:55 UTC
closed wontfix
Comment 12 ooo 2007-01-16 11:06:04 UTC
Just for the records: the apostrophe thing probably was a misunderstanding. The
_cell input_ has to be preceded by an apostrophe (single quote) to override
SortLists and AutoInput matching, not the SortList entry to be included in quotes.