Issue 71436 - writing aids cannot be enabled permanently
Summary: writing aids cannot be enabled permanently
Status: CLOSED FIXED
Alias: None
Product: lingucomponent
Classification: Code
Component: other (show other issues)
Version: 680m188
Hardware: All Windows, all
: P2 Trivial (vote)
Target Milestone: OOo 2.1
Assignee: stefan.baltzer
QA Contact: issues@lingucomponent
URL:
Keywords: oooqa, regression
: 71493 (view as issue list)
Depends on:
Blocks: 71134 71255
  Show dependency tree
 
Reported: 2006-11-10 21:46 UTC by andreschnabel
Modified: 2006-11-27 11:37 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description andreschnabel 2006-11-10 21:46:02 UTC
In SRC680m188 and OOE680m2 the writing aids (Spellchecker, Thesaurus and
Hyphenator) are disabled by default.

That means, for a fresh installation you need to enable these components to get
the tools working. 
In previous versions the tools have been enabled by default.

(I did noch check on linux / unix systems yet)
Comment 1 pavel 2006-11-13 08:22:43 UTC
Hmm, I think it is more than P3 Andre.

People will kill us with millions of questions like "it does not work" etc.

Who can analyze this issue?

Thomas?
Comment 2 michael.ruess 2006-11-13 09:12:09 UTC
Adding SBA to cc list.
Comment 3 andreschnabel 2006-11-13 18:38:16 UTC
this is getting even worse: 
after installing french dictionaries using DictOOo, the Spellchecker and
Thesaurus become disabled after OOo restart. 
try the following

- Start DictOOo and Install Dictionarie, Hyphenation and Thesaurus for French
(France)
- Restart OOo
- go to Extras - Option - Language Settings and make sure, all Writing Aids are
enabled 
- in the "Edid Modules" Dailog, Enable all writing Aids for FRench (France) and
German (Germany)
- Restart OOo

-> Spellchecker and Thesaurus are disbaled in Writing Aids, Hyphenation is
disabled in "Edit modules" for French and German


Please note, that all writing aids should have been enabled after the first
restart of OOo.
Comment 4 pavel 2006-11-13 18:40:33 UTC
*** Issue 71493 has been marked as a duplicate of this issue. ***
Comment 5 hjs 2006-11-14 10:52:39 UTC
*** Issue 71511 has been marked as a duplicate of this issue. ***
Comment 6 pb 2006-11-14 13:37:21 UTC
pb: I can reproduce it and because Thomas (tl) is sick I will have a look.
Comment 7 ooo 2006-11-15 12:03:31 UTC
on unix system (Debian and Fedora Core - Danish OOo) it more like the first
description Fri Nov 10 13:46:02:
install dictionary, restart application, enable spellcheker (_also_ under edit
modules), restart application: now you have a working spellchecker, even after a
restart of the computer
may make a difference that we in danish dont have thesaurus, but it is not
likely. because the danish OOo on windows is exactely like the description Mon
Nov 13 10:38:16
all builds OOE680m2 bulid 1
Comment 8 jjmckenzie 2006-11-15 15:01:10 UTC
Added MacIntosh Issue Tracker for 2.1 to this issue as a blocker.  If this is a
valid issue it definitely blocks release of the 2.1. 
James McKenzie
Comment 9 pb 2006-11-16 12:57:21 UTC
pb: I found out that the entries of linguistic.xcu are deleted on office start.
So all settings are lost. We think it could be possible that linguistic.xcu of
the user layer is incompatible to it of the share layer (which is written by
OOoDic). It is a presumption that the script of OOoDic has to be changed. But
because Thomas (tl) is sick this week and i don't have the knowledge, we have to
wait till monday. So I removed this issue from cws tl33.
Comment 10 thomas.lange 2006-11-20 12:57:47 UTC
Seems like this problem was introduced due to warning-free code because someone
out commented an essential line of code. :-/

Fixed in CWS tl34.
Files changed:
- svx/source/editeng/unolingu.cxx
Comment 11 thomas.lange 2006-11-21 10:10:47 UTC
.
Comment 12 stefan.baltzer 2006-11-21 17:06:03 UTC
SBA: Verified in CWS TL34.
Comment 13 stefan.baltzer 2006-11-27 11:37:11 UTC
SBA: OK in OOE680m5 Build 9093.
Closed.