Issue 71889 - Open document from website
Summary: Open document from website
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.0.4
Hardware: All Windows XP
: P3 Trivial with 1 vote (vote)
Target Milestone: OOo 2.3.1
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords:
: 64295 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-11-23 13:52 UTC by seva
Modified: 2009-04-28 09:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
target issue (763 bytes, text/html)
2007-11-05 12:29 UTC, aladdin2k7
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description seva 2006-11-23 13:52:28 UTC
I have problems when I try to open document from web site using Internet
Explorer (6, Windows XP sp2).
I disable ActiveX control so Internet Explorer saves file in temporary internet
files folder before opens document using OOo.
First time I try, all goes right.
Second time I try to open same file OOo return a error message like this: Object
not accessible. The object cannot be accessed due to insufficient user rights. 
It seems OOo is unable to open file stored in temporary internet files folder.
I had to disable so_activex.dll because it didn't recognize files I tried to
open from website.
OOo IE plugin showed me dialog to choose filter and then crash!
Comment 1 michael.ruess 2006-11-23 14:28:26 UTC
Framework issue.
Comment 2 thorsten.martens 2006-11-24 09:25:43 UTC
TM->UL: Seems to be yours, please have a look, thanks !
Comment 3 thorsten.martens 2006-11-24 10:20:56 UTC
TM->MAV: Upcoming error-message is reproducible, but filter-dialog isn´t shown.
So crash isn´t reproducible at this time. Will request file which might cause
the crash. Please have a look at the error-message. Thanks !
Comment 4 thorsten.martens 2006-11-24 10:23:03 UTC
TM->seva: please attach file that causes the crash. Thanks in advance.
Comment 5 seva 2006-11-24 10:27:39 UTC
I try with files on this website 
http://documentation.openoffice.org/HOW_TO/index.html
Comment 6 seva 2006-11-30 08:20:50 UTC
What about upcoming error-message?
Issue is stil unconfirmed...
Thanks.
Comment 7 mikhail.voytenko 2006-12-05 09:58:19 UTC
The reason why the document can not be opened second time should be investigated.
Comment 8 mikhail.voytenko 2006-12-05 09:58:58 UTC
Setting the target.
Comment 9 mikhail.voytenko 2007-01-26 14:29:49 UTC
The problem is that the MSIE locks the stream itself.
But the office should be able to open the document readonly in this case.
Comment 10 mikhail.voytenko 2007-02-16 11:46:44 UTC
MAV->TM: Please verify the issue.
Comment 11 thorsten.martens 2007-03-02 11:12:13 UTC
checked and verified in cws fwk61 -> OK !
Comment 12 kpalagin 2007-04-14 11:52:45 UTC
*** Issue 64295 has been marked as a duplicate of this issue. ***
Comment 13 bsector 2007-08-14 14:54:28 UTC
Its not work in windows 2000 and 2003 server
1 time open document.
2 times open in view mode, but click in edit mode and not open the document.
Comment 14 aladdin2k7 2007-09-07 10:01:50 UTC
I have reproduced the problem with OOo 2.3 RC1 which integrates cws fwk61.
The problem happened on Apache and IIS so it's a problem with IE cache processing ?

Updated also #64295 with attachement.
Comment 15 aladdin2k7 2007-09-12 14:38:46 UTC
Same result with OpenOffice.org 2.3 Release Candidate 3 (build OOG680_m5).
Comment 16 mikhail.voytenko 2007-09-13 14:55:26 UTC
Indeed, it looks like the change was lost during integration into the master. I
will integrate it in one of other cws.
Comment 17 mikhail.voytenko 2007-09-13 14:56:53 UTC
Reopening.
Comment 18 mikhail.voytenko 2007-09-13 15:04:55 UTC
I have commited the fix to cws fwk75.
Comment 19 aladdin2k7 2007-09-14 10:50:11 UTC
Great, Thanks !
So it will be included for 2.3.1 ?
Comment 20 mikhail.voytenko 2007-09-14 11:12:19 UTC
mav->aladdin2k7: Yes it should.
Comment 21 mikhail.voytenko 2007-09-18 12:52:27 UTC
MAV->TM: Please verify the issue.
Comment 22 uwe.luebbers 2007-10-24 15:13:49 UTC
verified in CWS fwk75
Comment 23 aladdin2k7 2007-11-05 10:55:44 UTC
Some feedback :
- When I open the document for the second time, now OOo open it but the document
is read only.

- OOo open and close a document immediately when the link has a target=_blank,
works with other target.

I have attached a testcase for the target problem. (index.html)

Tested with OpenOffice.org 2.3 (build OOG680_m8) (cws fwk75 included).
Comment 24 aladdin2k7 2007-11-05 12:29:42 UTC
Created attachment 49425 [details]
target issue
Comment 25 mikhail.voytenko 2007-11-05 13:52:21 UTC
mav->aladdin2k7: As I have written the MSIE locks the opened file stream after
the first opening. So the fix was to workaround this problem and to open the
document readonly in this case.
Comment 26 aladdin2k7 2007-11-05 14:08:17 UTC
mav->aladdin2k7 : Ok my mistake ;-)

Do I open a new issue for the target issue ? or I follow this issue ?
Comment 27 aladdin2k7 2007-11-05 15:55:42 UTC
check issue #83333
Comment 28 thorsten.martens 2009-04-28 09:45:18 UTC
closed