Issue 71930 - Superscript for ordinal numbers does not work if followed by punctuation
Summary: Superscript for ordinal numbers does not work if followed by punctuation
Status: CLOSED DUPLICATE of issue 67261
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.1
Hardware: PC Windows, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2006-11-24 11:45 UTC by osavill
Modified: 2007-02-26 09:49 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description osavill 2006-11-24 11:45:31 UTC
If you enter "21st " the auto formatter kicks in and it becomes 21<sup>st</
sup>. However, if you enter "21st." or "21st," no such superscripting takes 
place.

Moreover, if you enter "21st ", then backspace to delete the space and then add 
the ".", ",", or whatever, the punctuation is also superscripted !! You have to 
enter "21st ." and then delete the space.
Comment 1 michael.ruess 2006-11-24 12:00:42 UTC
Reassigned to SBA.
Comment 2 bezginovel 2007-02-01 19:09:01 UTC
Tested with:
Windows98SE 4.10.2222 OpenOffice.org 2.1.0 [680m6(Build:9095)]
Windows XP SP2 OpenOffice.org 2.1.0 [680m6(Build:9095)]
The results are the same for both systems.
a) Issue, where ordinal number suffixes were not converted to superscript if
followed by punctuation was partially confirmed:
Autocorrect worked as expected with following set of punctuation characters: {,.?;:}
However, reported behavior was observed with punctuation characters in {!"'}
I only list those punctuation marks which can normally follow an ordinal number.

Variation of the issue:
Ordinal number suffixes are normally converted to superscript if followed by a
column break or a line break, however they are not corrected if followed by a
page break (Insert|Manual Break...  choose "Page Break")

b) I have also examined the second issue where punctuation was converted to
superscript if the space character after ordinal number was removed with backspace.
I could not reproduce the issue by following the given steps. However, a
modification gives a result that has been described:
1. create a new writer document
2. type "21st " Note: after adding the space 'st' will be converted to superscript
3. press left arrow to move the cursor before the space
4. press 'delete' key to remove the space
5. press '.' 
6.=> '.' is superscript
Note: step 4 may be omitted if space character after the full stop is acceptable.
Also, this behavior is not specific to ordinal number suffixes, but is common to
all superscript text. Thus, I think this is not a defect, but is an expected
behavior
Comment 3 Rainer Bielefeld 2007-02-20 17:55:46 UTC
I checked with "2.0.2  German version WIN XP: [680m5(Build9011)]", nearby
everything worked perfect, only typographic quotes made problems with <sup>.
"2.1.0  German version WIN XP: [680m6(Build9095)]", "2.2.0  Dev. Snapshot  WIN
XP: [680m7(Build9118)]" cause problems as per ' Additional comments from
bezginovel Thu Feb 1 19:09:01 +0000 2007' except the singel quote: that works
after you insert the next character (same behaviour with closing round bracket)

Summary: typographic quotes always cause problems in WRITER
In versions later than 2.0.2 so I see new problems for all <  >  {  [  (  !  

It sounds presumably , but currently we have no information concerning LINUX
problems.

This is not only a WRITER problem, I see similar problems in CALC and DRAW,
where superscript in front of punctuation works even worse, but, as it seems, in
all tested version with the same problems. But currently I doubt that it will be
useful to change to 'framework' or 'lingucomponent'
Comment 4 stefan.baltzer 2007-02-23 16:21:14 UTC
SBA: Duplicate of issue 67261. This broke in OOo 2.03 and got fixed for OOo 2.1.
I have seen it OK in OOE680m5 Build 9093. 
Still working fine in OOF 680m8 (OOo 2.2 RC) Build 9119.

*** This issue has been marked as a duplicate of 67261 ***
Comment 5 stefan.baltzer 2007-02-23 16:24:32 UTC
SBA: Closed as Duplicate (and already fixed for OOo 2.2).

Note that this did affect all AutoCorrect settings (see issue 67261:
"AutoCorrect gets triggerd only by <Space>, punctuation marks don't work anymore").
Comment 6 Rainer Bielefeld 2007-02-23 16:51:48 UTC
As visible in my test results, that is definitvely not "fixed for 2.1", because
I still see the problems in "2.1.0  German version WIN XP: [680m6(Build9095)]"
and "2.2.0  Dev. Snapshot  WIN XP: [680m7(Build9118)]". So this is something
different from  Issue 67261 (I do not think so) or the fix for  Issue 67261 is
incomplete (especially because there still are serious problems in DRAW and
CALC. Currently my intention is to reopen issue 67261 with new, more general
component. Alternative suggestions?
Comment 7 hrp8264 2007-02-26 09:27:24 UTC
Superscript for ordinal numbers doesn't work at all in Dutch. It does work in 
English, although Dutch is selected as the standard language.
Comment 8 Rainer Bielefeld 2007-02-26 09:49:51 UTC
@hrp8264
Can you pls. open a new 'l10n' issue for your problem? that seems to be
something special related to the Dutch localization. Pls be so kind and set me
to CC!