Issue 72186 - Polish date format incorrect
Summary: Polish date format incorrect
Status: CLOSED DUPLICATE of issue 62460
Alias: None
Product: Internationalization
Classification: Code
Component: code (show other issues)
Version: OOo 2.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: ooo
QA Contact: issues@l10n
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-01 17:34 UTC by pazkooda
Modified: 2013-08-07 15:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pazkooda 2006-12-01 17:34:38 UTC
Zgodnie z http://so.pwn.pl/zasady.php?id=629747 data w formacie d.MM.yyyy 
powinna znaleźć się wśród formatów dat w oknie dialogowy Data/Czas.

Trzymając się ściśle tekstu z PWN powinien to być format _domyślny_ dla języka 
polskiego. 

Również daty w formatach: "d miesiąc, yyyy" i "d mie, yyyy" powinne "stracić" 
przecinki i wyglądać następująco "d miesiąc yyyy" oraz "d mie yyyy" 

Sprawa ta ciągnie się w OO.org chyba odkąd pierwszy raz go użyłem (ver. 1.0???)

W imieniu swoim i wielu tych, którym na codzień pomagam w pracy z OO.org (oraz 
zapewne znacznej części użytkowników OO.org) proszę o możliwie szybkie 
rozwiązanie problemu.
Comment 1 milek_pl 2006-12-02 23:32:11 UTC
According to Polish official spelling rules, the official date format should be
d.MM.yyyy. This format should be made default, with ISO variant only as an option. 

Additionally, the date formats with commas (such as "31 grudzień, 1999" and
"piątek 31 grudzień, 1999") should be written as "31 grudnia 1999" and "piątek,
31 grudnia 1999". Note that the month name should be in the genitive form. The
format "31. grudzień 1999" is completely wrong.
Comment 2 ivo.hinkelmann 2006-12-04 15:46:56 UTC
come you give me some hint what this issue is about??? Where do you have what
date format? In the strings ? In the applications ???
Comment 3 milek_pl 2006-12-04 18:37:14 UTC
ihi: The date format is being used as following (Writer): Insert > Field > Date.

After double-clicking the date field, an Edit field box appears (in Polish:
Edytuj pola: Dokument). The Format area contains preset date formats, they must
be defined somewhere in the application resources, probably just as UI string.
Comment 4 milek_pl 2006-12-04 19:06:43 UTC
ihi: I found the offending file, this is pl_PL.xml in localedata:

http://l10n.openoffice.org/source/browse/l10n/i18npool/source/localedata/data/pl_PL.xml

I can fix that myself, if you want, and attach it.
Comment 5 ivo.hinkelmann 2006-12-05 11:22:21 UTC
Eike, please have a look
Comment 6 ooo 2006-12-05 14:47:03 UTC
Using ISO 8601 as default was done on purpose, please see discussion in issue
43751. Genitive date forms (posessive context) aren't implemented yet, see issue
62460.

*** This issue has been marked as a duplicate of 62460 ***
Comment 7 ooo 2006-12-05 14:47:45 UTC
Closing dup.
Comment 8 milek_pl 2006-12-05 16:27:33 UTC
This is not a duplicate because the genitive form is only _one_ of the problems
which were filed here. One of the problems is that ISO is not conformant to
Polish  spelling rules, and the discussion you brought up in issue 43751 is
irrelevant to the subject. First of all, Polish Standard mentioned by gkocur is
binding only when it comes to purely technical applications, and not to spelling
rules. All spelling rules, official resolutions of the Board for the Polish
Language, etc., specify the correct format for writing. Second, the usage of
comma in dates is completely wrong. Third problem is that pl_PL.xml is not
localized completely (for example, it should be FollowPageWord>s.</FollowPageWord> 
<FollowPageWord>ss.</FollowPageWord>). Anyway, I will file another issue for that.
Comment 9 ooo 2006-12-05 18:35:11 UTC
Hi Mikel,

> This is not a duplicate because the genitive form is only _one_ of the
> problems which were filed here.

So a fine example for why separate issues should be filed for separate
problems..

> One of the problems is that ISO is not
> conformant to Polish  spelling rules, and the discussion you brought
> up in issue 43751 is irrelevant to the subject.

Who, me? Note that I didn't bring up that discussion. I just brought in
a reference to ICU that confirmed that ISO date formats are used in
Poland. I'll implement whatever native people say is correct and can be
strengthened by other sources. The problem is when sources disagree, as
in this case.

> First of all, Polish Standard mentioned by gkocur is binding only when
> it comes to purely technical applications, and not to spelling rules.
> All spelling rules, official resolutions of the Board for the Polish
> Language, etc., specify the correct format for writing.

Why is it then that also Windows and other operating systems as well as
the CLDR list the ISO date format for Polish? See
http://www.unicode.org/cldr/data/charts/main/pl_PL.html#416 and
http://www.unicode.org/cldr/data/charts/main/pl_PL.html#427 and
http://www.unicode.org/cldr/data/charts/summary/pl.html around item
#1855. As OOo locale data tries to align to the CLDR and will do so even
more over time, it would be good to get a authoritative listing into the
CLDR, see also http://www.unicode.org/cldr/filing_bug_reports.html


> Second, the usage of comma in dates is completely wrong.

The comma in the long date formats, between day names and month names
and such? No problem to remove.

> Third problem is that pl_PL.xml is not
> localized completely (for example, it should be
> FollowPageWord>s.</FollowPageWord>
> <FollowPageWord>ss.</FollowPageWord>). Anyway, I will file another
> issue for that.

Please do so.

Thanks
  Eike
Comment 10 milek_pl 2006-12-05 19:42:27 UTC
Eike:

Why is it then that also Windows and other operating systems as well as
the CLDR list the ISO date format for Polish? 

Well, the fact is that many wording or terminology errors persist in Microsoft
products just because of the fact that correcting them would mean amazing
amounts of work, and that wouldn't be economical. The same goes for the date
format: changing it could disable some custom solutions. There were even serious
spelling errors in the spelling dictionary that persisted for many years.

The fact is that ISO is valid in Poland, of course, but only for technical
notation. In almost all writing, we use either Roman numerals or D.MMMM.YYYY. I
can quote any current dictionary of correct Polish usage for that matter.

As for CLDR, I'll try to file a bug, though the website isn't really
user-friendly :) Anyway, there are amazing things in Polish locale in CLDR, like
short one-letter month names ("w" for "wrzesień", i.e., September). I have never
seen such an abbreviation, and none of the dictionaries I own lists it.

For non-controversial bugs in locale, see <a
href="http://www.openoffice.org/issues/show_bug.cgi?id=72300">72300</a>.