Issue 72194 - Writer leaks memory working with large tables
Summary: Writer leaks memory working with large tables
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOo 2.0.4
Hardware: Other Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2006-12-01 21:03 UTC by jancs
Modified: 2013-08-07 14:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

test file (1.17 MB, application/msword)
2006-12-04 13:05 UTC, jancs
no flags Details
report (9.77 KB, text/plain)
2006-12-21 11:19 UTC, richlv
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jancs 2006-12-01 21:03:24 UTC
May be it is not just in case of large tables but my observation are the following:
Freshly started OO - sofice.bin uses 26 MB physica memory and 18 MB in Virtual mem.
Opening of Word document (13 MB) containing large table raises memory
consupmtion to 102 MB in physical mem and 82 Mb in Virtual.
Editing of table - just cutting out the rows - each operation increases memory
consumption by about 7 MB of physical and 7 MB in virtual mem. (the amount ow
rows cut in one attempt is from 1 to 10, but is has no influence on the memory
lost by every operation). 
I notice this because Windows cried "i am runnig out of memory" and OO crashed
Memory usage was explored using Windows task manager, WinXp Sp2+; no other apps
running in the background.
Comment 1 michael.ruess 2006-12-04 11:38:24 UTC
Hm, I cannot reproduce it with new documents. Could you please attach the sample
document to this issue (zipped) or send it directly to for
the case it contains confidential data: send it as mail attachment; we here at
Sun will handle it appropriately!
Feel free to reopen issue when you have done so.
Thanks for your patience!
Comment 2 jancs 2006-12-04 13:05:28 UTC
Created attachment 41112 [details]
test file
Comment 3 jancs 2006-12-04 13:09:12 UTC
So, this test fiel ir the MS Word document containing LARGE table (which can be
used to test various bugs related to the large documents, cell number etc)

I repeated described operations on another computer and got the same results.
Comment 4 michael.ruess 2006-12-04 16:27:02 UTC
MRU->FME: could you please have a look if the memory consumption of tables might
be optimized somehow? The attached document may be something extreme, but 100 MB
of memory for about 30.000 cells really necessary?
Comment 5 jancs 2006-12-05 07:36:02 UTC
To add some oil to the fire: MS Word intentionaly or unintentionaly has some
mechanism limiting its memory footprint to approx 80 Mbytes. 
In case of Word 2000, when it reached the mentioned size in memory (which is
actually a hard task, but i succeded some time ago), it became VERY slow, but
did not died. 
Comment 6 richlv 2006-12-21 11:17:13 UTC
confirmed and more in 2.1.0 on slackware 11.0.

first, the document opens in 11 minutes. this is celeron 2.20ghz, no other cpu-intensive processes 
( uses all the cpu during this time), 250mb of physical ram still free when the document 
finishes loading.

basically any action results in memory usage increase (for example, simply changing row heigth). also crashed - i dragged one row to be slightly larger, then tried to undo this action (through 
the dit menu).

i sent the error report, but i am also attaching it here.
Comment 7 richlv 2006-12-21 11:19:49 UTC
Created attachment 41623 [details]
Comment 8 jancs 2009-04-15 20:37:06 UTC
seems this bug is solved - at least trying to repeat it using OO 3.0.1 on Win
observed changes in memory usage are comprehensible.