Issue 72222 - gallery with external files doesn't work if we install it as UNO package
Summary: gallery with external files doesn't work if we install it as UNO package
Status: ACCEPTED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.0.4
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL: http://sourceforge.net/project/downlo...
Keywords:
: 70412 (view as issue list)
Depends on:
Blocks:
 
Reported: 2006-12-03 11:08 UTC by kami911
Modified: 2019-10-05 11:06 UTC (History)
7 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
To use origin of the theme file as base path (1.14 KB, patch)
2012-04-29 11:47 UTC, hanya
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description kami911 2006-12-03 11:08:01 UTC
UNo package/extension and gallery installation releated problem:
It seem OOo mapping UNO package installed gallery files wrongly to user
home/OpenOffice.org2/user/gallery/... when the gallery contains external (linked
file)...
This is the way how we can put a photo into the gallery.
The correct mapping should be (example):
home/OpenOffice.org2/user/uno_packages/cache/uno_packages/5.tmp_/OOOP-2.0.4-1-gallery.oxt/gallery/Photos/Flowers/rose_sv400157.jpg
And even worse, installed gallery file installed in shared mode is also mapping
to home/OpenOffice.org2/user/gallery/...
It causes we can't use external linked files for the gallery at all.
URL is a test file, it is a big, but it shows the problem well... May I provide
a smaller testcase?
Comment 2 thorsten.martens 2006-12-04 10:10:28 UTC
TM->WG: please have a look, thanks !
Comment 3 wolframgarten 2006-12-04 10:25:29 UTC
Reassigned. Please have a look.
Comment 4 wolframgarten 2006-12-04 11:11:17 UTC
Priority changed.
Comment 5 clippka 2007-01-02 10:12:35 UTC
ok, will try to fix this
Comment 6 kami911 2007-02-13 21:41:09 UTC
Have we got an expected timeframe for the fix?
Comment 7 clippka 2007-04-11 14:43:22 UTC
no, not scheduled currently
Comment 8 clippka 2007-09-12 13:50:09 UTC
retargeted
Comment 9 kami911 2007-09-12 22:19:21 UTC
It is a sad piece of news to me. It is made my gallery extension unusable for
external pictures. Are there a chance to fix it in the next point relelase?
Comment 10 rail_ooo 2007-11-11 17:42:12 UTC
add cc
Comment 11 Mathias_Bauer 2010-05-17 12:40:53 UTC
isn't this a sub task of issue 70412?
Comment 12 Oliver Brinzing 2012-03-19 17:28:00 UTC
i can confirm this issue with oo3.2
but there are several gallery extensions available 
where graphics are placed inside the *.sdv file.

any hints how to put graphics inside a *.sdv file?
Comment 13 hanya 2012-03-19 17:51:52 UTC
(In reply to comment #12)
> any hints how to put graphics inside a *.sdv file?

No simple way is known. Create new theme into your office's gallery, put graphics into it. Pick up required file from your user's profile/gallery. We are making these files in this way.
Comment 14 Ariel Constenla-Haile 2012-03-19 21:46:26 UTC
(In reply to comment #12)
> i can confirm this issue with oo3.2
> but there are several gallery extensions available 
> where graphics are placed inside the *.sdv file.
> 
> any hints how to put graphics inside a *.sdv file?

there is a tool not to put graphics inside a *.sdv but to create a gallery linked to external files. AFAIK it is used to create the galleries for 
openoffice.org/basis3.4/share/gallery/rulers
openoffice.org/basis3.4/share/gallery/htmlexpo

the best use is for graphics in a folder relative to the *.sdv file

For example, the following command

openoffice.org/basis3.3/program/gengal \
--name "Test Gallery" \
--path file:///home/ariel/Im%C3%A1genes/OOo/ \
--number-from 860 \
file:///home/ariel/Im%C3%A1genes/OOo/update/update-download.png \
file:///home/ariel/Im%C3%A1genes/OOo/update/update-failed.png \
file:///home/ariel/Im%C3%A1genes/OOo/update/update-ok.png

will create the gallery files in /home/ariel/Imágenes/OOo

sg860.sdg
sg860.sdv
sg860.thm

next to the update/ folder containing the images.
And as I stripped from the path /home/ariel/Imágenes/OOo the links are relative to the gallery files. You can simply copy the gallery files together with the folder inside the user gallery directory.
Comment 15 Oliver Brinzing 2012-03-20 07:19:59 UTC
thanks for your comments, i think i found a solution:

- create a "pictures" folder in "user gallery folder"
- copy all pictures into folder

- open new *draw* document 
  following steps seem not to work with other document types!

- open gallery browser
- create a new gallery theme "Test"
- drag&drop pictures from windows explorer into gallery
  result: pictures are linked relative

- drag&drop pictures into draw document

- drag&drop pictures back to gallery theme
- delete linked pictures
- close oo
- *.sdv file contains all pictures,
  "pictures" folder and "dragsdrop" folder should be empty
- create extension
Comment 16 hanya 2012-03-20 08:48:36 UTC
(In reply to comment #14)
> (In reply to comment #12)
> > i can confirm this issue with oo3.2
> > but there are several gallery extensions available 
> > where graphics are placed inside the *.sdv file.
> > 
> > any hints how to put graphics inside a *.sdv file?
> 
> there is a tool not to put graphics inside a *.sdv but to create a gallery
> linked to external files. AFAIK it is used to create the galleries for 
> openoffice.org/basis3.4/share/gallery/rulers
> openoffice.org/basis3.4/share/gallery/htmlexpo
> 
> the best use is for graphics in a folder relative to the *.sdv file
> 
> For example, the following command
> 
> openoffice.org/basis3.3/program/gengal \
> --name "Test Gallery" \
> --path file:///home/ariel/Im%C3%A1genes/OOo/ \
> --number-from 860 \
> file:///home/ariel/Im%C3%A1genes/OOo/update/update-download.png \
> file:///home/ariel/Im%C3%A1genes/OOo/update/update-failed.png \
> file:///home/ariel/Im%C3%A1genes/OOo/update/update-ok.png
> 
> will create the gallery files in /home/ariel/Imágenes/OOo
Thanks to make it clarify, I have never seen any document about gengal. 
I tried to document it on wiki but it seems gengal has been removed from 3.4. 
There is no gengal directory under svx/source anymore....
Comment 17 Ariel Constenla-Haile 2012-03-20 10:59:29 UTC
(In reply to comment #16)
> Thanks to make it clarify, I have never seen any document about gengal. 
> I tried to document it on wiki but it seems gengal has been removed from 3.4. 
> There is no gengal directory under svx/source anymore....

you are right. I'll try to investigate why it was removed.
Comment 18 Ariel Constenla-Haile 2012-03-23 22:50:05 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > Thanks to make it clarify, I have never seen any document about gengal. 
> > I tried to document it on wiki but it seems gengal has been removed from 3.4. 
> > There is no gengal directory under svx/source anymore....
> 
> you are right. I'll try to investigate why it was removed.

275156:4a7819c8739a
27-Jan-2011
mba CWS gnumake3: remove gengal

I couldn't find a bug or a mail explaining this removal.
They may have run into troubles porting this to gbuild.

@hanya:
IMHO this binary is rather useful; if you thinks so, please open a new bug.
Comment 19 hanya 2012-04-29 11:47:31 UTC
Created attachment 77503 [details]
To use origin of the theme file as base path
Comment 20 hanya 2012-04-29 11:48:54 UTC
In GalleryTheme::ReadData of svx/source/gallery2/galtheme.cxx, 
aRelURL1: shared path and aRelURL2: user's path are checked but 
thm file provided by extensions are placed in their own packages.

proposed patch to fix this problem, attached in comment #19.
Comment 21 Rob Weir 2013-03-11 15:03:37 UTC
I'm adding this comment to all open issues with Issue Type == PATCH.  We have 220 such issues, many of them quite old.  I apologize for that.  

We need your help in prioritizing which patches should be integrated into our next release, Apache OpenOffice 4.0.

If you have submitted a patch and think it is applicable for AOO 4.0, please respond with a comment to let us know.

On the other hand, if the patch is no longer relevant, please let us know that as well.

If you have any general questions or want to discuss this further, please send a note to our dev mailing list:  dev@openoffice.apache.org

Thanks!

-Rob
Comment 22 Marcus 2017-05-20 10:47:39 UTC
Reset assigne to the default "issues@openoffice.apache.org".
Comment 23 oooforum (fr) 2019-10-05 11:06:04 UTC
*** Issue 70412 has been marked as a duplicate of this issue. ***