Issue 7258 - bugs with Excel export/import (charts-related) [details inside]
Summary: bugs with Excel export/import (charts-related) [details inside]
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-08-26 19:58 UTC by lars
Modified: 2003-09-08 16:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
the original (748.50 KB, application/octet-stream)
2002-08-29 22:49 UTC, lars
no flags Details
the Excel file from Calc (~800 KB) (840.00 KB, application/octet-stream)
2002-08-29 22:51 UTC, lars
no flags Details
the file as resaved from Excel (863.50 KB, application/octet-stream)
2002-08-29 22:53 UTC, lars
no flags Details
all Screenshots from the documents as BMP in an ACE archive (199 KB) (198.14 KB, application/octet-stream)
2002-08-29 22:58 UTC, lars
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lars 2002-08-26 19:58:50 UTC
I have attached the original and the xls created from that. Perhaps note that 
the original originates from a "glitched" Calc file; see issue 7256 for that

1). chart intervals wrong - several issues here (chart intervals is too general)

                            (like wrong subintervals (they are shown although 
                             not to be shown in sxc; but the value had manually 
                             been changed there; just for info, if there is the 
                             bug), wrong main intervals, wrong place of x-axis 
                             at y-value)

2). chart data point symbols partly wrong

3). text boxes ("T") loose formatting

4). text boxes text is placed wrong

5). comment boxes ("Sprechblase") vanish

6). on xls resave of xls: document info (like creator) "tags" (! not just the 
content) vanish

7). I think you know already: file size increases on resave

8). horizontical scrollbar length is wrong, so showing not all sheets at bottom


Info: there are 4 sheets, you have to also scroll to the left on the 1st sheet
Comment 1 lars 2002-08-28 23:42:23 UTC
I have opened the Calc created XLS in Excel 97 in order to see how it 
looks there; you can derive from that, which issues from the list are 
related to the Calc importer and which from the Calc exporter.

Those that are correct in Excel, but not in Calc, are most probably 
from the importer, those wrong in both are from the exporter.


First, another issue:

9). the colors of curves in a chart are associated wrong [export 
    filter]

10). the curves in a chart are not drawn as in Excel (keyword:
     "hiding") [import filter]


Now, what I can tell to be import or export filter related:

1). :  import
2). :  import
3). :         export
4). :  import
5). :         export
6). :                general
7). :                general
8). :         export


The file is attached as SXC and XLS; filenames act as descriptions.
Everything is also attached as BMPs; each file is 3.8 MB in size.
At the moment, attaching is still not possible.


Note: the issues mentioned here (1).-10).) concern the Calc created 
XLS file opened in Calc.


Now: other observations :

in Excel: -the Calc created XLS has a chart with black background 
           (sheet 2) and some other charts are garbled.

          -the chart on sheet 2 can't be edited; reproducable crash 
           when trying to:
//--------------------------------------------------------------------
EXCEL verursachte einen Fehler durch eine ungültige Seite
in Modul MSO97.DLL bei 0167:30705766.
Register:
EAX=0155000c CS=0167 EIP=30705766 EFLGS=00210213
EBX=00002080 SS=016f ESP=0062bc18 EBP=0062bf48
ECX=0000059c DS=016f ESI=00630000 FS=4e47
EDX=00005a02 ES=016f EDI=0155439c GS=0000
Bytes bei CS:EIP:
f3 a5 8b ca 83 e1 03 f3 a4 5f 5e c3 8d 14 31 3b 
Stapelwerte:
0155000c 0062bc70 30001065 0155000c 0062bc70 00005a02 300010d9 
0062bc70 0155000c 00005a02 30014f57 0062bc70 0155000c 00002d01 
000000ff 00000436 
//--------------------------------------------------------------------

in Calc: -the resaved XLS from Excel can't be opened: during startup 
          (the OOo logo is shown) a window pops up: "an internal 
          error occured" + other text  or sth. like that. 
          reproducable crash:
//--------------------------------------------------------------------
SOFFICE verursachte einen Ausnahmefehler e06d7363H in Modul 
MSVCRT.DLL bei 017f:7800b78d.
Register:
EAX=0093f3f8 CS=017f EIP=7800b78d EFLGS=00000206
EBX=00000000 SS=0187 ESP=0093f3dc EBP=0093f404
ECX=00000000 DS=0187 ESI=78033e68 FS=44b7
EDX=0093f440 ES=0187 EDI=0093f404 GS=41ff
Bytes bei CS:EIP:
5f 5e c9 c2 08 00 55 8b ec 51 53 56 57 8b 45 0c 
Stapelwerte:
01d211cc 00000001 e06d7363 00000001 00000000 00000000 00000003 
19930520 0093f440 01d97ea0 0093f61c 01d44394 0093f440 01d97ea0 
0093f680 00000000 
//--------------------------------------------------------------------

I renamed that XLS file to be attached here and now this error does 
not occur anymore (there was a problem with Excel saving the file: 
the original filename contained an ; and Excel put its .xls before 
the ; and the text after the ; came then after the .xls : .xls;text ; 
when I saw this however I resaved it using "save as" as ""original 
filename"" and the filename stayed intact; Note: I renamed the files 
after I saved and opened and saved them in the formats mentioned in 
order to attach them here, so they are from one "chain", if you know 
what I mean).

I am now renaming it to see whether the problem is there again;... 
No, it isn't, so I'm providing the in-Excel-resaved file with the 
original filename also.

Note: as this last problem (OOo crash) seems filename related, it 
might be that OOo in the first place wrote an "incorrect" Windows 
file to hdd, so look out for that; please also note in this context 
that the Calc original file stems from a "glitched" Calc file (see 
very beginning(1st description)).
The "actual" issues, issues 1). - 10). seem not to be affected by the 
renaming, as I've just checked.


Puh...
Comment 2 lars 2002-08-29 00:08:47 UTC
The "file open problem" is not filename related but related to the 
fact, that the file is in a shared Windows 98 SE network folder.

That folder is read/write enabled through password.


msvcrt.dll in C:\Windows\system  version: 6.10.9359.0  language: US


If someone wants to get started with the original Calc file, this 
file is also attached to another issue: issue 7087
Comment 3 lars 2002-08-29 17:13:26 UTC
11). axis text label size (length) or chart size (length) is wrong
     [import filter]
Comment 4 lars 2002-08-29 22:49:43 UTC
Created attachment 2621 [details]
the original
Comment 5 lars 2002-08-29 22:51:30 UTC
Created attachment 2622 [details]
the Excel file from Calc (~800 KB)
Comment 6 lars 2002-08-29 22:53:21 UTC
Created attachment 2623 [details]
the file as resaved from Excel
Comment 7 lars 2002-08-29 22:58:15 UTC
Created attachment 2624 [details]
all Screenshots from the documents as BMP in an ACE archive (199 KB)
Comment 8 lars 2002-08-29 23:02:13 UTC
ACE archiving software for example from http://www.winace.com

and the filename is outdated: "SXCxLS" : it does not contain those 
files; these are seperate as seen
Comment 9 lars 2002-08-29 23:14:51 UTC
winace.com also has extracters-only and linux ace software


749 KB  sxc

840 KB  xls Calc

864 KB  xls Excel


I provided the Excel resaved file, so that you can see the difference 
to your created xls file.

And I just see that issue 4). is no issue in Calc when loading the 
Excel xls file. When reading the Calc xls file, that is an issue for 
Calc, but not for Excel; so I thought it to be an import filter 
problem; however, as the Excel xls makes no problems, it's rather a 
Calc xls specific problem, so the Excel xls file will be of actual 
use.
Comment 10 lars 2002-08-31 19:46:11 UTC
12). see issue 6724   rather far down the bottom
Comment 11 lars 2002-08-31 21:57:47 UTC
12). is no issue here, don't see is. 6724
Comment 12 lars 2002-09-09 11:23:25 UTC
I know you are working on a new chart implementation, so these points 
here may be obsolete now, but test these points in the new 
version "for safety". Also: are old charts rendered using the new 
chart model or are they converted to new charts?
these problems should at least be fixed when opening in a new OOo 
version and saving there to excel or whatever.
Comment 13 lars 2002-10-17 13:18:39 UTC
should I file seperate issues?
should I then file seperate issues for all problems of 1). ?
Comment 14 lars 2002-10-28 18:34:39 UTC
 12  defects  listed here  since Aug. 26
Comment 15 oc 2003-03-10 11:58:12 UTC
Please only one issue per id. Please split this task, because 
multiple task are not usable for the development.
Comment 16 oc 2003-03-10 11:58:37 UTC
Closed because invalid