Issue 72671 - opened spreadsheed covers the whole screen
Summary: opened spreadsheed covers the whole screen
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOo 2.0.4
Hardware: Mac Mac OS X, all
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on:
Reported: 2006-12-17 13:35 UTC by rolandp
Modified: 2017-05-20 11:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

screenshot of iMac 20" screen completely filled with a new spreadsheet (142.10 KB, application/msword)
2006-12-23 07:53 UTC, rolandp
no flags Details
oversized Calc window (287.39 KB, image/tiff)
2007-03-15 13:42 UTC, toucheguy
no flags Details
an example file, but creating a new spreadsheet does the same job (7.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2007-04-06 11:53 UTC, rolandp
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description rolandp 2006-12-17 13:35:49 UTC
When I open a spreadsheed document (by dragging or by using the Open dialogue),
it systematically covers the whole screen below the menu line including the
dock. I need to click the green button to reduce the size before I can adjust
the page as I like. The size of the document window doesn't seem to be stored
when saving it.

This issue did not appear in former versions of OOo; I remark it since 2.0.4,
and also in 2.1.
Comment 1 kpalagin 2006-12-23 06:48:55 UTC
any chance you could provide illustrating screenshots?
Comment 2 rolandp 2006-12-23 07:53:12 UTC
Created attachment 41667 [details]
screenshot of iMac 20" screen completely filled with a new spreadsheet
Comment 3 pavel 2007-03-14 19:14:15 UTC
Me too ;-)

how to debug this?
Comment 4 toucheguy 2007-03-14 23:15:33 UTC
I hope that, as Shaun suggested, this issue can be taken into account within the
refresh issues for the Mac Aqua port.
It's not a vital issue, but quite annoying.
Comment 5 frank 2007-03-15 10:36:31 UTC
One for the Mac porting team.

Under tools-options-load/save-general load User specific settings with document
is set ?

The first start of Calc will open the new sheet in full screen mode. So if it is
just after the start, it's normal.

Comment 6 toucheguy 2007-03-15 13:39:49 UTC
- answer to fst: yes, user specific settings are set in Load/Save

- on first start, Calc window should leave the dock area free
- on first start, Calc window should keep sizing corner within the screen
- on subsequent openings of existing Calc sheet, window size should be as saved
by user (now Calc _always_ opens in oversized mode, i.e. bigger than full
screen, with status bar below the screen)

All this verified in v 2.2 RC 2 (Intel, Dutch), and already reported for 2.0.4
and 2.1
Comment 7 toucheguy 2007-03-15 13:42:56 UTC
Created attachment 43724 [details]
oversized Calc window
Comment 8 jjmckenzie 2007-03-19 04:48:18 UTC
Can you provide the .ods file?  I will need this for QA purposes only for 2.2rc3.
James McKenzie
Comment 9 toucheguy 2007-03-19 15:50:10 UTC
Problem seems solved in 2.2 rc3. Existing spreadsheet file now opens in window
size it had in previous session (although change in window size is not
explicitly saved - after changing the window size, the 'save' icon remains grey).
New spreadsheet also opens in this 'last saved window size'.
As far as I'm concerned, this issue can be closed! +1
Comment 10 rolandp 2007-04-06 11:53:08 UTC
Created attachment 44247 [details]
an example file, but creating a new spreadsheet does the same job
Comment 11 rolandp 2007-04-06 11:57:28 UTC
I still have the problem with the current (2.2) release for Macintosh (Intel). I
just discovered that creating a new drawing has the same effect! Is this an X11
Comment 12 eric.bachard 2007-04-06 12:27:07 UTC

Issue confirmed.

Just finished ( 5 minutes ago)  the Panther build of m207 - and found a workaround to the issue with 
launch - and I have made several tests, giving the following results :

1) Issue fully repeatable in the following cases :

- m207 aka 2.3pre (built on PowerPC) tested on Intel ( 10.4.8 )  / X11 1.1.3
- m207 aka 2.3pre (built on Intel)  and tested on Intel ( 10.4.8 ) / X11 1.1.3
- m207 aka 2.3pre (built on PowerPC ) and tested on PowerPC ( 10.4.9 ) / X11 1.1.3 
- OOF680_m14 (aka 2.2 ) built on Intel, tested on Intel ( 10.4.8 )  / X11 1.1.3

The only case it works, is when using X11 in fullscreen mode. We can't ask normal people to use this 
mode though .. 

2) No issue 

- I cannot reproduce that issue using OOF680_m14 nor SRC680_m207  tested on PowerPC Panther  
using X11 1.0 

I'll try to reinstall old X11 1.1.1 or 1.1.0 but I'm pretty sure this is an X11 issue

Please enter an issue on radar  (same as IZ but using Apple bug report ), and I'll try to contact Apple 
people about that issue. that the only thing I can do here for now :-/ 

Comment 13 rolandp 2007-04-06 15:58:00 UTC
I warned Apple Bug reporter about this issue.  It is #5116894.


Comment 14 eric.bachard 2007-04-07 16:29:24 UTC

Thanks you very much. I'll try to log me and confirm I have the same issue 

DISCLAIMER : what follows is a hack, you can use it at your own risks.

It is possible to downgrade X11 : 

1) go into /System/Library/Receipts 
2) rename X11User.pkg in e.g. X11User.pkg.back

3) install the X11 I provide here :

a) If you have an INTEL machine (Tiger ) :

b) If you have a PowerPC ( Tiger ) :

=> just reinstall this version of X11 solves the issue, and this is definitively
an X11 bug. 

Comment 15 rolandp 2007-04-08 16:36:42 UTC

Thanks for this hack. I installed it on my iMac Intel. It works and I hopethat
there are no problems somewhere else.

Un train peut en cacher un autre ;-) Joyeuses Pâques
Comment 16 eric.bachard 2007-10-06 23:20:14 UTC
Looks like this is Apple side, and I no longer want to play with closed Apple bug report: only the reporter 
can read the content and access to the information.

I propose to close this issue as wontfix. Opinions ?

Comment 17 jeremyhu 2008-02-02 18:36:46 UTC
Is this still an issue with Leopard's X11?  If so, please come help us fix it at
Comment 18 rolandp 2008-06-28 10:50:04 UTC
This issue is solved in OOo 2.4. I tried with MacOS 10.4.11 on a Powerbook G4,
and also with MacOS 10.5.3  on a iMac Intel (using X11 3 beta), in both cases
starting from X11 manually.
Comment 19 Marcus 2017-05-20 11:29:36 UTC
Reset assigne to the default "".