Issue 72957 - User settings overridden by installation
Summary: User settings overridden by installation
Status: CLOSED DUPLICATE of issue 80770
Alias: None
Product: lingucomponent
Classification: Code
Component: other (show other issues)
Version: OOo 2.1
Hardware: All Windows, all
: P3 Trivial with 9 votes (vote)
Target Milestone: not determined
Assignee: maison.godard
QA Contact: issues@lingucomponent
: 72121 80618 (view as issue list)
Depends on:
Reported: 2006-12-27 22:03 UTC by hagar_de_lest
Modified: 2008-11-05 20:58 UTC (History)
7 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

DicOOo 1.8 prototype (124.53 KB, application/vnd.sun.xml.writer)
2007-08-16 21:22 UTC, maison.godard
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hagar_de_lest 2006-12-27 22:03:11 UTC
When upgrading, OOo should not overwrite a user configuration file if there is
one existing (same name) in the user folder.

See here :

Even if this bug (for the linguistic.xcu file) cannot be systematically
reproduced, the issue is not with this specific file but with the upgrade
process. It should check first if a configuration file exists in the user
profile folder. If there is one, then, the install file should not be written in
the OOo main program folder.
Comment 1 Olaf Felka 2006-12-27 22:19:01 UTC
Looks like a linguistic problem. Installation is not touching any file in the 
user layer.
Comment 2 hagar_de_lest 2007-01-03 09:13:46 UTC
For information, a thread on the French forum on this issue :
Comment 3 hagar_de_lest 2007-01-03 14:23:36 UTC
Could it be caused by the installation of a language pack ?
I'm used to install the En-US main package then install the langpack for French UI.
In fact, I don't use the wizard to install dictionaries (I backup them) and I
got this problem also when upgrading from 2.0.4 to 2.1 !
Comment 4 hagar_de_lest 2007-02-20 10:17:46 UTC
See also this thread :

Issue seems to be specific to Windows.
Comment 5 hagar_de_lest 2007-02-26 12:10:32 UTC
Again, same pattern :
Comment 6 dalo 2007-03-04 14:48:51 UTC
On XP OOo 2.1
Note: Installing different language packs does not work.(No effect on changing
the UI language: Stays 'Default')
Unless you delete the linguistic.xcu file in User and Program File directory.
Comment 7 leiflodahl 2007-03-06 10:40:16 UTC
I have reproduced this problem with various other linguistic settings, e.g.
selecting another default language for spellcheck.

Agree that it's only a problem on Windows.

Linguistic.xcu is reset each time is started.

I think that all settings stored in Linguistic.xcu is infected by this problem.
Comment 8 thomas.lange 2007-03-06 10:46:29 UTC
tl->hagar_de_lest; please check this issue with a current version of OOo.
I think this issue was already solved months ago.
Comment 9 hagar_de_lest 2007-03-06 10:52:28 UTC
@ tl :
- I put version 2.1 in the bug details because it did occured for me also with
2.1 (in fact it's said in the French thread).
- Solved some months ago and still issues about that ??? Have you read the threads ?
Comment 10 leiflodahl 2007-03-06 10:59:31 UTC
Problem reproduced today with OOF680_m10
Comment 11 leiflodahl 2007-03-06 11:03:22 UTC
*** Issue 72957 has been confirmed by votes. ***
Comment 12 hagar_de_lest 2007-03-24 11:53:38 UTC
An additional issue I'd forgotten to point out :

And also one today on the users mailing list :
Comment 13 guraknugen 2007-04-08 19:01:28 UTC
I can see two ways to solve this problem. As it seems like some part of copies [C:\Program 
to [C:\Documents and Settings\<user name>\Application 
Data\OpenOffice.org2\user\registry\data\org\openoffice\Office] every time is started, the solutions could be one of the following:

1. should only copy the file if it doesn't exist in the target 


2. If a change is made in [C:\Documents and Settings\<user name>\Application 
the changed file should immediately be copied back to [C:\Program 
Files\OpenOffice.org2\share\registry\data\org\openoffice\Office\]. If this 
solution it the one we chose, then we also have to remember that, during an update, [C:\Program 
should never be replaced. Only added if it doesn't exist.

At least this is what my experiments lead, but I can be wrong of course.

Johnny Andersson
Comment 14 epodata 2007-04-10 20:33:43 UTC
I have exactly the same problem running OO0 2.0.2 under linux fedora core 5.
Comment 15 elehenaff 2007-04-24 20:15:12 UTC
issue # 76462 may be connected with this one. (duplicate?)
Comment 16 thomas.lange 2007-04-25 12:14:44 UTC
TL->elehenaff: Probably not. This issue is about upgrading an office and the
other does not seem to indicate a upgrade related problem.
Comment 17 hagar_de_lest 2007-04-25 15:17:31 UTC
@TL: it depends on the actions done previously by the OP. This issue occurs also
when installing additional dictionaries or language packs. We need more information.
Comment 18 alan 2007-05-09 13:55:34 UTC
Any news with this bug? I've just built Hebrew 2.2 with Russian and English
language packs. After I install an English language pack, I can't get the Hebrew
interface back, even if I change the settings. This is a very serious problem
for us, since we have many users who switch UI languages between Hebrew and
English or Russian. 
Comment 19 bentley 2007-05-09 22:19:21 UTC
I was affected by this problem too. Deleting the linguistic.xcu did the trick
for me. 

All I can say it's not just an OO 2.2 upgrade problem - doing a clean install
results in the same problem (making a different dic the startup dic).
Comment 20 alan 2007-05-10 06:39:23 UTC
If I want to change the UI language interface, deleting Linguistic.xcu is not
going to solve the problem, since Linguistic.xcu is where the change I made is
stored! Is there any other option until this bug is fixed?
Comment 21 bentley 2007-05-10 06:53:48 UTC
not the UI lingo
but the "default language for documents - Western"! (I need Australian English here)

it's working nicely for me now but only after deleting linguistic.xcu :)

Comment 22 hagar_de_lest 2007-05-10 07:16:50 UTC
@ ayaniger : if you're afraid, don't remove it, just rename it and see if that
fixes your issue. If you've read the threads linked, you should have seen how
the bug works and why deleting the right linguistic.xcu solves the problem.

NB: the right file to delete is in C:\Program Files\
2.0\share\registry\data\org\openoffice\Office => no impact on your personal
setting !
Comment 23 majukr05 2007-05-10 08:19:56 UTC
I just made a new test 
(meanwhile reproduced about 4-5 times with several dicts). 
[OOo 2.2 en-US + lp de/fr/es - WinXP_Ho]

Installing new dictionaries (en_ZA) by wizard:
DICT en ZA en_ZA
HYPH en ZA hyph_en_GB
THES en ZA th_en_US_v2

In C:\Programme\ 2.0\share\registry\data\org\openoffice\Office
appaers new entry 'Linguistic.xcu' with:

<?xml version="1.0" encoding="UTF-8"?>
<oor:component-data xmlns:oor=""
xmlns:xs="" oor:name="Linguistic"
 <node oor:name="ServiceManager">
  <node oor:name="LastFoundSpellCheckers">
   <prop oor:name="en-ZA" oor:op="replace" oor:type="xs:string">
  <node oor:name="SpellCheckerList">
   <prop oor:name="en-ZA" oor:op="replace" oor:type="xs:string">
  <node oor:name="HyphenatorList">
   <prop oor:name="en-ZA" oor:op="replace" oor:type="xs:string">
  <node oor:name="LastFoundHyphenators">
   <prop oor:name="en-ZA" oor:op="replace" oor:type="xs:string">
  <node oor:name="LastFoundThesauri">
   <prop oor:name="en-ZA" oor:op="replace" oor:type="xs:string">
  <node oor:name="ThesaurusList">
   <prop oor:name="en-ZA" oor:op="replace" oor:type="xs:string">

Switching language of UI was working fine before.
After having installed the en-ZAs there was no more possibility to do it.

Also other linguistic settings were corrupted, e.g.:
- All available language modules were acitivated (own selection was overwritten)
- All user-defined dictionaries were disabled
- 'Hyphenate without inquiry' disabled
- Settings for 'Characters before/after line break' overwritten

All attempts for correct/desirabled settings were reset (as above) after
restarting OOo.

The only way to avoid this malfunction was: 
to rename or to delete this 'shameful' Linguistic.xcu in 2.0\share\registry\data\org\openoffice\Office.

After that all worked fine again ...
Comment 24 alan 2007-05-10 08:24:22 UTC
Yes, hagar, I was referring to the local Linguistic.xcu and not the "global"
one. After deleting the global one, I was able to switch UI languages. This is
not a big deal for a developer like me, but it's not the prettiest solution to
tell all of our users, though.
Comment 25 bentley 2007-05-10 08:30:43 UTC
I am a bit confused what you call here UI language when we talk about a default
document lingo setting.

The UI language would be switching the application's (Writer) interface lingo to
French or what ever (not the document's lingo).

Are we talking her about two different issues or are you just misusing the word
UI for a dictionary/spelling setting? 

Comment 26 alan 2007-05-10 08:45:09 UTC
I am referring to the application's interface language, which you can change to
French, for example, if a French language pack is installed. This setting
("UILocale") is in Linguistic.xcu. Hagar mentioned in her post of April 25 that
settings in Linguistic.xcu get trounced after a language pack is installed, and
I confirmed that this happens when I installed language packs on 2.2. I wasn't
referring to the default document language ("DefaultLocale"), but the problem is
the same, since that setting is also in Linguistic.xcu.
Comment 27 Regina Henschel 2007-05-10 08:51:50 UTC
*** Issue 72121 has been marked as a duplicate of this issue. ***
Comment 28 bentley 2007-05-10 08:55:17 UTC

OK, thanks, I did not know the problem is this far reaching - so we basically
talk about two issues/problems.

Comment 29 hagar_de_lest 2007-05-10 09:18:17 UTC
@ ayaniger: yes, I fully agree with you, the fix is definitively not user
friendly. But it's the only one I know. In fact, I had written to Laurent (who
maintains the DicOOo wizard) when I spotted the issue (I even told him the
problem came from the macro where there was an operation related to this
linguistic.xcu file). The macro has been modified (no explicit reference to the
file now) but it seems there is still an operation related to the file via the
code this time. Therefore, and this could explain why the issue also occurs with
the language packs installation, perhaps this issue should be assigned to the
"code" module instead of "lingucomponent". But I'd like to have it confirmed by
a developer who knows how the mechanics works.

@ bentley: there are 2 issues but the root cause is the same.
Comment 30 Regina Henschel 2007-05-10 09:52:00 UTC
add me to cc
Comment 31 majukr05 2007-05-10 10:03:40 UTC
Some reflections

(1) There isn't a Linguistic.xcu in ...share\registry\data\org\openoffice\Office
after having installed OOo. This file appears for the first time e.g. after
having installed new dictionaries by wizard from web. 

(2) It seems, after the existence of this file, user settings in
...user\registry\data\org\openoffice\Office\Linguistic.xcu are replaced by the
settings of 2.2\share\registry\schema\org\openoffice\Office\Linguistic.xcs

[It was a former workaround I tried, to change the settings in Linguistic.xcs;
it worked but is wasn't stable (e.g. if OOo crashes) and too rigid.]

(3) There issue 72559 comes into play. (After updating OOo ...share/dict/ooo is
overwritten; most of the users don't have a copy - and to get back their
dictionaries, they have to start the wizard 'Install new dictionaries ...'

(4) That has the double effect of the summary of this issue: 
'User settings overridden by installation'
Comment 32 alan 2007-05-10 10:15:12 UTC
Since our Hebrew version of OOo requires defaults settings for CTL, the Hebrew
version has Linguistic.xcu immediately after installation. I imagine this is the
case for other non-English versions as well. So for us, this not a problem only
if you happen to have downloaded dictionaries, but it's a problem for every user
who wants to install a language pack.
Comment 33 hagar_de_lest 2007-05-10 10:24:53 UTC
@ majukr05 : but the 2 issues are not on the same level.
- Here, the user file is not deleted (or is it ? don't remember exactly), just
not taken into account. It's a kind of "priority" issue.
- In the issue 72559, however, the complete folder is overwritten! and users
have to reinstall completely the dictionaries.

@ ayaniger : the language pack problem makes me think this issue should be
transfered to "framework" now.

Could a developer investigate ? I fear we've to make some marketing to increase
the votes number for this issue.
Comment 34 bentley 2007-05-10 23:12:08 UTC
should be not too complicated to fix (me thinks) since there was no such issue
in OO2.1 (for me) - sounds to me one of the linguistic related code changes in
2.2 messed up!?

Comment 35 majukr05 2007-05-11 06:34:44 UTC
@ hagar_de_lest: 
Restarting OOo: User file Linguistic.xcu (with last user settings - ~8-9 KB) 
is changed to Linguistic.xcu.bak; 
new user file Linguistic.xcu (without user settings - 1 KB) - e.g.:

[Date: 2006-10-28;$Win32/680m5$Build-9073]

<?xml version="1.0" encoding="UTF-8"?>
<oor:component-data xmlns:oor=""
xmlns:xs="" oor:name="Linguistic"
 <node oor:name="General">
  <prop oor:name="DefaultLocale" oor:type="xs:string">

That's all - no 
<node oor:name="DictionaryList">, 
and no 
<node oor:name="ServiceManager">
  <prop oor:name="DataFilesChangedCheckValue" oor:type="xs:int">

AFAIR the appearance of this malfunction is (for me) since v 2.0.3/2.0.4 -
but perhaps it was overlapped with the problem quickstart.exe (for Win).
But I also tried without quickstart.exe, with the same results.
Since 2.1/2.2 I don't use quickstart.exe anymore.
Maybe there are different causes with the same appearance/results?
Comment 36 jstanhope 2007-07-16 01:57:21 UTC
I, also, have had this problem with installing dictionaries since 2.1 or 2.0.

Upgrading OOo (on Win 2000) uninstalls the dictionaries but leaves their files 
in the dictionary folder.  After reinstalling (using the built-in wizard) I 
cannot set/save the Default Language to anything other than English (USA).

Deleting the global linguistic.xcu file 
(share\registry\data\org\openoffice\Office) permits changes to the default 
language but uninstalls the dictionaries!

I have got past the problem by copying the "DefaultLocale" XML record from the 
user file into the global one while OOo is not running - leaving the global 
dictionary records unchanged.  This corrects the Default Language setting but 
still does not allow me to modify it from the UI.

For example...
 <node oor:name="General">
  <prop oor:name="DefaultLocale" oor:type="xs:string">

It appears that UI changes are written to the user linguistic.xcu file, but 
this is overridden at run time by the global one if it exists.  Unfortunately 
it must exist if additional dictionaries are installed for all users.
Comment 37 bentley 2007-07-16 04:19:51 UTC
I (again) see the problem with OO 2.2.1 that the custom dic settings (en-AU) are
reset to US. The old trick to delete the Liguistic.xcu no longer works since the
dictionary installation (now) gets lost and therefore its switching back to US.

Nice double catch!

I read here copying from local to global would do the trick but I've no idea 
where is what :(

hints? (I am no developer)
Comment 38 jstanhope 2007-07-16 06:42:50 UTC
Bentley... refer to majukr05's previous comments on this topic.

The user file location depends on a number of things to do with how Windoze is 
set up, so the best way to find it is to search your disk for "*.xcu".

If you have OpenOffice installed in the standard place then the global 
Linguistic.xcu file is in the folowing folder:
C:\Programme\ 2.0\share\registry\data\org\openoffice\Office

As a more complete example, the contents of my global file (with Default Locale 
set to "English (Australia)" and the "en-AU" dictionary & thesaurus installed) 

<?xml version="1.0" encoding="UTF-8"?>
<oor:component-data xmlns:oor="" 
xmlns:xs="" oor:name="Linguistic" 
 <node oor:name="General">
  <prop oor:name="DefaultLocale" oor:type="xs:string">
 <node oor:name="ServiceManager">
  <node oor:name="LastFoundSpellCheckers">
   <prop oor:name="en-AU" oor:op="replace" oor:type="xs:string">
  <node oor:name="SpellCheckerList">
   <prop oor:name="en-AU" oor:op="replace" oor:type="xs:string">
  <node oor:name="HyphenatorList">
   <prop oor:name="en-AU" oor:op="replace" oor:type="xs:string">
  <node oor:name="LastFoundHyphenators">
   <prop oor:name="en-AU" oor:op="replace" oor:type="xs:string">
  <node oor:name="LastFoundThesauri">
   <prop oor:name="en-AU" oor:op="replace" oor:type="xs:string">
  <node oor:name="ThesaurusList">
   <prop oor:name="en-AU" oor:op="replace" oor:type="xs:string">
Comment 39 bentley 2007-07-16 07:24:43 UTC

My global looks exactly like yours as listed (all en-AU) but dic still resets to
US once OO is closed/started.

majukr05's comment does not makes sense to me since the files he compares are
not comparable due to a totally different contents.
Comment 40 hagar_de_lest 2007-07-16 07:49:11 UTC
@ jstanhope: I don't think the "global" linguistic.xcu is needed for multiple
users. Dictionaries configuration is done in the dictionary.lst file, in the
global /share/dics/ooo/ folder and/or in the user profile folder /wordbook).

I can't see how the linguistic.xcu file could "uninstall" dictionaries as you've
Comment 41 bentley 2007-07-16 07:58:16 UTC
If there is a *working* solution to my problem I would be grateful for advice.
Currently I have to set my (local) dic every time I start OO2. 


Comment 42 hagar_de_lest 2007-07-16 08:39:14 UTC
Perhaps stupid question but who knows : are you sure your template has been
configured with the right language in the "Default" paragraph style ?
Comment 43 bentley 2007-07-16 08:50:13 UTC
even more stupid question from me - how can I find out? what have I to do?
Comment 44 hagar_de_lest 2007-07-16 10:46:17 UTC
See here :
Comment 45 bentley 2007-07-16 21:45:53 UTC
OK, I could side step the problem by creating a template and making this
template start-up default. 

However, the original problem needs to be fixed! - if I set a certain dictionary
in the Options it has to be permanently the default until changed again.

Comment 46 jstanhope 2007-07-17 01:05:13 UTC
I have done some experimenting, starting off with the modified global  
Linguistic.xcu from my previous post.  

1.  I removed the global file:  The UI Default Language setting was reset to US 
english, I lost my AU dictionaries, and I could *not* save a changed Default 
Language setting.  The global file was not recreated when OOo was restarted.

2.  I then removed the user file:  The UI Default Language remained as US 
english, I regained my AU dictionaries, and I was able to save a changed 
Default Language setting.  The local file was recreated when OOo was restarted

3.  I then restored the global file (with its "DefaultLocale" entry changed to 
"en-US" for testing):  The UI default language remained as AU english, my AU 
dictionaries remained installed, and I was able to save a changed Default 
Language setting.

@ bentley:  I think your solution might be to remove both the global & user 
Linguistic.xcu files, let OOo refresh its settings, and then update any 
settings you need.  This should reset the user file so that next time you only 
have to remove the global file as has been stated in other comments on this 

@ hagar_de_lest: I am not a developer so I don't know how this is all supposed 
to work.  However in practice, installing dictionaries (certainly with the 
"Administrator setup" option) seems to update both the dictionary.lst file and 
the global Linguistic.xcu file but not the user file(s).  But the OOo UI only 
updates the user file, which is overridden by the global one and in turn 
overrides the dictionary file - which may be why there is all this trouble.

Hope this helps, James.
Comment 47 bentley 2007-07-17 01:43:51 UTC

I searched my C drive for the Linguistic.xcu and only found one, that one buried
deep in the folder, and deleted it.

Deleted my start-up template from OO and reset template to default (otherwise OO
complains about the missing template when starting), started Writer and
installed the dic again, set it to en-AU again and closed writer.

Guess what, US-en is back once you restart Writer. 

Having said that the main problem seems OO2 is using an *default US template*
when it starts even you don't select to use any template and even you choose
another default dic in the options! Are we now closer to a working sloution?


Comment 48 jstanhope 2007-07-17 06:23:08 UTC
@ bently:  When you searched the C: drive did you tell Windows to search for 
hidden files & folders?  If you have a standard Win 2k/XP setup there should be 
".xcu" files in 2 places.

User:  C:\Documents and Settings\[username]\Application 

Global:  C:\Program Files\

The user Linguistic.xcu file was the significant one for me (removing it fixed 
the problem) but it is normally under the hidden "Application Data" folder.

Unfortunately I can't help you with template problems as I have not had any.
Comment 49 bentley 2007-07-17 07:06:57 UTC

Nope, I used the standard search in XP - following your advice I indeed (now)
see two Linguistic.xcu files and one .bak which I deleted now.

Started Writer, set Options to dic en-AU, closed Writer. Once started again it
was indeed still on AU.  :0 :)

thanks for being persistent! I wish OO2 would be less stricken to manage

greetings from Hervey Bay!

Comment 50 thorsten.martens 2007-08-13 08:42:12 UTC
*** Issue 80618 has been marked as a duplicate of this issue. ***
Comment 51 maison.godard 2007-08-16 21:21:37 UTC
please find an attempt of workaround on the attached file, it is a preview of a
coming 1.8 DicOOo version

Please da as quick as possible for reviewong and give feed back so that we may
insert it in the coming 2.3 version if possible

see issue 72559
Comment 52 maison.godard 2007-08-16 21:22:12 UTC
Created attachment 47577 [details]
DicOOo 1.8 prototype
Comment 53 Regina Henschel 2007-08-16 22:08:28 UTC
I have tested DictOOo1.8 with OOo2.2.1de on WinXP with French and with Spanish.
It works fine for me. The dictionary.lst has the entries for the new language,
nothing else is touched. There is no linguistic.xcu in share/registry/... :) and
the settings in Tools/Options are not touched. Changes there are persistent.
Both new languages are available for spell check.
Comment 54 thomas.lange 2007-08-16 22:21:20 UTC
Thank you Laurent and Regina!
Comment 55 majukr05 2007-08-17 00:05:10 UTC
I want to confirm the results of regina.

Tested DicOOo 1.8 proto (on WinXP) with 
(1)$Win32 OpenOffice.org_project/680m18$Build-9161
DICT pt BR pt_BR
HYPH pt BR hyph_pt_BR]

(2) OOo-dev/2.3$Win32 OpenOffice.org_project/680m1$Build-9206
DICT pl PL pl_PL
HYPH pl PL hyph_pl_PL
THES pl PL th_pl_PL_v2]

That's great - now all is working fine:
- no Linguistic.xcu in '... share ...'
- switching languages of UI (in 2.2.1) without problems
- user dictionaries were not disabled
- settings in 'Writing aids|Options' are stable
- spell checking without problems (also with the new language modules)

- only: all available language modules were acitivated (own selection was
vanished) in both versions; but perhaps that's normal (I don't remember) 
and after a new configuration there was no more change ...

Thanks to all :-)
Comment 56 maison.godard 2007-08-17 09:35:47 UTC
dicooo 1.8 will be released to deal with this

*** This issue has been marked as a duplicate of 80770 ***
Comment 57 bentley 2007-08-17 10:12:27 UTC
well this issue is nearly one year old until it has been fixed - not exactly
impressive but better late than never ;)
Comment 58 jstanhope 2007-08-22 23:26:51 UTC
Thanks very much for your work Laurent.
Comment 59 hagar_de_lest 2007-09-18 10:27:33 UTC
Hi All,

This issue has still 22 votes. As it has been fixed now with the new wizard,
don't forget to remove your votes from it and to report them on other issues.
Comment 60 bentley 2007-09-18 22:02:44 UTC
so how do I remove a vote and where?

I've not yet tested it but trust it is fixed coz I don't want to uninstall OO
just to test that.

Comment 61 hagar_de_lest 2007-09-18 22:09:36 UTC
To remove a vote, log in, go to My votes (under the issue number) replace the
vote by 0 in the related issue and submit the change with the button at bottom.
Comment 62 bentley 2007-09-18 22:26:05 UTC
Aha, done!
Comment 63 Mechtilde 2008-11-05 20:58:22 UTC
close the duplicate