Issue 73074 - Calc: Advanced filter
Summary: Calc: Advanced filter
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial with 5 votes (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: oooqa
: 63750 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-01-03 10:34 UTC by claudiadzm
Modified: 2017-05-20 11:41 UTC (History)
8 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Advanced filter (8.42 KB, application/vnd.sun.xml.calc)
2007-01-03 14:05 UTC, claudiadzm
no flags Details
The patch of this issue. (767 bytes, text/plain)
2009-05-04 09:07 UTC, gaojingmei
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description claudiadzm 2007-01-03 10:34:30 UTC
When I define an advanced filter for a named range, it is possible to refresh
the range and if the source range has changed, the filter-result is also actualized.

But this refreshing considers only changes of the data-range. It does not
re-read the criteria-range.

It should be possible to actualize a filter-result and the actualization
re-reads not only the source-data-range but also the criteria-range
Comment 1 kpalagin 2007-01-03 10:57:46 UTC
claudiadzm,
any chance you could provide sample file?
Comment 2 claudiadzm 2007-01-03 14:05:57 UTC
Created attachment 41854 [details]
Advanced filter
Comment 3 claudiadzm 2007-01-03 14:09:07 UTC
I created an example. What I mean:
When the criterias in the filter-range are changed, it would be nice, if the
range-refreshing would consider them.
As now you have to open the definition-dialogue as for a new filter.
Hope my english is understandable
Comment 4 claudiadzm 2007-02-12 06:36:37 UTC
Seems as if there is no interest for this issue. I'll give another example, that
might show better the problem:

the criteria-range may be created with a formula instead of e fix value, f.e.:
=">"&=AVEDEV(D2:D6000)

When the data in the data-range change, this criteria propably also changes and
an actualization of the range should not only consider the datarange but also
the new criteria
Comment 5 frank 2007-02-13 13:59:46 UTC
As enhancement re-assigned to requirements for decission finding.

Matthias, Niklas, please comment on this one and retarget as needed.

Frank
Comment 6 pmike 2008-08-06 06:39:51 UTC
This is a dupe to issue 85305
Comment 7 amy2008 2008-08-29 04:30:43 UTC
I don't think it is a duplication to issue 85305
Comment 8 gaojingmei 2009-05-04 09:07:57 UTC
Created attachment 61969 [details]
The  patch of  this issue.
Comment 9 niklas.nebel 2009-05-05 17:50:49 UTC
taking the issue
Comment 10 niklas.nebel 2009-05-05 17:54:30 UTC
I added the patch to CWS "calc50".
Comment 11 niklas.nebel 2009-05-28 15:21:32 UTC
reassigning to QA for verification
Comment 12 oc 2009-06-08 12:59:32 UTC
verified in internal build cws_calc50
Comment 13 Terry Yang 2012-09-21 09:09:07 UTC
*** Issue 63750 has been marked as a duplicate of this issue. ***