Issue 73417 - View of HTML page looks different to view in standard browsers, so no real WYSIWIG
Summary: View of HTML page looks different to view in standard browsers, so no real WY...
Status: CLOSED DUPLICATE of issue 19690
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.1
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: eric.savary
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-01-12 14:48 UTC by lduplant2000
Modified: 2007-05-04 15:13 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Sample html for Thunderbird signature (1.16 KB, text/html)
2007-01-15 13:30 UTC, lduplant2000
no flags Details
Screen shot of Signature_example.html (202.65 KB, application/vnd.oasis.opendocument.text)
2007-01-15 13:31 UTC, lduplant2000
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description lduplant2000 2007-01-12 14:48:23 UTC
I did a simple signature for Thunderbird in Writer and saved it in HTML file
format. When the file is viewed in Thunderbird, Firefox of Internet Explorer the
formatting is all wrong; caracters are smaller and line spacing larger (apporx
1.5 lines). I opened the Writer/html file in Front Page, corrected the
formatting and saved it again in html. Formatting is corrected.
Comment 1 michael.ruess 2007-01-12 16:06:04 UTC
Reassigned to es.
Comment 2 eric.savary 2007-01-15 10:02:00 UTC
Please attach a sample document.
Comment 3 lduplant2000 2007-01-15 13:30:07 UTC
Created attachment 42170 [details]
Sample html for Thunderbird signature
Comment 4 lduplant2000 2007-01-15 13:31:43 UTC
Created attachment 42171 [details]
Screen shot of Signature_example.html
Comment 5 lduplant2000 2007-01-15 13:32:31 UTC
Attached are a sample html file and a screen shot view of this html file opened
in Writer, Firefox, IE 7 & Front Page.
Comment 6 Rainer Bielefeld 2007-04-09 16:15:36 UTC
The reported problem is concerning the viewing in OOo, indeed, in OOO  the test
document looks different from the view in all other browsers.
I checked with "2.2.0RC4  German version WIN XP: [680m14(Build9134)]" and
compared view with view in Seamonkey (and IE). I can confirm the differences
shown in  "Screen_Shot.odt". 

Character size must no be a real bug, because that is adjustable in the browser,
so that the size with what some text will be shown might differ from browser to
browser. But the completely different line spacing view in OOo (no extra
distance between line "Tel." and "Fax") really might cause problems if OOo will
be used as a HTML editor. 
Comment 7 Rainer Bielefeld 2007-04-09 16:16:59 UTC
So NEW
Comment 8 Rainer Bielefeld 2007-04-09 16:17:43 UTC
Hey, what's on with the NEW radio button here?
Comment 9 eric.savary 2007-05-04 15:13:01 UTC
Well, this is an old known problem of compatibility or merged UI Writer <>
Writer Web <> HTML.
(Thus duplicate of issue 19690)

You probably formatted the 2 lines with the Default paragraph style whch has a
simple space between paragraphs in Writer (Same in Writer Web) but is exported
as a <p> tag which has a double space in all browsers...

Workaround: use a line break (Shift+Return = <br>) instead of a carriage return
(Return = <p>) between the paragraphs or format them as "Preformatted text" (=
<pre>).

*** This issue has been marked as a duplicate of 19690 ***
Comment 10 eric.savary 2007-05-04 15:13:20 UTC
closed