Issue 73625 - proposal for problematic UNC file url's
Summary: proposal for problematic UNC file url's
Status: CLOSED NOT_AN_OOO_ISSUE
Alias: None
Product: udk
Classification: Code
Component: code (show other issues)
Version: OOo 2.1
Hardware: All Windows, all
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-18 15:02 UTC by pulsifer
Modified: 2017-05-20 09:24 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description pulsifer 2007-01-18 15:02:44 UTC
-----Background-----

In Windows, a UNC path to a directory looks like this (see
http://support.microsoft.com/kb/311079):

\\server\share\path  

According to the file URI spec, Windows UNC paths should be accepted as file
urls if they are entered like this:

file:///server/share/path

See http://udk.openoffice.org/cpp/man/spec/uris.html, last section, "Hosts";
Note however there is a typo in the spec--it says
file://somewhere/somedir/file.txt but should say
file:///somewhere/somedir/file.txt, with 3 slashes after the "file:".

UNC's paths however have long been problematic in OOo.  See:

http://www.oooforum.org/forum/viewtopic.phtml?p=196522
http://qa.openoffice.org/issues/show_bug.cgi?id=9018
http://qa.openoffice.org/issues/show_bug.cgi?id=13148
http://qa.openoffice.org/issues/show_bug.cgi?id=51026
http://qa.openoffice.org/issues/show_bug.cgi?id=53184
http://qa.openoffice.org/issues/show_bug.cgi?id=56868
http://qa.openoffice.org/issues/show_bug.cgi?id=72031
http://qa.openoffice.org/issues/show_bug.cgi?id=72864
http://qa.openoffice.org/issues/show_bug.cgi?id=73620


Part of the problem would seem to be that in OOo's implementation of file URL's,
it cannot be unambiguously determined if the first component of the URL refers
to a server or to a directory.  For example, in

file:///part1/part2/part3

part1 could refer to the directory /part1 on the local files system, or it could
refer to the server part1 on the local network.

-----The Proposal-----

The submitter proposes that OOo's implementation of UNC file URL's be modified
so it can be unambiguously determined if the first part of the path is a local
directory or a network server.

There are a multitude of syntaxes that could be used.  For example:

file:///server:share/path
file:///server:/share/path
file:///server//share/path
file:///server/share:path
file:///server:share:path
file:///server:share:/path
file:///server/share:/path

What should not be used however, is the current ambiguous implementation
file:///server/share/path

The author of this proposal has no preference for syntax.  Note however that
Microsoft's document http://support.microsoft.com/kb/311079 discusses how
Netware shares are parsed, and this may enter into the decision.  Linux, Solaris
and Samba considerations may also enter into the decision.
Comment 1 Stephan Bergmann 2007-01-18 15:24:20 UTC
@pulsifer:  Why do you think

  file://somewhere/somedir/file.txt

in <http://udk.openoffice.org/cpp/man/spec/uris.html> is a typo?  On the
contrary, it is how OOo (at least tools/source/fsys/urlobj.cxx:1.59) represents
the UNC path

  \\somewhere\somedir\file.txt

as a file URL.  There is no ambiguity in OOo file URLs as to whether or not they
represent UNC paths (except perhaps in the heads of confused users).  There is
no need for any new syntax you propose.

That said, there are most certainly specific issues when dealing with UNC paths
or file URLs representing UNC paths, but they have nothing to do with such an
alleged ambiguity.

(Related, you also sometimes find

  file:////somewhere/somedir/file.txt

to represent the UNC path

  \\somewhere\somedir\file.txt

I do not know how well OOo supports this additional, equally unambiguous syntax.)
Comment 2 pulsifer 2007-01-18 15:49:44 UTC
Hello Stephan,

Thank you for your reply.  To answer your question, I thought it was a typo for
several reasons:

1. In researching http://qa.openoffice.org/issues/show_bug.cgi?id=73620, I tried
four possible syntaxes, "file:/", "file://", "file:///", "file:////" and none of
them worked.

2. I found other instances on the OOo website and documentation that listed the
syntax as "file:///".

3. Shoddy and incorrect documentation abound in the OOo project, so this was a
reasonable conclusion.

In summary, this was not an assumption, it was a conclusion reached based on
experience, research and a diligent effort to solve the problem before putting
in a bug report.

If you are saying that a UNC path is distinguished by having only two slashes
after the "file:", rather than three slashes, then you are right, it is not
ambiguous.  I am still glad I raised the issue however, since (a) this needs to
be better documented; and (b) based on how well UNC paths do not work in OOo,
there seems to be just as much confusion among the developers as the users.

Thank you again for your response.

Allen
Comment 3 kay.ramme 2007-01-19 08:27:22 UTC
Allen, 

would you be so kind to point to the documentation which is inaccurate?

By the way, I did some first tests and it seems that I can reproduce the
problems seen with UNC paths, so I need to dive a bit deeper ... ;-)

 Kay

Comment 4 Joost Andrae 2007-01-19 09:18:43 UTC
modified priority
Comment 5 pulsifer 2007-01-19 12:40:22 UTC
Hello Kay,

I apologize-- I was casting a wide net two days ago for any information that
could help me get this working, and I didn't bookmark most of what I had seen. 
Obviously, having read the spec, I tried that and it didn't work for me then. 
Yesterday, I retried it, and did get some error messages along with way, but was
eventually able to get everything I tried working.  This left me wondering if I
had really typed what I thought I had.  It even reached the point that I
rebooted my machine, cleared my OOo config, and tried everything again, just to
make sure.  Again, everything worked.  My write up is at
http://www.oooforum.org/forum/viewtopic.phtml?p=202357&highlight=#202357, and my
documentation on file URL's is at
http://OpenOfficeTechnology.com/documentation/OpenOffice-Configuration/File_URLs.

I am not at this point left with confidence that file URL's are really working
reliably or robustly, but was eventually able to get every thing working and was
not able to consistently reproduce any failures.  I would be interested in
hearing what you tried and saw in your testing.

In my testing, I was trying file URL's in the File | Open dialog, as well as the
template path configured in
org.openoffice.Office.Paths/Paths/NamedPath['Template']/UserPaths (see
Paths.xcs) and the default template file set by
org.openoffice.Setup/Office/Factories/Factory['com.sun.star.text.TextDocument']/ooSetupFactoryTemplateFile
(see Setup.xcs).

This issue should probably be marked as invalid, because as Stephan pointed out,
there is no ambiguity in the spec between a local URL and a network URL.  For a
network URL, it is ambiguous whether the server name is a UNC name or a DNS
name, but I don't know if this makes a difference in the lower level networking
code.

Allen
Comment 6 oooforum (fr) 2014-11-28 08:17:30 UTC
The Issue you raised has the status 'Unconfirmed' pending further action, but has not been updated within the last 7 years. Please consider re-testing with one of the latest version of AOO, as the problem(s) may have already been addressed.