Issue 74068 - "Replace dashes" needs improvement
Summary: "Replace dashes" needs improvement
Status: CLOSED DUPLICATE of issue 5018
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.3
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-31 17:41 UTC by abryl
Modified: 2007-07-18 16:57 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description abryl 2007-01-31 17:41:48 UTC
Currently "Replace dashes" option of AutoCorrect dialog allows to replace a
hyphen with a dash in situations like "word - anotherword". However, this is not
enough at least for Russian and Belarusian languages, where dash may follow a
punctuation mark, or even start a paragraph. Direct speech in this languages is
often written like:

- Something, - said John. - Something more!

So it will be very useful to have sub-options "after punctuation marks" and "at
the beginning of a paragraph" is the "Replace dashes" option, switched on by
default for some languages.
Comment 1 michael.ruess 2007-02-01 07:58:12 UTC
Reassigned to SBA.
Comment 2 stefan.baltzer 2007-07-18 16:40:55 UTC
SBA: Reassigned to requirements.

Comment 3 stefan.baltzer 2007-07-18 16:57:31 UTC
SBA: Confirmed. But duplicate.

*** This issue has been marked as a duplicate of 5018 ***
Comment 4 stefan.baltzer 2007-07-18 16:57:59 UTC
SBA: Closed.