Issue 74265 - distribution of hyph_nl_NL.dic is violating the LPPL
Summary: distribution of hyph_nl_NL.dic is violating the LPPL
Status: CLOSED DUPLICATE of issue 74309
Alias: None
Product: General
Classification: Code
Component: spell checking (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: issues@lingucomponent
QA Contact: issues@lingucomponent
URL:
Keywords: oooqa
Depends on:
Blocks: 54505
  Show dependency treegraph
 
Reported: 2007-02-07 13:40 UTC by doko
Modified: 2013-02-24 20:43 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description doko 2007-02-07 13:40:34 UTC
The README_nl_NL.txt mentions the hyph_nl_NL.dic file as follows:

  It is based on the TeX hyphenation patterns file that created and original 
  copyright by Piet Tutelaer.

  It is made available under the conditions of the LGPL license. 

  Arthur Buijs modified the hyphenation patterns file so that it can be used
  with the ALTLinux hyphenator.

It is violating point 6d of the LPPL (appended paragraph 6), which requires
either distribution of the unmodified file, or "Information that is sufficient
to obtain a complete, unmodified copy of the Work", or both.

For the "information" option, please include either a download location or a
pointer into a TeX distribution like MiKTeX, TeXLive or TeTeX. 
http://www.tug.org/tex-archive/language/hyphenation/ should work; for the
filename mention hyphen/nehyph.tex.

Some people think it's necessary to include the version information of this file
as well; rationale: you should be able to update your work if the original file
changes, seems to be easier if you know the base of your derived work.

Note that both the location and the filename are just guesses.
Comment 1 jbf.faure 2008-02-24 19:37:28 UTC
The README_nl_NL.txt for 2.4.0 version is different, it says :
--->
[ENGLISH] 
Dutch word list - OpenTaal
Version: 1.00 G
Format: MySpell

License:
--------------------------------------------------------------------------------
Use and/or distribution of the Dutch wordlist including the hyphenation 
patterns
is only allowed in accordance to the license conditions of the GNU Lesser 
General Public License (GNU LGPL). The text of this license is included at the 
end of this file. You are kindly requested to keep a copy of this file 
"README_nl_NL.txt" with every copy you make of the word list.

About the "Keurmerk Spelling" of the Dutch Language Union
--------------------------------------------------------------------------------
The Dutch Language Union declares that this product applies the rules
and principles of the official spelling, that is defined by The Dutch
Language Union, and that in a checking procedure no deviations were found.

For more information about the Keurmerk Spelling, please see: 
       www.taalunieversum.org/keurmerk (Dutch)
For more information about the Dutch Language Union see:
       http://taalunieversum.org/en/ (English)

About the Dutch word list:
--------------------------------------------------------------------------------
(c) 1996 Nederlandstalige Tex Gebruikersgroep
This word list is based on the Dutch word lists that were created 
by the Nederlandstalige TeX Gebruikersgroep. These word lists are made 
available 
under the conditions of the GNU LGPL. For more information, see:
http://www.ntg.nl/spelling/

(c) 2001, 2002, 2003, 2005 Simon Brouwer et al.
Conversion to the Myspell-format, and further improvements to the word list. 

(c) 2006, 2007 OpenTaal
Adaptation to the Dutch Official Spelling rules 2005 from the Dutch Language 
Union (Nederlandse Taalunie), and other considerable additions and 
improvements. For more information, see: http://www.opentaal.org/

Contact:
--------------------------------------------------------------------------------
For information about the OpenTaal project: 
http://www.opentaal.org/english.php
For questions and suggestions, write email to Simon Brouwer: 
simon.oo.o@xs4all.nl
<----

Can we assume that the problem has been fixed ?
Comment 2 rene 2009-01-21 16:31:10 UTC
[ sorry, oversaw your comment ]

jbfaure: maybe I am blind, but where do you see this?

the original file is not in the tree, and I don't see a pointer to the original
files?


That RAEDME_nl_NL is for the *spellchecking* dicts ("MySpell"), not *hyphenation*
Comment 3 jbf.faure 2009-01-21 22:04:33 UTC
Hi Rene,

it is the English part of the file README_nl_NL.txt you got when you install NL
dictionaries using Dicoo. This file mentions hyphenation patterns.
In fact there is a mistake in issue description because the name of readme file
for hyphenation is "README_hyph_nl_NL.txt", not "README_nl_NL.txt" and you got
it if you install hyphenation dictionary with Dicoo.

Regards
JBF
Comment 4 mechtilde 2009-06-21 14:02:26 UTC
@ cor

can you confirm it?
Comment 5 cno 2009-06-21 19:37:48 UTC
Hi Mechtilde, all,
I can confirm that the current dict-nl.oxt contains the text in the file 
  ..OOo<version>\3\user\uno_packages\cache\uno_packages\4E.tmp_\dict-nl.oxt
So is fixed in the mean time.
I can/do not judge on details from the past situation, but that is not relevant
any more now, I think ..

@Simon, agree?

Cor
Comment 6 simonbr 2009-06-21 21:13:04 UTC
Hi all, 

We are distributing the hyphenation patterns file under the conditions of the
LGPL. Its original author, Piet Tutelaer, has given explicit permission to do so.

So the distribution does not have to comply to the LPPL.
Comment 7 mechtilde 2009-12-18 21:50:31 UTC
working out a solution described in 74309

So i set this issue as duplicate

*** This issue has been marked as a duplicate of 74309 ***
Comment 8 mechtilde 2009-12-18 21:57:25 UTC
-> closed