Issue 74355 - Changing chart axis to logarithmic scale is not added to undo history
Summary: Changing chart axis to logarithmic scale is not added to undo history
Status: CLOSED DUPLICATE of issue 101423
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 2.0.4
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: requirements
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-08 23:21 UTC by jdpipe
Modified: 2013-08-07 15:12 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description jdpipe 2007-02-08 23:21:03 UTC
When changing the format of a chart axis from linear to logarithmic scale, the
action is not added to undo history. This means that pressure undo does not undo
that change to the chart, but instead undoes an earlier action, and leaves the
modified chart as-is.

Happens every time. This with OOo 2.0.4 on Ubuntu 6.10.
Comment 1 jdpipe 2007-02-08 23:22:12 UTC
woops, meant *pressing undo*.
Comment 2 kpalagin 2007-02-09 08:32:54 UTC
Can't repro with 2.2m2 on WinXP.

jdpipe,
please try with the latest build from www.openoffice.org (not distro-specific).
Comment 3 frank 2007-03-20 15:57:26 UTC
Hi,

your problem can be reproduced only if you have left the Chart Edit mode. In
this case the undo stack is reset to the Spreadsheet application from the Chart
application.

BTW Chart related Issues have to be filled under the Chart Component and not
Spreadsheet.

Frank
Comment 4 jdpipe 2007-03-21 08:10:16 UTC
Sorry to reopen...

Frank, you said "your problem can be reproduced only if you have left the Chart
Edit mode."

This means that you reproduced it? But you still don't think it's a bug?

Cheers
JP
Comment 5 frank 2007-03-21 09:48:49 UTC
Hi,

yes, it's not a bug because you have closed the application there the undo stack
is used. If you undo the scaling with the Chart still in Edit mode (small black
handles) it works. Only after leaving the chart the undo stack is reset and the
one for Calc is used again.

Frank
Comment 6 frank 2007-03-21 09:49:10 UTC
closed wfm
Comment 7 jdpipe 2007-03-21 10:09:52 UTC
Sorry, I'm going to be a pain now.

From the usability point of view I don't see that it's reasonable to expect the
user to realise this. If there is some issue with undo stacks not being
transferred from one so-called 'application' to another, so be it. But this is
not "not a bug", in my view.

Perhaps you can link this bug to one where there is a request to make 'undo
stacks' unified, if such exists.

JP
Comment 8 frank 2007-03-21 10:19:20 UTC
Hi,

there is no such Issue, so this one is re-flagged and reassigned to requirements
for decission finding.

Frank
Comment 9 jdpipe 2007-03-21 10:25:37 UTC
Cool, thanks. FWIW I would be arguing that this was a DEFECT. The current
behaviour is definitely non-intuitive from the user's point of view.
Comment 10 frank 2007-03-21 10:32:56 UTC
Please don't change the Issue TYpe field. It's not a defect even if you think
so. It works as designed and therefore this is if it's an Issue an enhancement.

Frank
Comment 11 jdpipe 2007-04-04 01:49:19 UTC
So if one wishes to report a bug in the /design/ as opposed to the
/implementation/ one must call it an /enhancement/, is that right? Software
designers can't make mistakes, only coders? I find your response rather
frustrating, as I feel that this bug report will now languish in the 'we'll fix
it one day' category, and not treated as the usability bug that I feel it to be.
Comment 12 IngridvdM 2009-04-29 10:46:44 UTC
I created a new issue 101423 to request a common undo stack containing also the
chart changes within the parent application. I think the new issue will be
easier to read for other people as this one with its lengthy discussions. So
chances might be better that the new issue collects some votes.
As long as that feature is not implemented, I am sorry, you will need to double
click on the chart to be able to undo changes of the chart.

*** This issue has been marked as a duplicate of 101423 ***
Comment 13 IngridvdM 2009-04-29 10:50:13 UTC
closing as duplicate