Issue 74531 - Actual Technologies ODBC driver throws error when accessing tables
Summary: Actual Technologies ODBC driver throws error when accessing tables
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOo 2.1
Hardware: Mac Mac OS X, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa, regression
Depends on:
Reported: 2007-02-14 10:50 UTC by alex.thurgood
Modified: 2013-08-07 15:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description alex.thurgood 2007-02-14 10:50:29 UTC
Platform : MacIntel Tiger, latest security fixes

Driver : ODBC driver from Actual Technologies for MacOSX

Remote DB : mysql

I downloaded, installed and configured the ODBC drivers on a MacIntel
Tiger to access a remote MySQL database. The connection test
from within the installer worked fine.

I then tried to set up an ODBC datasource document from within This worked and I can see the list of tables when I click
on the Tables icon button on the left hand side of the ODB document

However, if you double-click on any given table to open it and display
its contents (equivalent to the SQL instruction : SELECT * from Table1),
or if you attempt to execute a query directly on the table, via the Query button
(native SQL or SQL View), even if you
limit the responses to 3 (since this is an automatic limitation of the
demonstration period driver, this shouldn't be necessary, but I did the test
anyway), the following error message is displayed :

Driver does not support this function

When you click on the error message window, the table window will then
display, but no data is available.

I have contacted Actual Technologies and they have confirmed that this problem
exists with their driver in OOo 2.1, but not in the OOo 2.0.x branch, which
means that something somewhere got broken in the OOo development, or that the
driver was making a call that was tolerated in the 2.0.x branch and which now
throws an error.

It would be nice if this could be sorted, since at present there appears to be
no means of connecting a MacIntel to a remote mysql db.

Comment 1 alex.thurgood 2007-02-14 10:51:17 UTC
setting regression and oooqa keywords
Comment 2 alex.thurgood 2007-02-14 10:55:01 UTC
BTW, I can't test this against a dev 2.2 version of OOo because it is on a
production machine.

Comment 3 marc.neumann 2007-02-21 15:21:27 UTC
can you have a look on this mac issue.
Comment 4 jogi 2009-04-08 11:40:52 UTC
Comment 5 ocke.janssen 2011-02-10 08:39:46 UTC
Is the issue still valid with a OOo 3.3?
Comment 6 alex.thurgood 2011-02-10 10:16:20 UTC
Hi Ocke,

Well I don't get the same error message anymore. 

I can connect to my mysql database. I can see my tables when I click on the
Tables button in the ODB container. However, when I try to get any data to
display by clicking on any of the tables, I get the following error message, and
of course no data are displayed : 

Impossible de charger le contenu des données (i.e. can not load data content)

Error Status SQL: 24000

[Actual][MySQL] Invalid cursor state

The following SQL instruction caused the error :

SELECT * FROM `action_type`

Using the latest Actual Technologies ODBC driver 3.0.13, which uses a
mysqlclient library version 4.1.14, and on Mac OSX, using OOo 3.3 final.

Comment 7 alex.thurgood 2011-02-10 10:17:04 UTC
Addendum :

In other words, it still doesn't work.

Comment 8 ocke.janssen 2011-02-16 13:53:41 UTC
I'll take a look at it.