Issue 74854 - MsgBox with info icon shows wrong buttons
Summary: MsgBox with info icon shows wrong buttons
Status: CLOSED FIXED
Alias: None
Product: App Dev
Classification: Unclassified
Component: scripting (show other issues)
Version: 3.3.0 or older (OOo)
Hardware: All All
: P4 Trivial
Target Milestone: 4.1.0
Assignee: hdu@apache.org
QA Contact:
URL:
Keywords:
: 25150 98161 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-02-25 17:03 UTC by catkin
Modified: 2017-05-20 09:32 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.1
Developer Difficulty: ---


Attachments
Patch to add InfoBox constructor that takes the style and to fix the problem (1.60 KB, patch)
2013-12-02 09:14 UTC, hanya
no flags Details | Diff
test document for different MsgBox styles (10.16 KB, application/vnd.oasis.opendocument.text)
2013-12-02 12:35 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description catkin 2007-02-25 17:03:00 UTC
' These work as expected showing Yes, No and Cancel buttons plus
' successsively Stop, Question and Exclamation symbols
MsgBox "message", 3
MsgBox "message", 3 + 16 
MsgBox "message", 3 + 32
MsgBox "message", 3 + 48

' This does not work as expected, showing Yes, No and Cancel buttons plus
' an Information symbol.
' It gains the Information synbol but the only button is an OK button
MsgBox "message", 3 + 64
Comment 1 noel.power 2007-02-26 11:51:46 UTC
->ab
Comment 2 ab 2007-02-28 13:03:13 UTC
STARTED, 2.x
Comment 3 Mathias_Bauer 2007-12-04 14:57:33 UTC
basic and scripting issues now should be assigned to component "scripting"
Comment 4 Martin Hollmichel 2007-12-07 12:13:32 UTC
set target to 3.x according to http://wiki.services.openoffice.org/wiki/Target_3x
Comment 5 hdu@apache.org 2010-08-16 12:55:39 UTC
*** Issue 25150 has been marked as a duplicate of this issue. ***
Comment 6 hanya 2013-12-01 15:34:31 UTC
When 64 is specified that shows information symbol is InfoBox class and it 
supports only OK button to show.
Should it support the different kind of buttons only for the MsgBox function?
Comment 7 urmasd 2013-12-01 19:32:20 UTC
It is rather obvious that if the user has requested a dialog with 3 buttons, they should receive a dialog with 3 buttons and not with the 1.
Comment 8 hanya 2013-12-02 09:14:12 UTC
Created attachment 82022 [details]
Patch to add InfoBox constructor that takes the style and to fix the problem

Adds InfoBox( Window* pParent, WinBits nStyle, const XubString& rMessage ); 
to match with the other constructors like ErrorBox or QueryBox.
And use it for the information box in MsgBox function.
Comment 9 SVN Robot 2013-12-02 12:33:07 UTC
"hdu" committed SVN revision 1546977 into trunk:
#i74854# fix buttons in MsgBox with info icon
Comment 10 hdu@apache.org 2013-12-02 12:35:23 UTC
Created attachment 82024 [details]
test document for different MsgBox styles
Comment 11 hdu@apache.org 2013-12-02 12:37:41 UTC
Many thanks to Hanya for the patch! It is committed in trunk now.
Comment 12 hdu@apache.org 2013-12-02 12:41:24 UTC
Clarified the issue summary to be more generic.
Comment 13 hanya 2013-12-08 18:06:14 UTC
*** Issue 98161 has been marked as a duplicate of this issue. ***
Comment 14 hdu@apache.org 2014-04-01 12:35:57 UTC
Verified in the AOO410 branch.