Issue 74897 - macro invocation fires two events instead of one
Summary: macro invocation fires two events instead of one
Status: CLOSED DUPLICATE of issue 66981
Alias: None
Product: Impress
Classification: Application
Component: programming (show other issues)
Version: OOo 2.0.4
Hardware: All Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: christian.guenther
QA Contact: issues@graphics
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-27 05:18 UTC by macslow
Modified: 2007-03-02 10:35 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description macslow 2007-02-27 05:18:19 UTC
Assigning a basic-macro (starting an external program via the Shell()-command)
to an image (thus the image acts like a button when the presentation is run) and
have this be triggered by a click on the image fires two events (probably press
and release) instead of just one (only release).

This happens on slide 17 in:

http://macslow.thepimp.net/talks/bling-it-up_the-talk.tar.bz2

The macro is meant to issue a dbus-command to instruct compiz to rotate the cube
just one time. Instead it rotates the cube two times.
Comment 1 wolframgarten 2007-02-27 08:05:18 UTC
Reassigned. @cgu: didn't you have already another bug for this problem? Thanks
in advance.
Comment 2 christian.guenther 2007-02-27 09:44:37 UTC
You wrote the macro at the wrong position i.e. the macro is saved in the office
and not in the document.
Please attach the macro to reproduce the bug.
Comment 3 macslow 2007-02-27 11:10:32 UTC
I uploaded a new corrected version of the tarball with a fixed .odp file. It's
the same URL.
Comment 4 christian.guenther 2007-03-02 10:34:21 UTC
In my mind this issue is duplicate to issue 66981

*** This issue has been marked as a duplicate of 66981 ***
Comment 5 christian.guenther 2007-03-02 10:35:09 UTC
I close the issue as duplicate