Issue 75040 - SCIM Chinese Not Available
Summary: SCIM Chinese Not Available
Status: CLOSED DUPLICATE of issue 69051
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.1
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@framework
URL: http://www.yourchinatradingpartner.com
Keywords:
: 83677 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-03-02 03:48 UTC by slipwrist
Modified: 2009-07-24 10:39 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description slipwrist 2007-03-02 03:48:20 UTC
Dear Team;

Firstly, thanks for the great product, I've always enjoyed using it.

I'm currently running PCLinuxOS on my machine and tried installing SCIM for my
Chinese language needs.

SCIM works great in every application on the machine - except any belonging to
OpenOffice.Org.

I was wondering whether you had had any similar reports filed.

All the best.

Ken
Comment 1 jlcheng 2007-03-02 05:59:34 UTC
I use SLED 10 and KDE, and zh_CN.UTF8. I only find sometimes can not input
anything(include english char) after opened OOo little long time. And if I close
OOo, then restart OOo, will be good.
Comment 2 slipwrist 2007-03-04 00:50:18 UTC
Thanks, but that doesn't really solve my issue, as you seem to be working in an
ALL Chinese language environment in your distro. I, on the other hand, operate
in an ALL English environment, and only use Chinese for document writing,
editing, and receiving.

Thank you.
Comment 3 thorsten.martens 2007-03-05 08:27:58 UTC
TM->SBA: Please have a look. Sounds more like a wordprocessor- than a
framework-issue.
Comment 4 arego 2008-07-19 05:50:52 UTC
I know this is an old issue, but just in case someone has a problem like this, a
solution may be launch OOo from a console with:

$ export LC_CTYPE="zh_CN.utf8" && openoffice
Comment 5 tessarakt 2008-10-21 01:27:07 UTC
I don't really think this is a solution ...
Comment 6 stefan.baltzer 2008-10-21 09:43:03 UTC
SBA: This issue is based on OOo Version 2.1.
This issue grew a little old in the state of "unconfirmed".

Can someone please update this issue based on OOo 3.0 that was currently released?
Beside OOo being currently developed, in the Linux world, a year is a long time...

Please comment, thank you.
Comment 7 tessarakt 2008-10-21 10:01:32 UTC
Well, I tested yesterday on my Gentoo system with OOo 3.0. scim still does not
work, like under 2.1. Since I tried with 2.1, I even changed my config (don't
ask me exactly what, scim-agent or something like that), so that now it even
runs in psi-im (which is a Qt program, I think).

I can send further info about my system config when I am back home.

I will also try using a Chinese locale.
Comment 8 tessarakt 2008-10-21 10:04:34 UTC
scim has an FAQ entry on OOo:
http://www.scim-im.org/wiki/faq/gtk_gnome/why_i_can_not_input_with_scim_under_openoffice_oo
Comment 9 philipp.lohmann 2008-10-21 10:15:21 UTC
And it's wrong, too. The gtk binding of OOo uses gtk's method for input processing.
Comment 10 tessarakt 2008-10-21 20:00:22 UTC
My environment variables:

XMODIFIER=@im=SCIM
XMODIFIERS=@im=SCIM
QT_IM_MODULE=scim-bridge (<- that one made it work in psi ...)
LANG=de_DE.utf-8
LC_ALL=de_DE.utf-8
GTK_IM_MODULE=scim-bridge

That's all I think might be relevant ...

Neither
$ oowriter
nor
$ export LC_CTYPE="zh_CN.utf8" && oowriter
works for me.

Installed versions of scim and scim-bridge:

[I] app-i18n/scim-bridge
     Available versions:  ~0.4.9 (~)0.4.15-r1 ~0.4.15-r2!t {doc gtk qt3 qt4}
     Installed versions:  0.4.15-r1(17:45:31 05.10.2008)(gtk qt3 qt4 -doc)
     Homepage:            http://www.scim-im.org/projects/scim_bridge
     Description:         Yet another IM-client of SCIM


[I] app-i18n/scim
     Available versions:  1.4.5-r1 (~)1.4.7-r1 {doc gtk}
     Installed versions:  1.4.7-r1(23:45:32 16.08.2008)(gtk -doc)
     Homepage:            http://www.scim-im.org/
     Description:         Smart Common Input Method (SCIM) is an Input Method
(IM) development platform
Comment 11 tessarakt 2008-10-22 20:29:59 UTC
I suggest adding cjk keyword.
Comment 12 michael.ruess 2009-07-24 10:36:07 UTC
*** Issue 83677 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2009-07-24 10:39:22 UTC
Already tracked as issue 69051.

*** This issue has been marked as a duplicate of 69051 ***
Comment 14 michael.ruess 2009-07-24 10:39:50 UTC
Closed.