Issue 75081 - TOC font style is not saved in a MS Word file
Summary: TOC font style is not saved in a MS Word file
Status: CLOSED DUPLICATE of issue 29139
Alias: None
Product: Writer
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.2 RC2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-03 05:37 UTC by raindrops
Modified: 2007-03-06 11:38 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description raindrops 2007-03-03 05:37:40 UTC
I created a MS Word (*.doc) file using Writer. (I did not create an odt file
because not all of the intended readers would have OOo installed on their PC.)

I wanted the TOC to have hyperlinks, but not the usual "blue+underlined" font.
So I created a modified font style based on the "Hyperlink" style, and applied
that style to the TOC. 

If I start the "Insert Index/Table" window, go to "Entries" tab, and click on
the "LS" button, the "Character style" field shows the name of the new style I
created.

In the original PC, where I created the document, the TOC entries appear in
brown, without hyperlinks.

But I saved the document and opened it on a different PC, to edit it further. To
my surprise, the TOC appears in the default "blue+underlined" font. But the new
style *is* listed in the second PC.

So it seems that the user-created style is saved with a DOC file, but not
applied to TOC when the same document is opened in another PC. 

I have not tried this experiment with other (paragraph, etc) styles in places
other than TOC, but that also could be defective.

Of course, while saving the file in the original PC, it does say that some
features will not be saved, etc. But I think this particular problem should not
be there, because I am saving the file in DOC format, and then if I reopen the
file in the original PC, it appears as desired. The problem is there only when I
open the file in my other PC.

Both PCs have Win XP, SP-2.
Comment 1 raindrops 2007-03-04 15:40:58 UTC
On closer inspection, this seems to be a lack of compatibility with MS Word (not
between different PCs). I saved the doc files, and closed the file. When I
reopened it on the **same** PC, the TOC had lost the formatting.

Comment 2 raindrops 2007-03-04 16:29:08 UTC
Note that I had started out he file as "doc" format itself.
Comment 3 raindrops 2007-03-05 02:28:01 UTC
No that does not convey what I had in mind. What I meant is-

If I am editing an EXISTING doc file, then logically I will continue using the
same format. Even then, OOo offers me its non-compatible features, and then
warns me at the very end of all editing that I will lose some of my changes (it
doesn't even tell me WHAT I will lose!).

It must not do this.

However, this *IS* acceptable if I have started out in Writer without specifying
a format (which means I could save the file in any of the listed formats at the
end of the session).

To sum up, when I am using a specified doc file, let Writer behave just like MS
Word, by either graying out the non-compatible features or removing them
altogether from the menus and toolbars.
Comment 4 michael.ruess 2007-03-06 11:37:19 UTC
Unfortunately, Writer will erroneously use always the "hyperlink" font when
importing such a TOC from MS Word format. See issue 29139.
The export works correctly here (the TOC MUST NOT be write-protected of course
before exporting), the TOC will look and work correctly in MS Word.

*** This issue has been marked as a duplicate of 29139 ***
Comment 5 michael.ruess 2007-03-06 11:38:49 UTC
Closing duplicate.