Issue 75101 - Docking a window is inconsistent
Summary: Docking a window is inconsistent
Status: CLOSED DUPLICATE of issue 34373
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 1.0.0
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: thorsten.martens
QA Contact: issues@framework
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-03-04 17:15 UTC by apaksi
Modified: 2007-03-11 17:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description apaksi 2007-03-04 17:15:55 UTC
For example, in Impress, when I undock the 'Slides' window at the left, it first
seems impossible to re-dock it again.

The only thing it says in the help is:
"To undock and re-dock, double-click a vacant area in the window. In the Styles
and Formatting window, you can also double-click a gray part of the window next
to the icons."

But this doesn't work. Then by playing with Google I found out that I actually
have to press CTRL while I double-click the title of the 'Slides' window.

So it took an hour away from my time to work with my presentation, and someone
who doesn't know how to use Google to figure this out still wouldn't have
figured it out...

My suggestion: Make the re-docking so that you can just drag-and-drop from the
title of the tool window to an edge of the main window.
Comment 1 ace_dent 2007-03-05 08:30:29 UTC
Hi apaksi ,

Thanks for the report. Clearly the help files in OOo should be updated if they
have the omission you suggested. However, I believe your difficulty in docking
may be a duplicate of Issue 34373, since OOo does allow you to drag-n-drop as
you described.

Please try the suggestions in #34373 using a more recent version of OOo (your
report is for v1). Can you also update the platform and OS on this Issue.

Cheers,
Andrew
Comment 2 kpalagin 2007-03-11 17:13:49 UTC
Confirming with 2.2RC1 on WinXP - with "Show window contents while dragging" 
NOT set it seems to be impossible to dock toolbar (without knowing Ctrl-Double 
Click trick).

If "Show window contents while dragging" is set then window docks just fin 
when mouse pointer reaches screen edge.

This issue seems to be dup of http://www.openoffice.org/issues/show_bug.cgi?
id=34373. Resolving as such (thanks Andrew!).

apaksi,
please reopen if you think 34373 is different. 
I also suggest voting for 34373.

*** This issue has been marked as a duplicate of 34373 ***
Comment 3 kpalagin 2007-03-11 17:14:20 UTC
and closing.