Issue 75136 - PDF page numbers incorrect
Summary: PDF page numbers incorrect
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 2.1
Hardware: PC Windows XP
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: oooqa
: 98586 98587 (view as issue list)
Depends on:
Blocks:
 
Reported: 2007-03-05 17:44 UTC by johnwcowan
Modified: 2017-05-20 10:35 UTC (History)
6 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---
hdu: 3.4_release_blocker-


Attachments
Demonstration ODT file for PDF page numbering bug (6.99 KB, application/vnd.oasis.opendocument.text)
2007-03-06 16:06 UTC, johnwcowan
no flags Details
Demonstration PDF generated from ODT file for PDF page numbering bug (19.22 KB, application/pdf)
2007-03-06 16:09 UTC, johnwcowan
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description johnwcowan 2007-03-05 17:44:54 UTC
Writer's PDF export function does not write the correct page numbers into the
generated PDF.  Instead, the pages are simply numbered from 1 on up.  The page
numbers specified in the page styles should be used instead.
Comment 1 michael.ruess 2007-03-06 08:03:07 UTC
Reassigned to HI.
Comment 2 h.ilter 2007-03-06 11:25:28 UTC
Please provide a sample to evaluate.
Comment 3 johnwcowan 2007-03-06 16:06:34 UTC
Created attachment 43550 [details]
Demonstration ODT file for PDF page numbering bug
Comment 4 johnwcowan 2007-03-06 16:09:21 UTC
Created attachment 43551 [details]
Demonstration PDF generated from ODT file for PDF page numbering bug
Comment 5 johnwcowan 2007-03-06 16:12:44 UTC
Here is an odt file with 4 pages numbered 1, 12, 13, and xxiii.  The resulting
PDF file contains a blank page between 13 and xxiii, per issue 35214, so the
pages are numbered 1-5.
Comment 6 lohmaier 2007-03-06 17:06:55 UTC
You should have taken the time to actually read the other issue.
That issue is flagged as duplicate of issue 3910 and that in turn includes 
a) The reason why that page is inserted
and
b) How this feature can be disabled.

Uncheck the option to export automatically generated blank pages and the PDF
will only have 4 pages.

Worksforme.
Comment 7 lohmaier 2007-03-06 17:07:27 UTC
closing issue.
Comment 8 johnwcowan 2007-03-06 18:24:18 UTC
This issue is *not* identical to issue 3910 (sorry for pointing to the wrong
issue).  The issue here is that in the generated PDF the pages are numbered 1-5
(or 1-4 if you check the box), whereas they should be numbered 1, 12, 13,
(possible blank page) and xxiii, following the ODT page numbers.  This refers
not to the page numbers displayed at the bottom of the page (which are of course
correct) but the page numbers you see in the PDF viewer's own controls.

http://www.planetpdf.com/enterprise/article.asp?ContentID=AddingPageNumbersinAcrobat7&gid=7009
discusses how to do this in Adobe Acrobat, which should be sufficient evidence
that the PDF format allows it.
Comment 9 kpalagin 2007-03-11 19:00:48 UTC
johnwcowan,
attached .pdf shows numbering just fine - 1, 12, 13, [blank], xxiii.
When I generate .pdf from your .odt the numbering is identical to 
attached .pdf.
I am using Acrobat Reader 7.0 to view the files.
Comment 10 johnwcowan 2007-03-13 07:38:48 UTC
kpalagin, I loaded Acrobat Reader 7.0 for Win32 to see what it showed.  It's
true (as I've been saying all along) that the page number on the bottom of each
page shows the correct page numbers, 1, 12, 13, (blank), xxiii.  That's the page
number as shown in the *text* of the document.

But if you look at the status bar in Acrobat Reader (below the image of the
page), it says "Page 1 of 5" (or whichever) in the center.  Or if you click on
the "Pages" tab to show thumbnails of each page, you'll see that they say 1
through 5.  Likewise, if you choose File Print, the page numbers the dialogue
box understands are 1 through 5.

*This is not a requirement of the PDF format.*  It can be changed using Acrobat
(the payware version), as explained in the page whose URL appears in my comment
above.  Therefore, it can be, and should be, generated directly into the PDF.

Please, someone, read my comments rather than just assuming I mean something
that I take great pains *not* to suggest.

Comment 11 h.ilter 2007-03-13 11:56:43 UTC
This sounds more like a enhancement and not as defect.
Therefore issueType changed.
Comment 12 michael.ruess 2009-01-30 13:38:06 UTC
*** Issue 98586 has been marked as a duplicate of this issue. ***
Comment 13 skelem 2009-01-30 19:32:40 UTC
Please implement this "enhancement".  It's normal for our group to be reviewing
subsets of a large document, distributed as PDF files. It makes it difficult to
coordinate and track comments when every document is numbered in the PDF
starting at page 1.  Sure, I could tell every one of my reviewers to ignore the
page number displayed prominently in acroread, and, instead, scroll around to
find the printed (logical) page number.

The original request for this important feature was made almost two years ago.
Please bump up the priority for this "enhancement".
Comment 14 Michael Osipov 2011-05-27 19:57:35 UTC
Ridiculous. Crucial PDF feature still open for 4 years.
Comment 15 Edwin Sharp 2014-03-21 12:13:04 UTC
Export as PDF OK
AOO410m14(Build:9760)  -  Rev. 1573601
2014-03-03 17:47:48 (Mo, 03 Mrz 2014)
Win 7
Comment 16 Edwin Sharp 2014-03-25 20:29:13 UTC
*** Issue 98587 has been marked as a duplicate of this issue. ***