Issue 75321 - Vertical text alignment in table within page-anchored frame is unintendently modified by print preview
Summary: Vertical text alignment in table within page-anchored frame is unintendently ...
Status: CLOSED DUPLICATE of issue 65391
Alias: None
Product: Writer
Classification: Application
Component: viewing (show other issues)
Version: OOo 2.1
Hardware: All Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-12 15:25 UTC by s_oenke
Modified: 2007-03-12 16:48 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
OOo document for testing defect (7.16 KB, application/vnd.sun.xml.writer)
2007-03-12 15:28 UTC, s_oenke
no flags Details
Snapshot showing settings in edit view (88.88 KB, image/png)
2007-03-12 15:28 UTC, s_oenke
no flags Details
Snapshot showing defect in print preview (57.78 KB, image/png)
2007-03-12 15:29 UTC, s_oenke
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description s_oenke 2007-03-12 15:25:34 UTC
This issue was discussed in OOo-Writer-Forum as 'Vertical text alignment in
table in frame, anchored to page'.
Issue 27428 may be related to this.

When using a table within a page-anchored frame, I experienced some strange
behaviour concerning the vertical alignment of the text. This effect will only
be visible, if one column has a different font size than the other(s).

Steps to reproduce:
- Create a new document
- Create a frame, make sure it's anchored to 'page'
- Insert a 2x2 table into frame
- Write some text into the four cells and make sure, all cells/columns are
vertical aligned to 'Bottom'
- Select a column and change its font size (to a smaller font)

- NOW: When you change to print preview (both 'File->Print preview' or 'icon
with magnifying glass'), one can see that the smaller text jumps to top, i.e.
the 'bottom' setting is ignored (BTW same for 'center'). In addition, it will be
printed this way as well.

Note, that you can deactivate this behaviour by choosing a different anchoring
method other than 'page'. AND the document will be printed correctly, if you
skip the preview, i.e. just File->Print or using the appropriate button.

Furthermore, you experience some interesting sideeffects, when having the frame
page-anchored and the text bottom-aligned: Sometimes the written text is visible
twice and the system hangs some seconds, when coming back from print preview.
When you click into the text in order to modify it, the text jumps back in place.
Comment 1 s_oenke 2007-03-12 15:28:04 UTC
Created attachment 43662 [details]
OOo document for testing defect
Comment 2 s_oenke 2007-03-12 15:28:59 UTC
Created attachment 43663 [details]
Snapshot showing settings in edit view
Comment 3 s_oenke 2007-03-12 15:29:42 UTC
Created attachment 43664 [details]
Snapshot showing defect in print preview
Comment 4 michael.ruess 2007-03-12 16:47:33 UTC
Known problem.

*** This issue has been marked as a duplicate of 65391 ***
Comment 5 michael.ruess 2007-03-12 16:48:22 UTC
Closing duplicate.