Issue 75422 - macro Recorder does not repeat results of the recording
Summary: macro Recorder does not repeat results of the recording
Status: CLOSED DUPLICATE of issue 20046
Alias: None
Product: Writer
Classification: Application
Component: programming (show other issues)
Version: OOo 2.1
Hardware: All All
: P3 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: joerg.skottke
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks: 81517
  Show dependency tree
 
Reported: 2007-03-15 11:51 UTC by alandavidson
Modified: 2008-05-30 11:40 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description alandavidson 2007-03-15 11:51:03 UTC
I want to produce a frame 15 cm wide with no border. The macro below does
exactly what I want during the recording. However, when running the macro, the
frame always has a border. The results have been replicated by exactt, another
forum user.

Here are the steps:

1) Tools > Macros > Record Macro 
2) Insert > Frame 
3) In the Type tab, enter 15 for width. 
4) In the Borders tab, select None in Line Style 
5) Click OK. 
The correct frame is produced. 
6) Click Stop Recording 

Here is the macro:
rem ----------------------------------------------------------------------
sub InsertFrame
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem ----------------------------------------------------------------------
dim args1(4) as new com.sun.star.beans.PropertyValue
args1(0).Name = "AnchorType"
args1(0).Value = 0
args1(1).Name = "Pos.X"
args1(1).Value = 0
args1(2).Name = "Pos.Y"
args1(2).Value = 0
args1(3).Name = "Size.Width"
args1(3).Value = 15000
args1(4).Name = "Size.Height"
args1(4).Value = 499
dispatcher.executeDispatch(document, ".uno:InsertFrame", "", 0, args1())
end sub
Comment 1 michael.ruess 2007-03-15 11:57:45 UTC
Reassigned to JSK.
Comment 2 kpalagin 2007-03-20 20:46:15 UTC
Confirming with 2.2 RC2.
Issue http://www.openoffice.org/issues/show_bug.cgi?id=68515 seems to be 
related.
Comment 3 joerg.skottke 2007-11-28 12:05:41 UTC
Dupe to - yes, just one more of these macro recorder things that do not work...

*** This issue has been marked as a duplicate of 20046 ***
Comment 4 joerg.skottke 2008-05-30 11:40:45 UTC
close