Issue 75667 - Title box does not follow rotation of background "title area".
Summary: Title box does not follow rotation of background "title area".
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.2
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-23 09:39 UTC by keme6206
Modified: 2017-05-20 11:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Template with the undesired behaviour (15.46 KB, text/plain)
2007-03-23 09:51 UTC, keme6206
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description keme6206 2007-03-23 09:39:11 UTC
Using OpenOffice 2.1, Norwegian language version (forgive me if I'm guessing 
wrong on the english menu titles), I am creating a new presentation template. 
I want the slide title text to run on the left edge of the slide, rotated 90 
degrees (i.e. reading direction from bottom to top, the top of the letters 
pointing leftward).
- I open the main slide layout view (View, Background, Slide layout)
- I rotate the title area 90 degrees and move/resize it to fit snugly across 
the left side of the slide.
Everything looks fine, with the prompt text rotated as expected. Saving and 
reopening the template doesn't change the look of it. 

Creating a presentation based on my template, all slides get the title box 
below the slide. The top left corner of the title is correctly positioned at 
the bottom left corner of the slide. 

If I rotate the title 90 degrees, using the top left corner for the pivot 
point, it fits perfectly. Hence, I conclude that positioning uses top left 
corner for anchoring of boxes, and rotation of background areas does not 
propagate to the boxes/fields put on that area. 

This may be intended behaviour, or the support of rotated background areas is 
perhaps not intended. Anyway, it seems strange. Requested behaviour - 
alternatives in order of priority (my priority):
- Rotation of background area propagates to objects anchored in the area. 
(This may have undesired side effects on previously created templates, which 
may rely on the current behaviour, so a choice of "old or new behaviour" may 
be useful.)
- Anchoring in the "box center", so the title is visible to the user, and the 
default pivot point is the correct one.
- Disallow rotation of the background box.
Comment 1 wolframgarten 2007-03-23 09:43:57 UTC
Reassigned.
Comment 2 keme6206 2007-03-23 09:51:13 UTC
Created attachment 43884 [details]
Template with the undesired behaviour
Comment 3 keme6206 2007-03-23 12:42:27 UTC
Forgot to mention: OS platform I am using is Windows XP pro SP2, Norwegian 
language version.
Comment 4 christian.guenther 2007-03-30 14:33:37 UTC
Set to new and change the target
Comment 5 christian.guenther 2007-03-30 14:34:57 UTC
I can reproduce the bug.
Important is that you change the position and rotation of the title object on
the slide master.
Please have a look.
Comment 6 keme6206 2007-04-01 21:54:10 UTC
Moving and rotating the title field helps for the slides "ready made" in the 
template, so this would work for presentation content templates, or wizards. 
What I want to do is creating a basic slide template for the users to make new 
slides from. 
I moved/rotated the title placeholder, and expected the title field to follow 
the placeholder. It does move correctly, but does not rotate. 
Am I missing something here? 
As for "guessing wrong" on my initial posting: From instructions in the help 
system, I found that my guess "View, Background, Slide layout" is in 
fact "View, Master, Slide master". Sorry!
Comment 7 keme6206 2007-05-02 11:12:07 UTC
Behaviour confirmed with version 2.2
Comment 8 rene 2010-05-21 01:20:09 UTC
.
Comment 9 Marcus 2017-05-20 11:08:35 UTC
Reset assigne to the default "issues@openoffice.apache.org".