Issue 75912 - doesn't work well with embedded archive viewer from KDE
Summary: doesn't work well with embedded archive viewer from KDE
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 2.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2007-03-30 12:35 UTC by tfoerste
Modified: 2017-05-20 11:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Illustrating screenshot. (125.36 KB, image/png)
2007-03-31 12:57 UTC, kpalagin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tfoerste 2007-03-30 12:35:23 UTC
This is a regerssion from app-office/openoffice-bin-2.1.0 under stable Gentoo Linux:

I have local zip files, containing csv files. The csv suffix is re-assigned
from oocalc2 to oocalc.

If I open a csv file within konqueror it works fine.

If I open a zip-archive with ark, then I can click onto a csv file and it will
be opened.

If I browse the archive using the embedded archive viewer of konqueror I can
click onto a csv file and see the splash screen of ooffice for a short time,
but the file isn't opened with oocalc :-(
Comment 1 kpalagin 2007-03-31 12:55:36 UTC
Confirming with 2.0.4 (Novell's build) on Suse 10.2 KDE - see attached 
Comment 2 kpalagin 2007-03-31 12:57:05 UTC
Created attachment 44094 [details]
Illustrating screenshot.
Comment 3 tfoerste 2007-04-01 11:14:58 UTC
Right, 2.1 solved this issue from 2.0.4, but now this bug happens again :-(

BTW another effect of this bug is that you cannot open a csv file from a remote
directory mounted within konqueror using the fish protocol (underlaying is a ssh

It looks like a bug in temp file name handling of OO, isn't it ?
Comment 4 thorsten.martens 2007-04-02 13:03:03 UTC
TM->MAV: please have a look.
Comment 5 mikhail.voytenko 2007-04-02 13:59:50 UTC
According to the screenshot  provided by kpalagin, it looks like the tools
requests OOo to open the document using "zip:/<path>" URL, and the office can
not open the document. Usually in this case, the system handler should be used
to open the URL. But it looks indeed as the fixed already problem with external

Could you please provide more details, how does the office behave itself in the
originally described scenario.
Is there a kind of error-message ( something like in the screenshot from
kpalagin )? Or the file is open in writer application? Is the problem
reproducible only with ".csv" files?
Comment 6 tfoerste 2007-04-02 14:51:41 UTC
>reproducible only with ".csv" files?
no, same issue with doc files.

In general :
- local OO files can be opened faster than before :-)
- archived files (I tested it with zips) can only be open from within an
archive, if the content of the zip zip file itself is viewed by ark and not
within the internal viewer of konqueror)
- remotly stored OO files at a fish:// mounted dir cannot be opened, only the
splash screen is visible for a short time period, that's all.
Comment 7 tfoerste 2007-04-03 16:26:43 UTC
Issue solved for me by removing "%U" from the KDE link.
Comment 8 mikhail.voytenko 2007-04-16 13:30:06 UTC
mav->tfoerste: Sorry, I didn't understand the last your comment. Which KDE link
do you mean?
Comment 9 tfoerste 2007-04-16 13:43:37 UTC
Sorry, I meant the shortcut /
Comment 10 mikhail.voytenko 2007-04-16 14:01:28 UTC
mav->tfoerste: Thank you for the quick answer.
mav->ihi: Looks to be a system integration problem. Sending to you as discussed.
Comment 11 ivo.hinkelmann 2007-04-17 11:30:13 UTC
Cloth, can we remove those %U's from the *.desktop files?
Comment 12 Marcus 2017-05-20 11:31:36 UTC
Reset assigne to the default "".