Issue 75922 - pasting drawing group into middleof document gives wrong size&position
Summary: pasting drawing group into middleof document gives wrong size&position
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.2
Hardware: PC Windows 2000
: P4 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2007-03-30 15:08 UTC by honza_k
Modified: 2017-05-20 11:19 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
The schematics file with the graphics (11.97 KB, application/vnd.sun.xml.draw)
2007-03-30 15:10 UTC, honza_k
no flags Details
The Write document to demonstrate the paste error (22.01 KB, application/vnd.sun.xml.writer)
2007-03-30 15:11 UTC, honza_k
no flags Details
The DXF file from which the schematics.odg was created (54.50 KB, application/octet-stream)
2007-03-30 15:25 UTC, honza_k
no flags Details
Screenshot (35.11 KB, image/png)
2007-03-31 15:02 UTC, kpalagin
no flags Details
Pastes in the last and before pages. See screenshot. (69.80 KB, image/png)
2007-04-01 15:38 UTC, kpalagin
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description honza_k 2007-03-30 15:08:42 UTC
I have a Czech version of OpenOffice 2.2 that I downloaded very recently from a
link from www.openoffice.cz. I have MS Windows 2000 Proffessional, Czech
version, running on a standard PC.

I imported a DXF file created in a schematics editting software into a OODraw.
The file was imported without problems and the graphics looks as it should. I
modified it a little and then I wanted to paste the resulting drawing to an
existing OOWrite document using a Copy - Paste method.

However, I could not paste the graphics. Instead of it, the OOWrite only jumped
to another page (about in the middle of a document) and no graphics appeared.

Interesting is, that when I paste the drawing into an empty OOWrite document, it
works. Also I found an interesting behavior: The longer the OOWrite document is,
the larger (higher) the boundary frame of the drawing is - I get a lot of extra
space above and to the left of the drawing. And finally, when the document
exceeds about 6 pages, the drawing will not paste anymore.

When I take any other drawing that I create directly in OODraw or import using
WMF file, the pasting works without problems. So this issue might be a result of
a fact that the file was imported from DXF.

I will try to add two attachments:

Lorem_Ipsum.odt - the text document
schematics.odg - the graphics

How to reproduce the error:

1. Open the Lorem_Ipsum in OOWrite and schematics in OODraw.
2. Select the entire drawing using a mouse, and right-click Copy
3. Place the cursor somewhere to the middle of the Lorem_Ipsum document, and
right-click Paste
4. The OOWrite will jump out of the cursor location, and you will not be able to
see the graphics.

Now shorten the Lorem_Ipsum to one page only, and repeat the process. You will
see that the graphics will paste, but its boundary will be about twice as high
as the height of the graphics itself.

And finally, make a new document and paste the graphics. It will paste without
problems.

I hope this helps you to resolve the problem.

Jan Kratky
Czech Republic
Comment 1 honza_k 2007-03-30 15:10:15 UTC
Created attachment 44070 [details]
The schematics file with the graphics
Comment 2 honza_k 2007-03-30 15:11:14 UTC
Created attachment 44071 [details]
The Write document to demonstrate the paste error
Comment 3 honza_k 2007-03-30 15:23:20 UTC
I found one interesting thing: My graphics includes a blue circle (a schematics
for a Voltmeter, that consists of a circle with "V"). When I erase this circle
(it was left originally as it was imported from DXF) and replace it with a same
looking circle that I create manually using OODraw, then the pasting starts to
work!!!!

So this issue might have something in common with importing circles from DXF.

For your help I attach the DXF file from which I imported this graphics ... The
DXF file contains more schematics, so after importing to OODraw, I separated it
into objects (it was imported as one group) and chose the lower left schematics,
copied, and pasted to a new document - and that was how the "schematics"
document was created ...
Comment 4 honza_k 2007-03-30 15:25:18 UTC
Created attachment 44072 [details]
The DXF file from which the schematics.odg was created
Comment 5 kpalagin 2007-03-31 15:01:24 UTC
honza_k,
pastes with 2.2 on WinXP just fine - see attached screenshot.
I selected the shapes in drawing by dragging the mouse over them, Edit - Copy, 
switched to Writer and pasted.
Comment 6 kpalagin 2007-03-31 15:02:30 UTC
Created attachment 44098 [details]
Screenshot
Comment 7 honza_k 2007-04-01 07:01:30 UTC
To kpalagin:

Yes, this way it works. But try to paste it to somewhere farther to the
document. You pasted it to the very begin. See my step no. 2 - place your cursor
somewhere in the middle of the document. 

So please try for example the last page ...
Comment 8 kpalagin 2007-04-01 15:38:10 UTC
Created attachment 44130 [details]
Pastes in the last and before pages. See screenshot.
Comment 9 honza_k 2007-04-01 17:23:51 UTC
OK ...

so I tried it once again ... when I opened only the schematics and the text, it
worked, to my great surprise. I was shocked ... But I played with it, because I
was sure about this bug, (I fought with it last friday for about 2 hours) and
discovered how it works exactly and what exactly you have to do:

I found that YOU HAVE TO IMPORT THE DXF, to get this bug appear. If you don't do
the import, everything works!!

So I change the steps as follows:

1. Save the attached DXF file to your disk.
2. Open the OODraw (create an empty document from the QuickStart Icon)
3. In the OODraw, choose Open, select filetype DXF, and open the file
4. You will see three schematics in one group
5. Right-click on it and separate the group
6. As a side-effect, you will see that the texts move (it's a subject of my
issue #75928)
7. Open the OOWrite document (Lorem Ipsum) :-)
8. Go to OODraw, select the lower left schematics with the mouse and right-click
Copy
9. Go to the OOWrite and paste ...
10. The OOWrite jumps to another page, and you will see a "lonely" anchor icon
and the green boundary squares will be each at different pages than the anchor
... However, you will not be able to find the image!

If you paste the image to the very begin of the document, you will see the
image, but its boundary will be about 4-times bigger than the image itself.

This way it works today. It is interesting that the error persisted even when I
closed all the documents, so I did not have any OpenOffice program opened, and
then when I tried it again (without Windows restart), the bug was still there.
Today I started my computer (it was off during the day) and saw the same
behavior as the user "kpalagin" did ... As soon as I did the import of the DXF,
the bug began to "work" and until you restart your system, it will remain there.
Comment 10 kpalagin 2007-04-01 18:48:32 UTC
Confirming with 2.2m8 on WinXP using last repro steps from honza_k - make sure 
you paste drawing somewhere on the last page.
Comment 11 michael.ruess 2007-04-02 11:51:09 UTC
MRU->OD: to be reproduced, here are the steps as summary
- open the attached DXF in OOo Draw, select the graphic, from context select
"Break" and de-select
- with mouse, select the the lower left diagram and copy to Clipboard
- In a new Writer document create six page breaks and paste the object
-> view jumps, object seems to have exorbitant size.
Does not happen, when the object is pasted into first page
Comment 12 Oliver-Rainer Wittmann 2007-07-27 14:28:36 UTC
due to lack of resources I have to re-target this issue to OOo 2.x
Comment 13 Mathias_Bauer 2007-12-04 13:16:06 UTC
target 3.x
Comment 14 Marcus 2017-05-20 11:19:41 UTC
Reset assigne to the default "issues@openoffice.apache.org".