Issue 75935 - moving cells (drag/drop) destroys formatting of source cell
Summary: moving cells (drag/drop) destroys formatting of source cell
Status: CLOSED DUPLICATE of issue 8461
Alias: None
Product: Calc
Classification: Application
Component: formatting (show other issues)
Version: OOo 2.2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@sc
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-30 21:09 UTC by titusopen
Modified: 2007-04-11 11:43 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description titusopen 2007-03-30 21:09:52 UTC
If you highlight a cell and move the content to another cell with drag/drop, the
formatting of the source cell is being destroyed (set back to default). That is
annoying, I would expect the source cell to remain in the format it had before
the drag/drop. It becomes especially obvious when you have formatted with
another font size than the default size.

My (annoying) workaround is to just copy the cells to another place and then
highlight the source cells and delete the content by simply hitting the delete
button. Doing it this way doesn't touch the source cell's format.

I love Open Office and thank you in advance for your efforts!
Titus
Comment 1 kpalagin 2007-04-02 13:48:55 UTC
Confirming with 2.2m7 on WinXP.
Repro steps:
1. Start Calc, type random text in cell A1.
2. Apply random color (say red) to this cell.
3. Select this cell and move (using D&D) to A2.
4. Type something in A1 - text will have default color.
Comment 2 frank 2007-04-11 11:42:43 UTC
Hi,

this is a double to Issue 8461 .

Frank

*** This issue has been marked as a duplicate of 8461 ***
Comment 3 frank 2007-04-11 11:43:07 UTC
closed double