Issue 76324 - Editing: end-of-line cursor doesn't move with added spaces
Summary: Editing: end-of-line cursor doesn't move with added spaces
Status: CLOSED DUPLICATE of issue 20878
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 2.2
Hardware: PC Windows XP
: P4 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2007-04-12 19:29 UTC by candacevan
Modified: 2007-04-12 20:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description candacevan 2007-04-12 19:29:48 UTC
I am running the Writer module of OO 2.2.0 on Windows XP Pro. To observe this
bug, you'll need any Writer document containing a paragraph that is two or more
lines long. 

In using the Writer module, if I go back to edit existing text and I place the
cursor at the end of a line (but _not_ the end of the paragraph or at the end of
the last line in the paragraph) and I type one or more spaces, the cursor does
not change its position appropriately. If I then type a character, the cursor
moves to the appropriate position. So, the spaces are being tracked -- they are
just not reflected in the cursor's position.

For example, suppose this were a paragraph (x's are letters, / is cursor) and I
placed the cursor as illustrated:
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/
xxxxxxxxxxxxxxxxxxxxxxxxxx

Now I type two spaces. I don't see this:
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx  /
xxxxxxxxxxxxxxxxxxxxxxxxxx

I see this:
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx/
xxxxxxxxxxxxxxxxxxxxxxxxxx

But if I then type a new letter (represented by y), I see
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx  y/
xxxxxxxxxxxxxxxxxxxxxxxxxx

So, the application is keeping track of those spaces, but the cursor is not
moving as though they were there.
Comment 1 Regina Henschel 2007-04-12 20:58:04 UTC
Yes, a known problem, see issue 20878. Perhaps you vote for it.

*** This issue has been marked as a duplicate of 20878 ***
Comment 2 Regina Henschel 2007-04-12 20:58:40 UTC
closing duplicat